aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2011-11-14 21:47:47 +0000
committerJohan van Selst <johans@FreeBSD.org>2011-11-14 21:47:47 +0000
commitc8144eafb489a824f1e279f7dfb9cfd84cffc336 (patch)
treeb517e7de29a830c3f13e765fcc338913f91282d8 /archivers
parent34df09046fc692c7a987dec8a1a44efa9407c2c0 (diff)
downloadports-c8144eafb489a824f1e279f7dfb9cfd84cffc336.tar.gz
ports-c8144eafb489a824f1e279f7dfb9cfd84cffc336.zip
Fix conflicting glob_t definitions, which triggered a crash
when importing the rpm4 module in Python. PR: ports/162483 Submitted by: Sean Mitchell <smitchell@hcn-inc.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=285796
Diffstat (limited to 'archivers')
-rw-r--r--archivers/rpm4/Makefile1
-rw-r--r--archivers/rpm4/files/patch-misc_glob.h18
2 files changed, 19 insertions, 0 deletions
diff --git a/archivers/rpm4/Makefile b/archivers/rpm4/Makefile
index 363b19bce3c2..581bcce45851 100644
--- a/archivers/rpm4/Makefile
+++ b/archivers/rpm4/Makefile
@@ -6,6 +6,7 @@
PORTNAME= rpm
PORTVERSION= 4.9.1.2
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= http://rpm.org/releases/rpm-${PORTVERSION:R:R}.x/ \
ftp://ftp.mirrorservice.org/sites/ftp.rpm.org/pub/rpm/dist/rpm-${PORTVERSION:E}.x/
diff --git a/archivers/rpm4/files/patch-misc_glob.h b/archivers/rpm4/files/patch-misc_glob.h
new file mode 100644
index 000000000000..6d8b056c8d48
--- /dev/null
+++ b/archivers/rpm4/files/patch-misc_glob.h
@@ -0,0 +1,18 @@
+--- misc/glob.h.orig 2011-11-14 22:06:03.000000000 +0100
++++ misc/glob.h 2011-11-14 22:07:01.000000000 +0100
+@@ -110,10 +110,11 @@
+ #endif
+ typedef struct
+ {
+- __size_t gl_pathc; /* Count of paths matched by the pattern. */
+- char **gl_pathv; /* List of matched pathnames. */
+- __size_t gl_offs; /* Slots to reserve in `gl_pathv'. */
+- int gl_flags; /* Set to FLAGS, maybe | GLOB_MAGCHAR. */
++ __size_t gl_pathc; /* Count of total paths so far. */
++ __size_t gl_matchc; /* Count of paths matching pattern. */
++ __size_t gl_offs; /* Reserved at beginning of gl_pathv. */
++ int gl_flags; /* Copy of flags parameter to glob. */
++ char **gl_pathv; /* List of paths matching pattern. */
+
+ /* If the GLOB_ALTDIRFUNC flag is set, the following functions
+ are used instead of the normal file access functions. */