aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2024-01-12 15:09:46 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2024-01-12 15:11:29 +0000
commitd4329229fbe8ad0a96a1b9ec796d17cf512455d1 (patch)
treebafbd1ae43d70259bde776544f2f6a47cfa33dfc /archivers
parent23d0853a55a12096d3ffae672925a3ded9647fe0 (diff)
downloadports-d4329229fbe8ad0a96a1b9ec796d17cf512455d1.tar.gz
ports-d4329229fbe8ad0a96a1b9ec796d17cf512455d1.zip
MANPREFIX: eliminate its usage
While here move manpages to share/man
Diffstat (limited to 'archivers')
-rw-r--r--archivers/amigadepacker/Makefile5
-rw-r--r--archivers/lbrate/Makefile6
-rw-r--r--archivers/lha-ac/Makefile11
-rw-r--r--archivers/lziprecover/Makefile5
-rw-r--r--archivers/opkg-openwrt/Makefile4
-rw-r--r--archivers/opkg-openwrt/pkg-plist4
-rw-r--r--archivers/packddir/Makefile5
-rw-r--r--archivers/pixz/Makefile5
-rw-r--r--archivers/ppmd/Makefile5
-rw-r--r--archivers/tardy/Makefile6
-rw-r--r--archivers/unarchiver/Makefile6
-rw-r--r--archivers/zip/Makefile8
12 files changed, 38 insertions, 32 deletions
diff --git a/archivers/amigadepacker/Makefile b/archivers/amigadepacker/Makefile
index 2a2e6ffc1992..977b39b22899 100644
--- a/archivers/amigadepacker/Makefile
+++ b/archivers/amigadepacker/Makefile
@@ -1,5 +1,6 @@
PORTNAME= amigadepacker
PORTVERSION= 0.04
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= http://zakalwe.fi/~shd/foss/amigadepacker/ \
LOCAL/ehaupt
@@ -17,10 +18,10 @@ USE_CSTD= gnu89
CONFIGURE_ARGS+= --prefix=${PREFIX}
ALL_TARGET= ${PORTNAME}
-PLIST_FILES= bin/amigadepacker man/man1/amigadepacker.1.gz
+PLIST_FILES= bin/amigadepacker share/man/man1/amigadepacker.1.gz
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}/${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${PREFIX}/share/man/man1
.include <bsd.port.mk>
diff --git a/archivers/lbrate/Makefile b/archivers/lbrate/Makefile
index d74fbd0db988..6dfef5220624 100644
--- a/archivers/lbrate/Makefile
+++ b/archivers/lbrate/Makefile
@@ -1,6 +1,6 @@
PORTNAME= lbrate
PORTVERSION= 1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= archivers
MASTER_SITES= SUNSITE/utils/compress
@@ -15,13 +15,13 @@ MAKE_ARGS= CC="${CC}" CFLAGS="${CPPFLAGS} ${CFLAGS} ${LDFLAGS}"
PORTDOCS= ChangeLog README TODO
PLIST_FILES= bin/lbrate \
- man/man1/lbrate.1.gz
+ share/man/man1/lbrate.1.gz
OPTIONS_DEFINE= DOCS
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/lbrate ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/lbrate.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/lbrate.1 ${STAGEDIR}${PREFIX}/share/man/man1
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/archivers/lha-ac/Makefile b/archivers/lha-ac/Makefile
index 912614e452bf..dc70c35958fd 100644
--- a/archivers/lha-ac/Makefile
+++ b/archivers/lha-ac/Makefile
@@ -1,5 +1,6 @@
PORTNAME= lha
PORTVERSION= 1.14i.20211125
+PORTREVISION= 1
CATEGORIES= archivers
PKGNAMESUFFIX= -ac
@@ -25,17 +26,17 @@ GNU_CONFIGURE= yes
TEST_TARGET= check
PLIST_FILES= bin/lha-ac \
- man/ja/man1/lha-ac.1.gz \
- man/man1/lha-ac.1.gz
+ share/man/ja/man1/lha-ac.1.gz \
+ share/man/man1/lha-ac.1.gz
OPTIONS_DEFINE= NLS
NLS_CONFIGURE_ON= --enable-multibyte-filename=auto
NLS_CONFIGURE_OFF= --disable-multibyte-filename
do-install:
- -${MKDIR} ${STAGEDIR}${MANPREFIX}/man/ja/man1
+ -${MKDIR} ${STAGEDIR}${PREFIX}/share/man/ja/man1
${INSTALL_PROGRAM} ${WRKSRC}/src/lha ${STAGEDIR}${PREFIX}/bin/lha-ac
- ${INSTALL_MAN} ${WRKSRC}/man/lha.1 ${STAGEDIR}${MANPREFIX}/man/man1/lha-ac.1
- ${INSTALL_MAN} ${WRKSRC}/man/lha.n ${STAGEDIR}${MANPREFIX}/man/ja/man1/lha-ac.1
+ ${INSTALL_MAN} ${WRKSRC}/man/lha.1 ${STAGEDIR}${PREFIX}/share/man/man1/lha-ac.1
+ ${INSTALL_MAN} ${WRKSRC}/man/lha.n ${STAGEDIR}${PREFIX}/share/man/ja/man1/lha-ac.1
.include <bsd.port.mk>
diff --git a/archivers/lziprecover/Makefile b/archivers/lziprecover/Makefile
index 016548653dc4..8e0711f80c04 100644
--- a/archivers/lziprecover/Makefile
+++ b/archivers/lziprecover/Makefile
@@ -1,5 +1,6 @@
PORTNAME= lziprecover
PORTVERSION= 1.23
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= SAVANNAH/lzip/${PORTNAME}
@@ -12,11 +13,11 @@ LICENSE= GPLv2+
USES= tar:lz
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --infodir=${PREFIX}/${INFO_PATH} \
- --mandir=${MANPREFIX}/man CXXFLAGS="${CXXFLAGS}"
+ --mandir=${PREFIX}/share/man CXXFLAGS="${CXXFLAGS}"
TEST_TARGET= check
INFO= ${PORTNAME}
-PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
+PLIST_FILES= bin/${PORTNAME} share/man/man1/${PORTNAME}.1.gz
PORTDOCS= AUTHORS ChangeLog NEWS README
OPTIONS_DEFINE= DOCS
diff --git a/archivers/opkg-openwrt/Makefile b/archivers/opkg-openwrt/Makefile
index 5e2e88531ed5..f7182a39bc79 100644
--- a/archivers/opkg-openwrt/Makefile
+++ b/archivers/opkg-openwrt/Makefile
@@ -1,6 +1,6 @@
PORTNAME= opkg
DISTVERSION= 20180803
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= archivers sysutils
PKGNAMESUFFIX= -openwrt
@@ -46,7 +46,7 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/utils/opkg-key ${STAGEDIR}${PREFIX}/bin
.for file in opkg-cl.1 opkg-key.1
${INSTALL_MAN} ${WRKSRC}/man/${file}.in \
- ${STAGEDIR}${MANPREFIX}/man/man1/${file}
+ ${STAGEDIR}${PREFIX}/share/man/man1/${file}
.endfor
.include <bsd.port.post.mk>
diff --git a/archivers/opkg-openwrt/pkg-plist b/archivers/opkg-openwrt/pkg-plist
index edb4707c1daa..4ee61effa01d 100644
--- a/archivers/opkg-openwrt/pkg-plist
+++ b/archivers/opkg-openwrt/pkg-plist
@@ -1,4 +1,4 @@
bin/opkg-cl
bin/opkg-key
-man/man1/opkg-cl.1.gz
-man/man1/opkg-key.1.gz
+share/man/man1/opkg-cl.1.gz
+share/man/man1/opkg-key.1.gz
diff --git a/archivers/packddir/Makefile b/archivers/packddir/Makefile
index 95fa649fc8bf..2b9be5999164 100644
--- a/archivers/packddir/Makefile
+++ b/archivers/packddir/Makefile
@@ -1,5 +1,6 @@
PORTNAME= packddir
PORTVERSION= 0.0.6
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= SAVANNAH
DISTNAME= upackddir_${PORTVERSION}-1
@@ -14,14 +15,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING
WRKSRC= ${WRKDIR}/src
PLIST_FILES= bin/upackddir \
- man/man1/upackddir.1.gz
+ share/man/man1/upackddir.1.gz
MAKE_ARGS= CC="${CC}"
post-patch:
${REINPLACE_CMD} -e 's|$$(DESTDIR)/usr|$$(DESTDIR)${PREFIX}|' ${WRKSRC}/Makefile
post-install:
- ${INSTALL_MAN} ${WRKSRC}/upackddir.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/upackddir.1 ${STAGEDIR}${PREFIX}/share/man/man1
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/upackddir
.include <bsd.port.mk>
diff --git a/archivers/pixz/Makefile b/archivers/pixz/Makefile
index 9ce95ae48bcf..f47386a85ea6 100644
--- a/archivers/pixz/Makefile
+++ b/archivers/pixz/Makefile
@@ -1,5 +1,6 @@
PORTNAME= pixz
DISTVERSION= 1.0.7
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= https://github.com/vasi/${PORTNAME}/releases/download/v${DISTVERSION}/
@@ -14,9 +15,9 @@ USES= libarchive pkgconfig tar:xz
GNU_CONFIGURE= yes
-PLIST_FILES= bin/${PORTNAME} man/man1/pixz.1.gz
+PLIST_FILES= bin/${PORTNAME} share/man/man1/pixz.1.gz
post-install:
- ${INSTALL_MAN} ${WRKSRC}/src/pixz.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/src/pixz.1 ${STAGEDIR}${PREFIX}/share/man/man1
.include <bsd.port.mk>
diff --git a/archivers/ppmd/Makefile b/archivers/ppmd/Makefile
index cabc28fccc21..80fc1b735d43 100644
--- a/archivers/ppmd/Makefile
+++ b/archivers/ppmd/Makefile
@@ -1,5 +1,6 @@
PORTNAME= ppmd
PORTVERSION= 20050811
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= LOCAL/ehaupt
@@ -14,13 +15,13 @@ USES= cpe
CPE_VENDOR= ppmd_project
PORTDOCS= read_me.txt
-PLIST_FILES= bin/ppmd man/man1/ppmd.1.gz
+PLIST_FILES= bin/ppmd share/man/man1/ppmd.1.gz
OPTIONS_DEFINE= DOCS
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${PREFIX}/share/man/man1
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
diff --git a/archivers/tardy/Makefile b/archivers/tardy/Makefile
index 56044b067747..311abe848371 100644
--- a/archivers/tardy/Makefile
+++ b/archivers/tardy/Makefile
@@ -1,7 +1,7 @@
PORTNAME= tardy
PORTVERSION= 1.28
DISTVERSIONSUFFIX= .D001.orig
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= archivers
MASTER_SITES= SF/tardy/${PORTVERSION}/
DISTNAME= ${PORTNAME}_${PORTVERSION}${DISTVERSIONSUFFIX}
@@ -24,7 +24,7 @@ MAKE_JOBS_UNSAFE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_FILES= bin/tardy man/man1/tardy.1.gz
+PLIST_FILES= bin/tardy share/man/man1/tardy.1.gz
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -38,6 +38,6 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/man1/${PORTNAME}.1 \
- ${STAGEDIR}${MANPREFIX}/man/man1
+ ${STAGEDIR}${PREFIX}/share/man/man1
.include <bsd.port.mk>
diff --git a/archivers/unarchiver/Makefile b/archivers/unarchiver/Makefile
index 6d2a76ca3a2a..a2a1b639ac4f 100644
--- a/archivers/unarchiver/Makefile
+++ b/archivers/unarchiver/Makefile
@@ -1,6 +1,6 @@
PORTNAME= unar
PORTVERSION= 1.10.1
-PORTREVISION= 24
+PORTREVISION= 25
CATEGORIES= archivers gnustep
MASTER_SITES= http://wakaba.c3.cx/releases/TheUnarchiver/
DISTNAME= ${PORTNAME}${PORTVERSION}_src
@@ -23,7 +23,7 @@ MAKEFILE= Makefile.freebsd
WRKSRC= ${WRKDIR}/The\ Unarchiver
BUILD_WRKSRC= ${WRKSRC}/XADMaster
-PLIST_FILES= bin/lsar bin/unar man/man1/lsar.1.gz man/man1/unar.1.gz
+PLIST_FILES= bin/lsar bin/unar share/man/man1/lsar.1.gz share/man/man1/unar.1.gz
PORTDOCS= README.md
PORTEXAMPLES= lsar.bash_completion unar.bash_completion
@@ -31,7 +31,7 @@ OPTIONS_DEFINE= DOCS EXAMPLES
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/XADMaster/??ar ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/Extra/??ar.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/Extra/??ar.1 ${STAGEDIR}${PREFIX}/share/man/man1
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/archivers/zip/Makefile b/archivers/zip/Makefile
index 98f1a3bc9147..dcdc37d4787b 100644
--- a/archivers/zip/Makefile
+++ b/archivers/zip/Makefile
@@ -1,6 +1,6 @@
PORTNAME= zip
PORTVERSION= 3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= archivers
MASTER_SITES= SF/info${PORTNAME}/Zip%203.x%20%28latest%29/${PORTVERSION}
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
@@ -23,14 +23,14 @@ MAKEFILE= unix/Makefile
ALL_TARGET= generic
PLIST_FILES= bin/zip bin/zipcloak bin/zipnote bin/zipsplit \
- man/man1/zip.1.gz man/man1/zipcloak.1.gz \
- man/man1/zipnote.1.gz man/man1/zipsplit.1.gz
+ share/man/man1/zip.1.gz share/man/man1/zipcloak.1.gz \
+ share/man/man1/zipnote.1.gz share/man/man1/zipsplit.1.gz
PORTDOCS= *
do-install:
.for p in ${PLIST_FILES:Mbin*:T}
${INSTALL_PROGRAM} ${WRKSRC}/${p} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/man/${p}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/man/${p}.1 ${STAGEDIR}${PREFIX}/share/man/man1
.endfor
do-install-DOCS-on: