aboutsummaryrefslogtreecommitdiff
path: root/astro/astrometry
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-07-05 15:57:00 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-07-05 15:57:00 +0000
commitc9295f9f80ddf280ea394d568ed45a74428ae6aa (patch)
treeca9465d96f2670647d146329b5ee2b18299b7512 /astro/astrometry
parent09acace680fb70be74fec9e87eccd91169a2c205 (diff)
downloadports-c9295f9f80ddf280ea394d568ed45a74428ae6aa.tar.gz
ports-c9295f9f80ddf280ea394d568ed45a74428ae6aa.zip
astro/astrometry: switch maintainer and improve port a bit
- Give maintainership to Rainer Hurling - New LIB_DEPENDS for math/gsl and astro/wcslib - Add USES=localbase - Change USE_LDCONFIG from path to 'yes' - Make man pages usable - Move bin, libs, data to standard places - Initial hints for automatic 'index' downloads - Adapt pkg-message - Update pkg-plist PR: 246007 Submitted by: Rainer Hurling <rhurlin@gwdg.de>
Notes
Notes: svn path=/head/; revision=541286
Diffstat (limited to 'astro/astrometry')
-rw-r--r--astro/astrometry/Makefile39
-rw-r--r--astro/astrometry/files/os-features-config.h2
-rw-r--r--astro/astrometry/files/pkg-message.in7
-rw-r--r--astro/astrometry/pkg-plist582
4 files changed, 335 insertions, 295 deletions
diff --git a/astro/astrometry/Makefile b/astro/astrometry/Makefile
index 3b1e077541dd..ff9c890aa9c5 100644
--- a/astro/astrometry/Makefile
+++ b/astro/astrometry/Makefile
@@ -3,12 +3,13 @@
PORTNAME= astrometry
PORTVERSION= 0.80
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= http://astrometry.net/downloads/
DISTNAME= ${PORTNAME}.net-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Software for describing astronomical images
+MAINTAINER= rhurlin@gwdg.de
+COMMENT= Astronomic calibration service
LICENSE= GPLv2
@@ -18,22 +19,44 @@ BROKEN_armv7= fails to link: os-features-test.c:10: undefined symbol 'canonical
BUILD_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= libcairo.so:graphics/cairo \
libcfitsio.so:astro/cfitsio \
+ libgsl.so:math/gsl \
libpng.so:graphics/png \
- libnetpbm.so:graphics/netpbm
+ libnetpbm.so:graphics/netpbm \
+ libwcs.so:astro/wcslib
RUN_DEPENDS= ${PYNUMPY}
-USES= gmake jpeg pkgconfig python shebangfix
+USES= gmake jpeg localbase pkgconfig python shebangfix
SHEBANG_FILES= bin/* blind/*.py sdss/*.py util/[!c]*.py
-USE_LDCONFIG= ${PREFIX}/${PORTNAME}/lib
+USE_LDCONFIG= yes
+
ALL_TARGET= all extra
-MAKE_ENV= INSTALL_DIR=${STAGEDIR}${PREFIX}/${PORTNAME} \
+MAKE_ARGS= NETPBM_INC="-I${LOCALBASE}/include/netpbm" \
+ NETPBM_LIB="-L${LOCALBASE}/lib -lnetpbm" \
+ SYSTEM_GSL=yes
+MAKE_ENV= INSTALL_DIR=${STAGEDIR}${PREFIX} \
+ DOC_INSTALL_DIR=${STAGEDIR}${PREFIX}/${PORTNAME}/doc \
+ EXAMPLE_INSTALL_DIR=${STAGEDIR}${PREFIX}/${PORTNAME}/examples \
+ MAN1_INSTALL_DIR=${STAGEDIR}${PREFIX}/man/man1 \
PYTHON=${PYTHON_CMD} PYTHON_SCRIPT=${PYTHON_CMD}
MAKE_JOBS_UNSAFE= yes
+# Changes search path in astrometry-engine
+DATA_INSTALL_DIR= ${STAGEDIR}${DATADIR}
+# Need this to get gzipped man pages
+MANDIRS= ${MANPREFIX}/man/man1
SUB_FILES= pkg-message
LDFLAGS+= -lz
+# DATA_INSTALL_DIR does not work globally :(
post-install:
- @${REINPLACE_CMD} -i '' -e 's|${STAGEDIR}||' \
- ${STAGEDIR}${PREFIX}/${PORTNAME}/etc/${PORTNAME}.cfg
+ @${REINPLACE_CMD} -i '' \
+ -e 's|${STAGEDIR}/usr/local/data|${DATADIR}|' \
+ ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.cfg
+ @${RMDIR} ${STAGEDIR}${PREFIX}/data
+ @${MKDIR} ${STAGEDIR}${DATADIR}/sdss
+ @${MKDIR} ${STAGEDIR}${DATADIR}/blind
+ @${MKDIR} ${STAGEDIR}${DATADIR}/catalogs
+ ${INSTALL_DATA} ${WRKSRC}/sdss/testdata/*.fit* ${STAGEDIR}${DATADIR}/sdss
+ ${INSTALL_DATA} ${WRKSRC}/blind/index-9918.fits ${STAGEDIR}${DATADIR}/blind
+ ${INSTALL_DATA} ${WRKSRC}/catalogs/*.fit* ${STAGEDIR}${DATADIR}/catalogs
.include <bsd.port.mk>
diff --git a/astro/astrometry/files/os-features-config.h b/astro/astrometry/files/os-features-config.h
index c6eaeaa2f07c..ad00021dd871 100644
--- a/astro/astrometry/files/os-features-config.h
+++ b/astro/astrometry/files/os-features-config.h
@@ -2,4 +2,4 @@
#define NEED_DECLARE_QSORT_R 1
#define NEED_QSORT_R 0
#define NEED_SWAP_QSORT_R 0
-#define HAVE_NETPBM 0
+#define HAVE_NETPBM 1
diff --git a/astro/astrometry/files/pkg-message.in b/astro/astrometry/files/pkg-message.in
index 721fd05d07a0..37484df4e176 100644
--- a/astro/astrometry/files/pkg-message.in
+++ b/astro/astrometry/files/pkg-message.in
@@ -3,11 +3,14 @@
message: <<EOM
Astrometry was successfully installed.
-You'll find this distribution in %%PREFIX%%/astrometry
+You'll find this distribution under %%PREFIX%%. Examples are found
+under %%PREFIX%%/astrometry/examples. See %%PREFIX%%/astrometry/doc/
+for some info, more detailed at http://astrometry.net/use.html and
+http://astrometry.net/doc/readme.html.
Although the code is released under a GPL license, you will also need
to download some data files, and these are distributed under different
-license. See %%PREFIX%%/astrometry/doc/GETTING-INDEXES
+license. Data files (indexes) should be stored under %%DATADIR%%/
EOM
}
]
diff --git a/astro/astrometry/pkg-plist b/astro/astrometry/pkg-plist
index 055b52c92ff8..1c93a1901742 100644
--- a/astro/astrometry/pkg-plist
+++ b/astro/astrometry/pkg-plist
@@ -1,59 +1,7 @@
-astrometry/bin/an-fitstopnm
-astrometry/bin/an-pnmtofits
-astrometry/bin/astrometry-engine
-astrometry/bin/build-astrometry-index
-astrometry/bin/degtohms
-astrometry/bin/downsample-fits
-astrometry/bin/fit-wcs
-astrometry/bin/fits-column-merge
-astrometry/bin/fits-flip-endian
-astrometry/bin/fits-guess-scale
-astrometry/bin/fitscopy
-astrometry/bin/fitsgetext
-astrometry/bin/fitsverify
-astrometry/bin/get-healpix
-astrometry/bin/get-wcs
-astrometry/bin/hmstodeg
-astrometry/bin/hpsplit
-astrometry/bin/image2pnm
-astrometry/bin/image2xy
-astrometry/bin/imarith
-astrometry/bin/imcopy
-astrometry/bin/imstat
-astrometry/bin/listhead
-astrometry/bin/liststruc
-astrometry/bin/merge-columns
-astrometry/bin/modhead
-astrometry/bin/new-wcs
-astrometry/bin/pad-file
-astrometry/bin/plot-constellations
-astrometry/bin/plotann.py
-astrometry/bin/plotquad
-astrometry/bin/plotxy
-astrometry/bin/query-starkd
-astrometry/bin/removelines
-astrometry/bin/solve-field
-astrometry/bin/startree
-astrometry/bin/subtable
-astrometry/bin/tablist
-astrometry/bin/tabmerge
-astrometry/bin/tabsort
-astrometry/bin/text2fits
-astrometry/bin/uniformize
-astrometry/bin/votabletofits
-astrometry/bin/wcs-grab
-astrometry/bin/wcs-match
-astrometry/bin/wcs-pv2sip
-astrometry/bin/wcs-rd2xy
-astrometry/bin/wcs-resample
-astrometry/bin/wcs-to-tan
-astrometry/bin/wcs-xy2rd
-astrometry/bin/wcsinfo
astrometry/doc/CREDITS
astrometry/doc/LICENSE
astrometry/doc/README.md
astrometry/doc/report.txt
-astrometry/etc/astrometry.cfg
astrometry/examples/CREDITS
astrometry/examples/apod1.jpg
astrometry/examples/apod1.xyls
@@ -70,235 +18,301 @@ astrometry/examples/m44-1975-01-18.jpg
astrometry/examples/sdss.jpg
astrometry/examples/sdss.xyls
astrometry/examples/tycho2-mag6.fits
-astrometry/include/astrometry/2mass-fits.h
-astrometry/include/astrometry/2mass.h
-astrometry/include/astrometry/allquads.h
-astrometry/include/astrometry/an-bool.h
-astrometry/include/astrometry/an-endian.h
-astrometry/include/astrometry/an-opts.h
-astrometry/include/astrometry/an-thread-pthreads.h
-astrometry/include/astrometry/an-thread.h
-astrometry/include/astrometry/anqfits.h
-astrometry/include/astrometry/anwcs.h
-astrometry/include/astrometry/augment-xylist.h
-astrometry/include/astrometry/axyfile.h
-astrometry/include/astrometry/bl-nl.h
-astrometry/include/astrometry/bl-nl.inc
-astrometry/include/astrometry/bl-nl.ph
-astrometry/include/astrometry/bl-sort.h
-astrometry/include/astrometry/bl.h
-astrometry/include/astrometry/bl.inc
-astrometry/include/astrometry/bl.ph
-astrometry/include/astrometry/blind.h
-astrometry/include/astrometry/blindutils.h
-astrometry/include/astrometry/brightstars.h
-astrometry/include/astrometry/bt.h
-astrometry/include/astrometry/build-index.h
-astrometry/include/astrometry/cairoutils.h
-astrometry/include/astrometry/catalog.h
-astrometry/include/astrometry/coadd.h
-astrometry/include/astrometry/codefile.h
-astrometry/include/astrometry/codekd.h
-astrometry/include/astrometry/codetree.h
-astrometry/include/astrometry/constellation-boundaries.h
-astrometry/include/astrometry/constellations.h
-astrometry/include/astrometry/convolve-image.h
-astrometry/include/astrometry/ctmf.h
-astrometry/include/astrometry/dimage.h
-astrometry/include/astrometry/dualtree.h
-astrometry/include/astrometry/dualtree_nearestneighbour.h
-astrometry/include/astrometry/dualtree_rangesearch.h
-astrometry/include/astrometry/engine.h
-astrometry/include/astrometry/errors.h
-astrometry/include/astrometry/fileutils.h
-astrometry/include/astrometry/fit-wcs.h
-astrometry/include/astrometry/fits-guess-scale.h
-astrometry/include/astrometry/fitsbin.h
-astrometry/include/astrometry/fitsfile.h
-astrometry/include/astrometry/fitsioutils.h
-astrometry/include/astrometry/fitstable.h
-astrometry/include/astrometry/gslutils.h
-astrometry/include/astrometry/hd.h
-astrometry/include/astrometry/healpix-utils.h
-astrometry/include/astrometry/healpix.h
-astrometry/include/astrometry/hpquads.h
-astrometry/include/astrometry/image2xy-files.h
-astrometry/include/astrometry/image2xy.h
-astrometry/include/astrometry/index.h
-astrometry/include/astrometry/intmap.h
-astrometry/include/astrometry/ioutils.h
-astrometry/include/astrometry/kdtree.h
-astrometry/include/astrometry/kdtree_fits_io.h
-astrometry/include/astrometry/keywords.h
-astrometry/include/astrometry/log.h
-astrometry/include/astrometry/matchfile.h
-astrometry/include/astrometry/matchobj.h
-astrometry/include/astrometry/mathutil.h
-astrometry/include/astrometry/merge-index.h
-astrometry/include/astrometry/multiindex.h
-astrometry/include/astrometry/new-wcs.h
-astrometry/include/astrometry/nomad-fits.h
-astrometry/include/astrometry/nomad.h
-astrometry/include/astrometry/openngc.h
-astrometry/include/astrometry/os-features-config.h
-astrometry/include/astrometry/os-features.h
-astrometry/include/astrometry/permutedsort.h
-astrometry/include/astrometry/plotannotations.h
-astrometry/include/astrometry/plotfill.h
-astrometry/include/astrometry/plotgrid.h
-astrometry/include/astrometry/plotimage.h
-astrometry/include/astrometry/plotoutline.h
-astrometry/include/astrometry/plotstuff.h
-astrometry/include/astrometry/plotxy.h
-astrometry/include/astrometry/qfits_byteswap.h
-astrometry/include/astrometry/qfits_card.h
-astrometry/include/astrometry/qfits_convert.h
-astrometry/include/astrometry/qfits_error.h
-astrometry/include/astrometry/qfits_float.h
-astrometry/include/astrometry/qfits_header.h
-astrometry/include/astrometry/qfits_image.h
-astrometry/include/astrometry/qfits_keywords.h
-astrometry/include/astrometry/qfits_md5.h
-astrometry/include/astrometry/qfits_memory.h
-astrometry/include/astrometry/qfits_rw.h
-astrometry/include/astrometry/qfits_std.h
-astrometry/include/astrometry/qfits_table.h
-astrometry/include/astrometry/qfits_time.h
-astrometry/include/astrometry/qfits_tools.h
-astrometry/include/astrometry/qidxfile.h
-astrometry/include/astrometry/quad-builder.h
-astrometry/include/astrometry/quad-utils.h
-astrometry/include/astrometry/quadfile.h
-astrometry/include/astrometry/rdlist.h
-astrometry/include/astrometry/resample.h
-astrometry/include/astrometry/resort-xylist.h
-astrometry/include/astrometry/scamp-catalog.h
-astrometry/include/astrometry/scamp.h
-astrometry/include/astrometry/simplexy-common.h
-astrometry/include/astrometry/simplexy.h
-astrometry/include/astrometry/sip-utils.h
-astrometry/include/astrometry/sip.h
-astrometry/include/astrometry/sip_qfits.h
-astrometry/include/astrometry/solvedfile.h
-astrometry/include/astrometry/solver.h
-astrometry/include/astrometry/starkd.h
-astrometry/include/astrometry/starutil.h
-astrometry/include/astrometry/starutil.inc
-astrometry/include/astrometry/starxy.h
-astrometry/include/astrometry/tabsort.h
-astrometry/include/astrometry/tic.h
-astrometry/include/astrometry/tweak.h
-astrometry/include/astrometry/tweak2.h
-astrometry/include/astrometry/tycho2-fits.h
-astrometry/include/astrometry/tycho2.h
-astrometry/include/astrometry/ucac3.h
-astrometry/include/astrometry/ucac4.h
-astrometry/include/astrometry/uniformize-catalog.h
-astrometry/include/astrometry/unpermute-quads.h
-astrometry/include/astrometry/unpermute-stars.h
-astrometry/include/astrometry/usnob-fits.h
-astrometry/include/astrometry/usnob.h
-astrometry/include/astrometry/verify.h
-astrometry/include/astrometry/wcs-pv2sip.h
-astrometry/include/astrometry/wcs-rd2xy.h
-astrometry/include/astrometry/wcs-xy2rd.h
-astrometry/include/astrometry/xylist.h
-astrometry/lib/libanbase.a
-astrometry/lib/libanfiles.a
-astrometry/lib/libanutils.a
-astrometry/lib/libastrometry.a
-astrometry/lib/libastrometry.so
-astrometry/lib/libcatalogs.a
-astrometry/lib/libgsl-an.a
-astrometry/lib/libkd.a
-astrometry/lib/libqfits.a
-astrometry/lib/python/astrometry/__init__.py
-astrometry/lib/python/astrometry/blind/__init__.py
-astrometry/lib/python/astrometry/blind/_plotstuff_c.so
-astrometry/lib/python/astrometry/blind/plotann.py
-astrometry/lib/python/astrometry/blind/plotstuff.py
-astrometry/lib/python/astrometry/blind/plotstuff_c.py
-astrometry/lib/python/astrometry/catalogs/__init__.py
-astrometry/lib/python/astrometry/libkd/__init__.py
-astrometry/lib/python/astrometry/libkd/spherematch.py
-astrometry/lib/python/astrometry/libkd/spherematch_c.so
-astrometry/lib/python/astrometry/net/client/client.py
-astrometry/lib/python/astrometry/sdss/__init__.py
-astrometry/lib/python/astrometry/sdss/_cutils.so
-astrometry/lib/python/astrometry/sdss/common.py
-astrometry/lib/python/astrometry/sdss/cutils.py
-astrometry/lib/python/astrometry/sdss/cutout.py
-astrometry/lib/python/astrometry/sdss/dr10.py
-astrometry/lib/python/astrometry/sdss/dr7.py
-astrometry/lib/python/astrometry/sdss/dr8.py
-astrometry/lib/python/astrometry/sdss/dr9.py
-astrometry/lib/python/astrometry/sdss/fields.py
-astrometry/lib/python/astrometry/sdss/runList-dr10.par
-astrometry/lib/python/astrometry/sdss/runList-dr8.par
-astrometry/lib/python/astrometry/sdss/runList-dr9.par
-astrometry/lib/python/astrometry/sdss/sdss_das.py
-astrometry/lib/python/astrometry/sdss/sdss_name.py
-astrometry/lib/python/astrometry/sdss/yanny.py
-astrometry/lib/python/astrometry/util/EXIF.py
-astrometry/lib/python/astrometry/util/__init__.py
-astrometry/lib/python/astrometry/util/_util.so
-astrometry/lib/python/astrometry/util/addpath.py
-astrometry/lib/python/astrometry/util/file.py
-astrometry/lib/python/astrometry/util/filetype.py
-astrometry/lib/python/astrometry/util/find_data_file.py
-astrometry/lib/python/astrometry/util/fits.py
-astrometry/lib/python/astrometry/util/fix_sdss_idr.py
-astrometry/lib/python/astrometry/util/horizons.py
-astrometry/lib/python/astrometry/util/image2pnm.py
-astrometry/lib/python/astrometry/util/imageutils.py
-astrometry/lib/python/astrometry/util/miscutils.py
-astrometry/lib/python/astrometry/util/multiproc.py
-astrometry/lib/python/astrometry/util/plotshift.py
-astrometry/lib/python/astrometry/util/plotutils.py
-astrometry/lib/python/astrometry/util/removelines.py
-astrometry/lib/python/astrometry/util/resample.py
-astrometry/lib/python/astrometry/util/run_command.py
-astrometry/lib/python/astrometry/util/shell.py
-astrometry/lib/python/astrometry/util/siap.py
-astrometry/lib/python/astrometry/util/stages.py
-astrometry/lib/python/astrometry/util/starutil.py
-astrometry/lib/python/astrometry/util/starutil_numpy.py
-astrometry/lib/python/astrometry/util/timingpool.py
-astrometry/lib/python/astrometry/util/ttime.py
-astrometry/lib/python/astrometry/util/uniformize.py
-astrometry/lib/python/astrometry/util/usnob_catalog.py
-astrometry/lib/python/astrometry/util/usnob_get_image.py
-astrometry/lib/python/astrometry/util/usnob_get_region.py
-astrometry/lib/python/astrometry/util/util.py
-astrometry/share/man/man1/an-fitstopnm.1
-astrometry/share/man/man1/an-pnmtofits.1
-astrometry/share/man/man1/astrometry-engine.1
-astrometry/share/man/man1/build-astrometry-index.1
-astrometry/share/man/man1/coadd.1
-astrometry/share/man/man1/downsample-fits.1
-astrometry/share/man/man1/fit-wcs.1
-astrometry/share/man/man1/fits-flip-endian.1
-astrometry/share/man/man1/fits-guess-scale.1
-astrometry/share/man/man1/fitsgetext.1
-astrometry/share/man/man1/get-healpix.1
-astrometry/share/man/man1/get-wcs.1
-astrometry/share/man/man1/hpsplit.1
-astrometry/share/man/man1/image2xy.1
-astrometry/share/man/man1/new-wcs.1
-astrometry/share/man/man1/pad-file.1
-astrometry/share/man/man1/plot-constellations.1
-astrometry/share/man/man1/plotquad.1
-astrometry/share/man/man1/plotxy.1
-astrometry/share/man/man1/query-starkd.1
-astrometry/share/man/man1/solve-field.1
-astrometry/share/man/man1/subtable.1
-astrometry/share/man/man1/tabsort.1
-astrometry/share/man/man1/wcs-grab.1
-astrometry/share/man/man1/wcs-match.1
-astrometry/share/man/man1/wcs-pv2sip.1
-astrometry/share/man/man1/wcs-rd2xy.1
-astrometry/share/man/man1/wcs-resample.1
-astrometry/share/man/man1/wcs-to-tan.1
-astrometry/share/man/man1/wcs-xy2rd.1
-astrometry/share/man/man1/wcsinfo.1
-@dir astrometry/data
+bin/an-fitstopnm
+bin/an-pnmtofits
+bin/astrometry-engine
+bin/build-astrometry-index
+bin/degtohms
+bin/downsample-fits
+bin/fit-wcs
+bin/fits-column-merge
+bin/fits-flip-endian
+bin/fits-guess-scale
+bin/fitscopy
+bin/fitsgetext
+bin/fitsverify
+bin/get-healpix
+bin/get-wcs
+bin/hmstodeg
+bin/hpsplit
+bin/image2pnm
+bin/image2xy
+bin/imarith
+bin/imcopy
+bin/imstat
+bin/listhead
+bin/liststruc
+bin/merge-columns
+bin/modhead
+bin/new-wcs
+bin/pad-file
+bin/plot-constellations
+bin/plotann.py
+bin/plotquad
+bin/plotxy
+bin/query-starkd
+bin/removelines
+bin/solve-field
+bin/startree
+bin/subtable
+bin/tablist
+bin/tabmerge
+bin/tabsort
+bin/text2fits
+bin/uniformize
+bin/votabletofits
+bin/wcs-grab
+bin/wcs-match
+bin/wcs-pv2sip
+bin/wcs-rd2xy
+bin/wcs-resample
+bin/wcs-to-tan
+bin/wcs-xy2rd
+bin/wcsinfo
+etc/astrometry.cfg
+include/astrometry/2mass-fits.h
+include/astrometry/2mass.h
+include/astrometry/allquads.h
+include/astrometry/an-bool.h
+include/astrometry/an-endian.h
+include/astrometry/an-opts.h
+include/astrometry/an-thread-pthreads.h
+include/astrometry/an-thread.h
+include/astrometry/anqfits.h
+include/astrometry/anwcs.h
+include/astrometry/augment-xylist.h
+include/astrometry/axyfile.h
+include/astrometry/bl-nl.h
+include/astrometry/bl-nl.inc
+include/astrometry/bl-nl.ph
+include/astrometry/bl-sort.h
+include/astrometry/bl.h
+include/astrometry/bl.inc
+include/astrometry/bl.ph
+include/astrometry/blind.h
+include/astrometry/blindutils.h
+include/astrometry/brightstars.h
+include/astrometry/bt.h
+include/astrometry/build-index.h
+include/astrometry/cairoutils.h
+include/astrometry/catalog.h
+include/astrometry/coadd.h
+include/astrometry/codefile.h
+include/astrometry/codekd.h
+include/astrometry/codetree.h
+include/astrometry/constellation-boundaries.h
+include/astrometry/constellations.h
+include/astrometry/convolve-image.h
+include/astrometry/ctmf.h
+include/astrometry/dimage.h
+include/astrometry/dualtree.h
+include/astrometry/dualtree_nearestneighbour.h
+include/astrometry/dualtree_rangesearch.h
+include/astrometry/engine.h
+include/astrometry/errors.h
+include/astrometry/fileutils.h
+include/astrometry/fit-wcs.h
+include/astrometry/fits-guess-scale.h
+include/astrometry/fitsbin.h
+include/astrometry/fitsfile.h
+include/astrometry/fitsioutils.h
+include/astrometry/fitstable.h
+include/astrometry/gslutils.h
+include/astrometry/hd.h
+include/astrometry/healpix-utils.h
+include/astrometry/healpix.h
+include/astrometry/hpquads.h
+include/astrometry/image2xy-files.h
+include/astrometry/image2xy.h
+include/astrometry/index.h
+include/astrometry/intmap.h
+include/astrometry/ioutils.h
+include/astrometry/kdtree.h
+include/astrometry/kdtree_fits_io.h
+include/astrometry/keywords.h
+include/astrometry/log.h
+include/astrometry/matchfile.h
+include/astrometry/matchobj.h
+include/astrometry/mathutil.h
+include/astrometry/merge-index.h
+include/astrometry/multiindex.h
+include/astrometry/new-wcs.h
+include/astrometry/nomad-fits.h
+include/astrometry/nomad.h
+include/astrometry/openngc.h
+include/astrometry/os-features-config.h
+include/astrometry/os-features.h
+include/astrometry/permutedsort.h
+include/astrometry/plotannotations.h
+include/astrometry/plotfill.h
+include/astrometry/plotgrid.h
+include/astrometry/plotimage.h
+include/astrometry/plotoutline.h
+include/astrometry/plotstuff.h
+include/astrometry/plotxy.h
+include/astrometry/qfits_byteswap.h
+include/astrometry/qfits_card.h
+include/astrometry/qfits_convert.h
+include/astrometry/qfits_error.h
+include/astrometry/qfits_float.h
+include/astrometry/qfits_header.h
+include/astrometry/qfits_image.h
+include/astrometry/qfits_keywords.h
+include/astrometry/qfits_md5.h
+include/astrometry/qfits_memory.h
+include/astrometry/qfits_rw.h
+include/astrometry/qfits_std.h
+include/astrometry/qfits_table.h
+include/astrometry/qfits_time.h
+include/astrometry/qfits_tools.h
+include/astrometry/qidxfile.h
+include/astrometry/quad-builder.h
+include/astrometry/quad-utils.h
+include/astrometry/quadfile.h
+include/astrometry/rdlist.h
+include/astrometry/resample.h
+include/astrometry/resort-xylist.h
+include/astrometry/scamp-catalog.h
+include/astrometry/scamp.h
+include/astrometry/simplexy-common.h
+include/astrometry/simplexy.h
+include/astrometry/sip-utils.h
+include/astrometry/sip.h
+include/astrometry/sip_qfits.h
+include/astrometry/solvedfile.h
+include/astrometry/solver.h
+include/astrometry/starkd.h
+include/astrometry/starutil.h
+include/astrometry/starutil.inc
+include/astrometry/starxy.h
+include/astrometry/tabsort.h
+include/astrometry/tic.h
+include/astrometry/tweak.h
+include/astrometry/tweak2.h
+include/astrometry/tycho2-fits.h
+include/astrometry/tycho2.h
+include/astrometry/ucac3.h
+include/astrometry/ucac4.h
+include/astrometry/uniformize-catalog.h
+include/astrometry/unpermute-quads.h
+include/astrometry/unpermute-stars.h
+include/astrometry/usnob-fits.h
+include/astrometry/usnob.h
+include/astrometry/verify.h
+include/astrometry/wcs-pv2sip.h
+include/astrometry/wcs-rd2xy.h
+include/astrometry/wcs-xy2rd.h
+include/astrometry/xylist.h
+lib/libanbase.a
+lib/libanfiles.a
+lib/libanutils.a
+lib/libastrometry.a
+lib/libastrometry.so
+lib/libcatalogs.a
+lib/libkd.a
+lib/libqfits.a
+lib/python/astrometry/__init__.py
+lib/python/astrometry/blind/__init__.py
+lib/python/astrometry/blind/_plotstuff_c.so
+lib/python/astrometry/blind/plotann.py
+lib/python/astrometry/blind/plotstuff.py
+lib/python/astrometry/blind/plotstuff_c.py
+lib/python/astrometry/catalogs/__init__.py
+lib/python/astrometry/libkd/__init__.py
+lib/python/astrometry/libkd/spherematch.py
+lib/python/astrometry/libkd/spherematch_c.so
+lib/python/astrometry/net/client/client.py
+lib/python/astrometry/sdss/__init__.py
+lib/python/astrometry/sdss/_cutils.so
+lib/python/astrometry/sdss/common.py
+lib/python/astrometry/sdss/cutils.py
+lib/python/astrometry/sdss/cutout.py
+lib/python/astrometry/sdss/dr10.py
+lib/python/astrometry/sdss/dr7.py
+lib/python/astrometry/sdss/dr8.py
+lib/python/astrometry/sdss/dr9.py
+lib/python/astrometry/sdss/fields.py
+lib/python/astrometry/sdss/runList-dr10.par
+lib/python/astrometry/sdss/runList-dr8.par
+lib/python/astrometry/sdss/runList-dr9.par
+lib/python/astrometry/sdss/sdss_das.py
+lib/python/astrometry/sdss/sdss_name.py
+lib/python/astrometry/sdss/yanny.py
+lib/python/astrometry/util/EXIF.py
+lib/python/astrometry/util/__init__.py
+lib/python/astrometry/util/_util.so
+lib/python/astrometry/util/addpath.py
+lib/python/astrometry/util/file.py
+lib/python/astrometry/util/filetype.py
+lib/python/astrometry/util/find_data_file.py
+lib/python/astrometry/util/fits.py
+lib/python/astrometry/util/fix_sdss_idr.py
+lib/python/astrometry/util/horizons.py
+lib/python/astrometry/util/image2pnm.py
+lib/python/astrometry/util/imageutils.py
+lib/python/astrometry/util/miscutils.py
+lib/python/astrometry/util/multiproc.py
+lib/python/astrometry/util/plotshift.py
+lib/python/astrometry/util/plotutils.py
+lib/python/astrometry/util/removelines.py
+lib/python/astrometry/util/resample.py
+lib/python/astrometry/util/run_command.py
+lib/python/astrometry/util/shell.py
+lib/python/astrometry/util/siap.py
+lib/python/astrometry/util/stages.py
+lib/python/astrometry/util/starutil.py
+lib/python/astrometry/util/starutil_numpy.py
+lib/python/astrometry/util/timingpool.py
+lib/python/astrometry/util/ttime.py
+lib/python/astrometry/util/uniformize.py
+lib/python/astrometry/util/usnob_catalog.py
+lib/python/astrometry/util/usnob_get_image.py
+lib/python/astrometry/util/usnob_get_region.py
+lib/python/astrometry/util/util.py
+man/man1/an-fitstopnm.1.gz
+man/man1/an-pnmtofits.1.gz
+man/man1/astrometry-engine.1.gz
+man/man1/build-astrometry-index.1.gz
+man/man1/coadd.1.gz
+man/man1/downsample-fits.1.gz
+man/man1/fit-wcs.1.gz
+man/man1/fits-flip-endian.1.gz
+man/man1/fits-guess-scale.1.gz
+man/man1/fitsgetext.1.gz
+man/man1/get-healpix.1.gz
+man/man1/get-wcs.1.gz
+man/man1/hpsplit.1.gz
+man/man1/image2xy.1.gz
+man/man1/new-wcs.1.gz
+man/man1/pad-file.1.gz
+man/man1/plot-constellations.1.gz
+man/man1/plotquad.1.gz
+man/man1/plotxy.1.gz
+man/man1/query-starkd.1.gz
+man/man1/solve-field.1.gz
+man/man1/subtable.1.gz
+man/man1/tabsort.1.gz
+man/man1/wcs-grab.1.gz
+man/man1/wcs-match.1.gz
+man/man1/wcs-pv2sip.1.gz
+man/man1/wcs-rd2xy.1.gz
+man/man1/wcs-resample.1.gz
+man/man1/wcs-to-tan.1.gz
+man/man1/wcs-xy2rd.1.gz
+man/man1/wcsinfo.1.gz
+%%DATADIR%%/blind/index-9918.fits
+%%DATADIR%%/catalogs/abell-all.fits
+%%DATADIR%%/catalogs/brightstars.fits
+%%DATADIR%%/catalogs/openngc-ic.fits
+%%DATADIR%%/catalogs/openngc-names.fits
+%%DATADIR%%/catalogs/openngc-ngc.fits
+%%DATADIR%%/catalogs/ugc.fits
+%%DATADIR%%/catalogs/uzc2000.fits
+%%DATADIR%%/sdss/cut-tsObj-002830-6-0-0398.fit
+%%DATADIR%%/sdss/psf.fits
+%%DATADIR%%/sdss/psf00.fits
+%%DATADIR%%/sdss/psf01k.fits
+%%DATADIR%%/sdss/psf02k.fits
+%%DATADIR%%/sdss/psf1k0.fits
+%%DATADIR%%/sdss/psf2k0.fits
+%%DATADIR%%/sdss/tsField-002830-6-0398.fit