aboutsummaryrefslogtreecommitdiff
path: root/astro/boinc-einsteinathome/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-05-23 08:18:16 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-05-23 08:18:16 +0000
commit7e8cddfe9b32ac833b3d9364ae81790ffe853605 (patch)
tree139cc36780be52d14757d45a8fe71a0aa54049ee /astro/boinc-einsteinathome/Makefile
parent13ceb9e5b940de6792128726a8d18933e2ca2369 (diff)
downloadports-7e8cddfe9b32ac833b3d9364ae81790ffe853605.tar.gz
ports-7e8cddfe9b32ac833b3d9364ae81790ffe853605.zip
- Update to 4.61
Approved by: Rene Ladan <r.c.ladan@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=163160
Diffstat (limited to 'astro/boinc-einsteinathome/Makefile')
-rw-r--r--astro/boinc-einsteinathome/Makefile25
1 files changed, 17 insertions, 8 deletions
diff --git a/astro/boinc-einsteinathome/Makefile b/astro/boinc-einsteinathome/Makefile
index 39e9a0b3d27d..30022ac2498c 100644
--- a/astro/boinc-einsteinathome/Makefile
+++ b/astro/boinc-einsteinathome/Makefile
@@ -5,7 +5,7 @@
#
PORTNAME= boinc-einsteinathome
-PORTVERSION= 0.40
+PORTVERSION= 4.61
CATEGORIES= astro
MASTER_SITES= http://einstein.phys.uwm.edu/app_test/FreeBSD/
DISTNAME= albert_${PORTVERSION}_i386-unknown-freebsd
@@ -17,14 +17,14 @@ COMMENT= Einstein@Home for BOINC
.include <bsd.port.pre.mk>
ONLY_FOR_ARCHS= i386 amd64
-# Binary is built on 4.9 :
-.if ${OSVERSION} >= 500000
-.if ${ARCH} == "amd64"
-RUN_DEPENDS+= compat4x-i386>0:${PORTSDIR}/misc/compat4x
-.else
-LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
+
+# Binary is built for 5.X :
+.if ${OSVERSION} < 500000
+IGNORE= only supports FreeBSD 5.X and newer
.endif
-# also depends on libm.so.2
+
+.if ${OSVERSION} >= 600000
+LIB_DEPENDS+= c.5:${PORTSDIR}/misc/compat5x
.endif
RUN_DEPENDS+= boinc_client:${PORTSDIR}/net/boinc-client
@@ -40,6 +40,15 @@ BOINC_HOME?= /var/db/boinc
EINSTEIN_SITE= einstein.phys.uwm.edu
EINSTEIN_BINARY=${DISTNAME}
+.if ${ARCH} == amd64 && ${OSVERSION} >= 600000
+AMD64= ""
+.else
+AMD64= "@comment "
+.endif
+
+SUB_FILES= pkg-message
+SUB_LIST= AMD64=${AMD64}
+
PLIST_SUB= EINSTEIN_BINARY="${EINSTEIN_BINARY}" EINSTEIN_SITE=${EINSTEIN_SITE} \
BOINC_HOME=${BOINC_HOME}