aboutsummaryrefslogtreecommitdiff
path: root/astro/celestia
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-05 14:30:00 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-05 14:30:00 +0000
commite91ed3ea1cf00bd0f3170aeadcdc2bfb7d326770 (patch)
tree4a29b47ba42bebf977b8eb8a9191c12a6c41c353 /astro/celestia
parente7965f1caeba4097cdb1c09ce9ab70eaadd35ef7 (diff)
downloadports-e91ed3ea1cf00bd0f3170aeadcdc2bfb7d326770.tar.gz
ports-e91ed3ea1cf00bd0f3170aeadcdc2bfb7d326770.zip
- Remove support for the expired KDE3 port
- While here convert NOPORTDOCS and USE_GMAKE PR: ports/180265 Submitted by: rene
Notes
Notes: svn path=/head/; revision=322329
Diffstat (limited to 'astro/celestia')
-rw-r--r--astro/celestia/Makefile32
-rw-r--r--astro/celestia/pkg-plist56
2 files changed, 11 insertions, 77 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 1d1199894008..9f8c4cebacac 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -9,16 +9,15 @@ MASTER_SITES= SF/${PORTNAME}/Celestia-source/${PORTVERSION}
PKGNAMESUFFIX= -${CELESTIA_UI}
MAINTAINER= danfe@FreeBSD.org
-COMMENT= Scriptable space flight simulator for X
+COMMENT= Scriptable space flight simulator for X11
LICENSE= GPLv2
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png
+USES= gettext gmake
USE_AUTOTOOLS= libtool
-USE_GMAKE= yes
-USES= gettext
USE_GL= gl
USE_LUA= 5.0+ # should be optional, but the build fails without it
WANT_GNOME= yes
@@ -27,7 +26,7 @@ CXXFLAGS+= -fsigned-char # fix text rendering (see Gentoo bug 316573)
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -pthread
-UI_LIST= glut gtk gnome kde
+UI_LIST= glut gtk gnome
CELESTIA_UI?= glut
CONFLICTS= ${UI_LIST:S|${CELESTIA_UI}||:S|^|celestia-|:S|$|-[0-9]*|}
@@ -38,11 +37,9 @@ CONFLICTS= ${UI_LIST:S|${CELESTIA_UI}||:S|^|celestia-|:S|$|-[0-9]*|}
# the default one);
# gtk Full interface with minimal dependencies: adds menu, configuration
# dialog, some other utilities;
-# gnome Full GTK interface plus a few Gnome integration goodies, such as
+# gnome Full GTK interface plus a few GNOME integration goodies, such as
# preference saving in GConf (this looks and works very much like
-# the Windows interface);
-# kde Probably the richest of all: brings contextual menus, toolbars,
-# KDE integration, internationalization, bookmarks, etc.
+# the Windows interface).
#
.if ${CELESTIA_UI} == "glut"
CONFIGURE_ARGS+= --with-glut
@@ -55,11 +52,6 @@ CATEGORIES+= gnome
CONFIGURE_ARGS+= --with-gnome
USE_GNOME+= libgnomeui
GCONF_SCHEMAS= celestia.schemas
-.elif ${CELESTIA_UI} == "kde"
-CATEGORIES+= kde
-CONFIGURE_ARGS+= --with-kde
-USE_KDELIBS_VER= 3
-INSTALLS_ICONS= yes
.else
IGNORE= requires one of the <${UI_LIST}> values for CELESTIA_UI
.endif
@@ -73,19 +65,17 @@ PLIST_FILES+= share/celestia/celestia-logo.png share/celestia/celestiaui.xml
.else
STARTUP_NOTIFY= false
.endif
-.if ${CELESTIA_UI} == "kde"
-LIB_DEPENDS+= theora:${PORTSDIR}/multimedia/libtheora
-PLIST_SUB+= KDE=""
-.else
-PLIST_SUB+= KDE="@comment "
-.endif
PORTDOCS= AUTHORS ChangeLog README
-DESKTOP_ENTRIES="Celestia" "Explore space" \
+DESKTOP_ENTRIES="Celestia" "Explore the space" \
"${PREFIX}/share/pixmaps/celestia.png" "celestia" \
"Astronomy;Education;Science;" ${STARTUP_NOTIFY}
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-patch:
# Fix Lua discovery pkg-config(1) calls
@${REINPLACE_CMD} -E 's|lua5\.?|lua-5.|' ${WRKSRC}/configure
@@ -110,7 +100,7 @@ post-install:
# does not hurt and simplifies PLIST handling
${INSTALL_DATA} ${WRKSRC}/src/celestia/gtk/data/celestia.png \
${PREFIX}/share/pixmaps
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
diff --git a/astro/celestia/pkg-plist b/astro/celestia/pkg-plist
index dd40e80b0c7f..0969b7e6fd2b 100644
--- a/astro/celestia/pkg-plist
+++ b/astro/celestia/pkg-plist
@@ -555,62 +555,6 @@ share/locale/zh_CN/LC_MESSAGES/celestia_constellations.mo
share/locale/zh_TW/LC_MESSAGES/celestia.mo
share/locale/zh_TW/LC_MESSAGES/celestia_constellations.mo
share/pixmaps/celestia.png
-%%KDE%%share/applnk/Edutainment/Science/celestia.desktop
-%%KDE%%share/apps/celestia
-%%KDE%%share/celestia/bookmarks.xml
-%%KDE%%share/celestia/celestiaui.rc
-%%KDE%%share/celestia/favicons/celestia_20020830192652097.png
-%%KDE%%share/celestia/favicons/celestia_20020830192655186.png
-%%KDE%%share/celestia/favicons/celestia_20021210223316001.png
-%%KDE%%share/celestia/favicons/celestia_20021212191412299.png
-%%KDE%%share/celestia/favicons/celestia_20021215164511359.png
-%%KDE%%share/celestia/favicons/celestia_20021215164726547.png
-%%KDE%%share/celestia/favicons/celestia_20021215170159036.png
-%%KDE%%share/celestia/favicons/celestia_20030106235954721.png
-%%KDE%%share/config/celestiarc
-%%KDE%%share/doc/HTML/en/celestia/fig1.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig10.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig11.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig12.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig13.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig14.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig15.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig16.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig17.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig18.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig19.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig2.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig20.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig21.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig22.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig221.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig23.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig24.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig25.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig26.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig27.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig28.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig29.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig3.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig30.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig4.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig5.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig6.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig7.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig8.jpg
-%%KDE%%share/doc/HTML/en/celestia/fig9.jpg
-%%KDE%%share/doc/HTML/en/celestia/index.cache.bz2
-%%KDE%%share/doc/HTML/en/celestia/index.docbook
-%%KDE%%share/doc/HTML/en/celestia/common
-%%KDE%%share/icons/hicolor/16x16/apps/celestia.png
-%%KDE%%share/icons/hicolor/22x22/apps/celestia.png
-%%KDE%%share/icons/hicolor/32x32/apps/celestia.png
-%%KDE%%share/icons/hicolor/48x48/apps/celestia.png
-%%KDE%%share/mimelnk/application/x-celestia-script.desktop
-%%KDE%%share/services/celestia.protocol
-%%KDE%%@dirrm share/doc/HTML/en/celestia
-%%KDE%%@dirrm share/celestia/favicons
-%%KDE%%@dirrm share/applnk/Edutainment/Science
@dirrm share/celestia/textures/medres
@dirrm share/celestia/textures/lores
@dirrm share/celestia/textures/hires