aboutsummaryrefslogtreecommitdiff
path: root/astro/geographiclib
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-10-14 19:00:57 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-10-14 19:00:57 +0000
commit9ccabfbcb84fff8247faf23fcb01063b29c3df50 (patch)
tree64565af5c1df6fddda8d682c776fda3aa70292ca /astro/geographiclib
parent629ee4e44c21d38dacfda883e81c8d53548b96d3 (diff)
downloadports-9ccabfbcb84fff8247faf23fcb01063b29c3df50.tar.gz
ports-9ccabfbcb84fff8247faf23fcb01063b29c3df50.zip
- Update to version 1.38
- Add options for additional datasets PR: 194235 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=370880
Diffstat (limited to 'astro/geographiclib')
-rw-r--r--astro/geographiclib/Makefile27
-rw-r--r--astro/geographiclib/distinfo6
-rw-r--r--astro/geographiclib/pkg-plist13
3 files changed, 23 insertions, 23 deletions
diff --git a/astro/geographiclib/Makefile b/astro/geographiclib/Makefile
index 5c899fd71afd..14302b6f832e 100644
--- a/astro/geographiclib/Makefile
+++ b/astro/geographiclib/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= geographiclib
-PORTVERSION= 1.37
-PORTREVISION= 1
+PORTVERSION= 1.38
CATEGORIES= astro
MASTER_SITES= SF/geographiclib/distrib \
SF/geographiclib:geoids,gravity,magnetic
@@ -28,32 +27,33 @@ MAKE_ARGS+= pythondir=${PYTHON_SITELIBDIR}/geographiclib
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-OPTIONS_SUB= yes
OPTIONS_DEFAULT= GEOID_EGM96_5 GRAVITY_EGM96 GRAVITY_WGS84 \
MAGNETIC_WMM2010 MAGNETIC_IGRF11
+OPTIONS_GROUP= DATASETS
+OPTIONS_SUB= yes
GEOID_NAMES:= egm84-30 egm84-15 egm96-15 egm96-5 \
egm2008-5 egm2008-2_5 egm2008-1
-GRAVITY_NAMES:= egm84 egm96 egm2008 wgs84
+GRAVITY_NAMES:= egm84 egm96 egm2008 wgs84 grs80
MAGNETIC_NAMES:= wmm2010 igrf11 emm2010
.for n in ${GEOID_NAMES}
-OPTIONS_DEFINE+= GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}
GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DESC= Install ${n} geoid dataset
+OPTIONS_GROUP_DATASETS+= GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}
GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DISTFILES= geoids-distrib/${n}.tar.bz2:geoids
MAKESUM_DISTFILES+= geoids-distrib/${n}.tar.bz2:geoids
MAKESUM_OPTIONS_DEFAULT+= GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}
.endfor
.for n in ${GRAVITY_NAMES}
-OPTIONS_DEFINE+= GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}
GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DESC= Install ${n} gravity model
+OPTIONS_GROUP_DATASETS+= GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}
GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DISTFILES= gravity-distrib/${n}.tar.bz2:gravity
MAKESUM_DISTFILES+= gravity-distrib/${n}.tar.bz2:gravity
MAKESUM_OPTIONS_DEFAULT+= GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}
.endfor
.for n in ${MAGNETIC_NAMES}
-OPTIONS_DEFINE+= MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}
MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DESC= Install ${n} magnetic model
+OPTIONS_GROUP_DATASETS+= MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}
MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DISTFILES= magnetic-distrib/${n}.tar.bz2:magnetic
MAKESUM_DISTFILES+= magnetic-distrib/${n}.tar.bz2:magnetic
MAKESUM_OPTIONS_DEFAULT+= MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}
@@ -70,21 +70,14 @@ post-patch:
${REINPLACE_CMD} -e '/wget/s/wget -O/fetch -o /' \
${WRKSRC}/tools/geographiclib-get-*.sh
-install-datasets-mkdir: .NOTMAIN
- for d in geoids gravity magnetic ;\
- do ${MKDIR} ${STAGEDIR}${DATADIR}/$${d} &&\
- ${TOUCH} ${STAGEDIR}${DATADIR}/$${d}/.keep ;\
- done
-.PHONY: install-datasets-mkdir
-
.for n in geoids gravity magnetic
-install-datasets-${n}: install-datasets-mkdir .NOTMAIN
+install-datasets-${n}: .NOTMAIN
+ ${MKDIR} ${STAGEDIR}${DATADIR}/${n}
(cd ${WRKDIR}/${n} && \
${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/${n})
.PHONY: install-datasets-${n}
.endfor
-post-install: install-datasets-mkdir
.if ${PORT_OPTIONS:MGEOID_*}
post-install: install-datasets-geoids
.endif
@@ -98,7 +91,7 @@ post-install: install-datasets-magnetic
.PHONY: x-tool-plist
x-tool-plist: ${PLIST} .NOTMAIN
${REINPLACE_CMD}\
- -e '/^%%PORTDOCS%%/d'\
+ -e '/^%%PORTDOCS%%/d' -e '/@dir /d'\
-e '/^%%DATADIR%%\/geoids\/[^.]/{\
h;s|^%%DATADIR%%/geoids/\([^.]\{1,\}\).*|GEOID_\1|;\
s/[^0-9A-Za-z]/_/g;\
diff --git a/astro/geographiclib/distinfo b/astro/geographiclib/distinfo
index cf30c1432691..906a398f760a 100644
--- a/astro/geographiclib/distinfo
+++ b/astro/geographiclib/distinfo
@@ -1,5 +1,5 @@
-SHA256 (GeographicLib/GeographicLib-1.37.tar.gz) = ebf2dec42d8b738024eb29ad36976ff8ea550eb4c005a07cb1b2abbc2e4d3de5
-SIZE (GeographicLib/GeographicLib-1.37.tar.gz) = 1963202
+SHA256 (GeographicLib/GeographicLib-1.38.tar.gz) = 13904610395efb0b2a94729a912688aca87b02cf7518633178c6a4a829aeff8c
+SIZE (GeographicLib/GeographicLib-1.38.tar.gz) = 1976874
SHA256 (GeographicLib/geoids-distrib/egm2008-1.tar.bz2) = bdb382d0be7ece9142450eacc24b7b7f0889ee3e0ba4f535b04ec383f94c0fb5
SIZE (GeographicLib/geoids-distrib/egm2008-1.tar.bz2) = 162388303
SHA256 (GeographicLib/geoids-distrib/egm2008-2_5.tar.bz2) = d602e13446a4a4a23f39aecfe6a2a0760a1bc6c1b497482c2ebc9f7d513be699
@@ -20,6 +20,8 @@ SHA256 (GeographicLib/gravity-distrib/egm84.tar.bz2) = 7ebec3b2aa2e88581470cd776
SIZE (GeographicLib/gravity-distrib/egm84.tar.bz2) = 258023
SHA256 (GeographicLib/gravity-distrib/egm96.tar.bz2) = 6fea4c6bd56ff8ac53dbdad8d5dd505c855471d0354c4abc5c5fe048bf8350c1
SIZE (GeographicLib/gravity-distrib/egm96.tar.bz2) = 2055724
+SHA256 (GeographicLib/gravity-distrib/grs80.tar.bz2) = 636c438460c9ccb90332bd6fd7d57dbfa62782ac6b64bd84989d559736579230
+SIZE (GeographicLib/gravity-distrib/grs80.tar.bz2) = 784
SHA256 (GeographicLib/gravity-distrib/wgs84.tar.bz2) = 4cf4f7e533261986b25f9e3c929d846044e0fb2b9c35f301df545c335491f2e7
SIZE (GeographicLib/gravity-distrib/wgs84.tar.bz2) = 807
SHA256 (GeographicLib/magnetic-distrib/emm2010.tar.bz2) = aa8782fddb505d8dc24e3dd26784712c1b1848227e23cdcb4e4f2d3ed49d9e14
diff --git a/astro/geographiclib/pkg-plist b/astro/geographiclib/pkg-plist
index 758c535dd959..43ad055f2284 100644
--- a/astro/geographiclib/pkg-plist
+++ b/astro/geographiclib/pkg-plist
@@ -52,7 +52,7 @@ include/GeographicLib/Utility.hpp
lib/libGeographic.a
lib/libGeographic.so
lib/libGeographic.so.13
-lib/libGeographic.so.13.0.0
+lib/libGeographic.so.13.0.1
%%PYTHON_SITELIBDIR%%/geographiclib/__init__.py
%%PYTHON_SITELIBDIR%%/geographiclib/accumulator.py
%%PYTHON_SITELIBDIR%%/geographiclib/constants.py
@@ -68,6 +68,8 @@ libexec/GeographicLib/matlab/ecc2flat.m
libexec/GeographicLib/matlab/eqdazim_fwd.m
libexec/GeographicLib/matlab/eqdazim_inv.m
libexec/GeographicLib/matlab/flat2ecc.m
+libexec/GeographicLib/matlab/gedistance.m
+libexec/GeographicLib/matlab/gedoc.m
libexec/GeographicLib/matlab/geocentricforward.cpp
libexec/GeographicLib/matlab/geocentricforward.m
libexec/GeographicLib/matlab/geocentricreverse.cpp
@@ -86,6 +88,7 @@ libexec/GeographicLib/matlab/geodreckon.m
libexec/GeographicLib/matlab/geographiclibinterface.m
libexec/GeographicLib/matlab/geoidheight.cpp
libexec/GeographicLib/matlab/geoidheight.m
+libexec/GeographicLib/matlab/gereckon.m
libexec/GeographicLib/matlab/gnomonic_fwd.m
libexec/GeographicLib/matlab/gnomonic_inv.m
libexec/GeographicLib/matlab/localcartesianforward.cpp
@@ -139,11 +142,13 @@ man/man1/MagneticField.1.gz
man/man1/Planimeter.1.gz
man/man1/RhumbSolve.1.gz
man/man1/TransverseMercatorProj.1.gz
+man/man8/geographiclib-get-geoids.8.gz
+man/man8/geographiclib-get-gravity.8.gz
+man/man8/geographiclib-get-magnetic.8.gz
sbin/geographiclib-get-geoids
sbin/geographiclib-get-gravity
sbin/geographiclib-get-magnetic
share/cmake/GeographicLib/FindGeographicLib.cmake
-%%DATADIR%%/geoids/.keep
%%GEOID_EGM2008_1%%%%DATADIR%%/geoids/egm2008-1.pgm
%%GEOID_EGM2008_1%%%%DATADIR%%/geoids/egm2008-1.pgm.aux.xml
%%GEOID_EGM2008_1%%%%DATADIR%%/geoids/egm2008-1.wld
@@ -165,16 +170,16 @@ share/cmake/GeographicLib/FindGeographicLib.cmake
%%GEOID_EGM96_5%%%%DATADIR%%/geoids/egm96-5.pgm
%%GEOID_EGM96_5%%%%DATADIR%%/geoids/egm96-5.pgm.aux.xml
%%GEOID_EGM96_5%%%%DATADIR%%/geoids/egm96-5.wld
-%%DATADIR%%/gravity/.keep
%%GRAVITY_EGM2008%%%%DATADIR%%/gravity/egm2008.egm
%%GRAVITY_EGM2008%%%%DATADIR%%/gravity/egm2008.egm.cof
%%GRAVITY_EGM84%%%%DATADIR%%/gravity/egm84.egm
%%GRAVITY_EGM84%%%%DATADIR%%/gravity/egm84.egm.cof
%%GRAVITY_EGM96%%%%DATADIR%%/gravity/egm96.egm
%%GRAVITY_EGM96%%%%DATADIR%%/gravity/egm96.egm.cof
+%%GRAVITY_GRS80%%%%DATADIR%%/gravity/grs80.egm
+%%GRAVITY_GRS80%%%%DATADIR%%/gravity/grs80.egm.cof
%%GRAVITY_WGS84%%%%DATADIR%%/gravity/wgs84.egm
%%GRAVITY_WGS84%%%%DATADIR%%/gravity/wgs84.egm.cof
-%%DATADIR%%/magnetic/.keep
%%MAGNETIC_EMM2010%%%%DATADIR%%/magnetic/emm2010.wmm
%%MAGNETIC_EMM2010%%%%DATADIR%%/magnetic/emm2010.wmm.cof
%%MAGNETIC_IGRF11%%%%DATADIR%%/magnetic/igrf11.wmm