aboutsummaryrefslogtreecommitdiff
path: root/astro/google-earth/Makefile
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-01-29 16:27:58 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-01-29 16:27:58 +0000
commitc066234ed2b3c9f237a0d75dd34a6326ffbdf68e (patch)
tree0be169223a61877b83c6036f466c38d4aaa28727 /astro/google-earth/Makefile
parent54a8b690acda09027daed956b08520bf4c196829 (diff)
downloadports-c066234ed2b3c9f237a0d75dd34a6326ffbdf68e.tar.gz
ports-c066234ed2b3c9f237a0d75dd34a6326ffbdf68e.zip
- Go back to previous version, 6.0.3.2197, as the new one, 6.2.0.5905,
not only still crashes on 9.x/amd64 [1] but now also on 8.x with Radeon Graphics: (using Xorg drivers as there is no fglrx for FreeBSD) http://people.freebsd.org/~nox/tmp/google-earth-6.2.0.5905/8-radeon-amd64/crashlog-4f24bff5.txt Port shar for 6.2.0.5905 for testing: http://people.freebsd.org/~nox/tmp/google-earth-6.2.0.5905/google-earth-6.2.0.5905.shar Crashlog for 6.2.0.5905 on 9.x/amd64 with Nvidia Graphics: http://people.freebsd.org/~nox/tmp/google-earth-6.2.0.5905/9-nvidia-amd64/crashlog-4f24c0d5.txt Crashlog for 6.1.0.5001 on 9.x/amd64 with Nvidia Graphics for comparison: http://people.freebsd.org/~nox/tmp/google-earth-6.1.0.5001/9-nvidia-amd64/crashlog-4f16ff57.txt - Bump PORTEPOCH. PR: ports/160422 [1] Submitted by: "Hartmann, O." <ohartman@zedat.fu-berlin.de> [1]
Notes
Notes: svn path=/head/; revision=290041
Diffstat (limited to 'astro/google-earth/Makefile')
-rw-r--r--astro/google-earth/Makefile51
1 files changed, 30 insertions, 21 deletions
diff --git a/astro/google-earth/Makefile b/astro/google-earth/Makefile
index 01ecd3be9944..c94a2d3afe70 100644
--- a/astro/google-earth/Makefile
+++ b/astro/google-earth/Makefile
@@ -6,30 +6,24 @@
#
PORTNAME= google-earth
-PORTVERSION= 6.1.0.5001
-PORTEPOCH= 1
+PORTVERSION= 6.0.3.2197
+PORTEPOCH= 2
CATEGORIES= astro deskutils geography
MASTER_SITES= http://dl.google.com/earth/client/advanced/previous/:previous \
http://dl.google.com/earth/client/current/:current
-DISTFILES= google-earth-stable_current_i386.rpm:current
+DISTFILES= GoogleEarthLinux.bin:previous
DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
+EXTRACT_ONLY= # none
MAINTAINER= nox@FreeBSD.org
COMMENT= Explore, Search and Discover
-EXTRACT_DEPENDS+= ${RPM2CPIO}:${PORTSDIR}/archivers/rpm
+EXTRACT_DEPENDS= unmakeself:${PORTSDIR}/archivers/unmakeself
RUN_DEPENDS= update-mime-database:${PORTSDIR}/misc/shared-mime-info
-RPM2CPIO?= ${LOCALBASE}/bin/rpm2cpio
-EXTRACT_CMD?= ${RPM2CPIO}
-EXTRACT_BEFORE_ARGS?=
-EXTRACT_AFTER_ARGS?= | ${CPIO} -id --quiet
-
RESTRICTED= Not sure about redistribution rights
-WRKSRC= ${WRKDIR}
-SUB_FILES= Google-googleearth.desktop
-NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/\..*//g}/
USE_LINUX= yes
USE_LINUX_APPS= xorglibs
@@ -38,6 +32,8 @@ USE_PERL5_BUILD= yes
.include <bsd.port.pre.mk>
+UNMAKESELF= ${LOCALBASE}/bin/unmakeself
+
.if defined(WITH_NVIDIA_GL)
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
.else
@@ -56,24 +52,37 @@ IGNORE= needs non-default linux ports (define OVERRIDE_LINUX_BASE_PORT=f10 and O
BROKEN= seems to crash on >= 9.x/amd64: http://www.freebsd.org/cgi/query-pr.cgi?pr=160422
.endif
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${DIST_SUBDIR}/${_DISTFILES} ${WRKSRC}
+ @cd ${WRKSRC} && ${UNMAKESELF} ${_DISTFILES} && ${RM} -f ${_DISTFILES}
+ @cd ${WRKSRC} && ${TAR} xf googleearth-data.tar && ${RM} -f googleearth-data.tar
+ @cd ${WRKSRC} && ${TAR} xf googleearth-linux-x86.tar && ${RM} -f googleearth-linux-x86.tar
+
post-patch:
- @${REINPLACE_CMD} -i "" -e 's|^# Set the home.*|GOOGLEEARTH_DATA_PATH=${DATADIR}|' ${WRKSRC}/opt/google/earth/free/googleearth
- @${REINPLACE_CMD} -i "" -e "s|^# Let's boogie.*|rm -f \$${HOME}/.googleearth/instance-running-lock|" ${WRKSRC}/opt/google/earth/free/googleearth
- @${RM} ${WRKSRC}/opt/google/earth/free/googleearth.orig
- @${RM} ${WRKSRC}/opt/google/earth/free/google-earth
- ${PERL} -i -pe 's|/lib/ld-lsb.so.3\0\0\0|/lib/ld-linux.so.2\0|' ${WRKSRC}/opt/google/earth/free/googleearth-bin
+ @${REINPLACE_CMD} -i "" -e 's|^# Set the home.*|GOOGLEEARTH_DATA_PATH=${DATADIR}|' ${WRKSRC}/bin/googleearth
+ @${REINPLACE_CMD} -i "" -e "s|^# Let's boogie.*|rm -f \$${HOME}/.googleearth/instance-running-lock|" ${WRKSRC}/bin/googleearth
+ @${REINPLACE_CMD} -i "" -e 's/^TMPPATH.*/exit 0/' ${WRKSRC}/postinstall.sh
+ @${REINPLACE_CMD} -i "" -e 's|\"\$$SETUP_INSTALLPATH/|\"${WRKSRC}/|' ${WRKSRC}/postinstall.sh
+ @${REINPLACE_CMD} -i "" -e 's|\$$SETUP_INSTALLPATH/googleearth |${PREFIX}/bin/googleearth |' ${WRKSRC}/postinstall.sh
+ ${PERL} -i -pe 's|/lib/ld-lsb.so.3\0\0\0|/lib/ld-linux.so.2\0|' ${WRKSRC}/googleearth-bin
+
+do-build:
+ @${SETENV} SETUP_INSTALLPATH=${DATADIR} ${WRKSRC}/postinstall.sh
+ @cd ${WRKSRC} && ${RM} -rf setup.* preuninstall.sh postinstall.sh \
+ bin/googleearth.orig
pre-su-install:
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${WRKSRC}
do-install:
${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${FILESDIR}/googleearth-mimetypes.xml ${PREFIX}/share/mime/packages/
+ ${INSTALL_DATA} ${WRKSRC}/googleearth-mimetypes.xml ${PREFIX}/share/mime/packages/
${INSTALL_DATA} ${WRKSRC}/Google-googleearth.desktop ${PREFIX}/share/applications/googleearth.desktop
- ${CP} -rp ${WRKSRC}/opt/google/earth/free/* ${DATADIR}
+ ${CP} -rp ${WRKSRC}/* ${DATADIR}
${RM} -f ${DATADIR}/googleearth-mimetypes.xml ${DATADIR}/googleearth.desktop
- ${INSTALL_SCRIPT} ${FILESDIR}/browserwrapper ${DATADIR}
- ${LN} -sf ${DATADIR}/googleearth ${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${FILESDIR}/browserwrapper ${DATADIR}/bin
+ ${LN} -sf ${DATADIR}/bin/googleearth ${PREFIX}/bin/
-@update-mime-database ${PREFIX}/share/mime
-@update-desktop-database