aboutsummaryrefslogtreecommitdiff
path: root/astro/gpsdrive/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-06-22 22:05:06 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-06-22 22:05:06 +0000
commitd0bd892b309fc89af659d6af4a08ca2cb68496d0 (patch)
tree80159dcd1c73c3b9cd17d4bc1b155e6a47778312 /astro/gpsdrive/Makefile
parente1369a19af3a59970056ae93700da8bcf2a997d2 (diff)
downloadports-d0bd892b309fc89af659d6af4a08ca2cb68496d0.tar.gz
ports-d0bd892b309fc89af659d6af4a08ca2cb68496d0.zip
- New LIB_DEPENDS syntax.
- USES=libtool. - Fix configure when $CC = gcc.
Notes
Notes: svn path=/head/; revision=358836
Diffstat (limited to 'astro/gpsdrive/Makefile')
-rw-r--r--astro/gpsdrive/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/astro/gpsdrive/Makefile b/astro/gpsdrive/Makefile
index 349adf798087..332dfd03510e 100644
--- a/astro/gpsdrive/Makefile
+++ b/astro/gpsdrive/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gpsdrive
PORTVERSION= 2.09
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= astro geography
MASTER_SITES= http://www.gpsdrive.de/packages/ \
LOCAL/beech
@@ -13,20 +13,18 @@ COMMENT= GPS navigation system
LICENSE= GPLv2
-LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
-USES= gmake perl5 pkgconfig
-USE_AUTOTOOLS= libtool
+USES= gmake libtool perl5 pkgconfig
USE_GNOME= gtk20
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-garmin
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib -lgmodule-2.0
MAKE_JOBS_UNSAFE= yes
-MANLANG= "" de es
-
OPTIONS_DEFINE= NLS
.include <bsd.port.options.mk>
@@ -39,6 +37,7 @@ PLIST_SUB+= NLS="@comment "
.endif
post-patch:
+ @${REINPLACE_CMD} 's/test "$$CC" = "gcc"/false/' ${WRKSRC}/configure
.if ! ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} 's|SUBDIRS = src po man|SUBDIRS = src man|' \
${WRKSRC}/Makefile.in