aboutsummaryrefslogtreecommitdiff
path: root/astro/gpsdrive
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:35:55 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:35:55 +0000
commite1eb39c5be4ccb61e714ffae2265bf92eef681d6 (patch)
tree66c3141ec2deea0af71114d8f9f85c976491f469 /astro/gpsdrive
parent451c73b09ff2552eb841fd00f31131b1c1cd5a0a (diff)
downloadports-e1eb39c5be4ccb61e714ffae2265bf92eef681d6.tar.gz
ports-e1eb39c5be4ccb61e714ffae2265bf92eef681d6.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead. add missing dependency to gettext.
Notes
Notes: svn path=/head/; revision=84823
Diffstat (limited to 'astro/gpsdrive')
-rw-r--r--astro/gpsdrive/Makefile4
-rw-r--r--astro/gpsdrive/files/patch-configure11
-rw-r--r--astro/gpsdrive/files/patch-src-Makefile.in18
3 files changed, 14 insertions, 19 deletions
diff --git a/astro/gpsdrive/Makefile b/astro/gpsdrive/Makefile
index 0bad2b3b5cb0..79e3ac8bfe60 100644
--- a/astro/gpsdrive/Makefile
+++ b/astro/gpsdrive/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gpsdrive
PORTVERSION= 1.31
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= http://gpsdrive.kraftvoll.at/ \
http://gpsdrive.dotdeguy.de/ \
@@ -19,8 +20,9 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/pre/}
MAINTAINER= molter@gufi.org
COMMENT= A GPS navigation system
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
+USE_GETOPT_LONG=yes
USE_PERL5= yes
USE_GMAKE= yes
USE_GNOME= gdkpixbuf
diff --git a/astro/gpsdrive/files/patch-configure b/astro/gpsdrive/files/patch-configure
new file mode 100644
index 000000000000..0fefcf80cbb9
--- /dev/null
+++ b/astro/gpsdrive/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Sat Dec 7 06:51:08 2002
++++ configure Fri Jul 11 15:42:44 2003
+@@ -12623,8 +12623,6 @@
+
+
+
+-CFLAGS="-O2 -Wall"
+-CXXFLAGS="$CFLAGS"
+
+
+ # Check whether --with-pentiumpro or --without-pentiumpro was given.
diff --git a/astro/gpsdrive/files/patch-src-Makefile.in b/astro/gpsdrive/files/patch-src-Makefile.in
index 81dfd61321f8..37e0df52b2d3 100644
--- a/astro/gpsdrive/files/patch-src-Makefile.in
+++ b/astro/gpsdrive/files/patch-src-Makefile.in
@@ -1,14 +1,5 @@
--- src/Makefile.in.orig Thu Aug 8 23:52:40 2002
+++ src/Makefile.in Thu Aug 8 23:54:21 2002
-@@ -117,7 +117,7 @@
-
- # gpsdrive_LDADD= $(GLIB_LIBS) $(GTK_LIBS) $(PIXLIBS)
- #gpsdrive_LDADD=@LIBS@
--gpsdrive_LDADD = @XLIBS@
-+gpsdrive_LDADD = @XLIBS@ -lgnugetopt
- # gpsdrive_CFLAGS=@CFLAGS@
- # libgpsd_a_CFLAGS=@CFLAGS@
- # CFLAGS=
@@ -173,7 +173,7 @@
am_friendsd_OBJECTS = friendsd.$(OBJEXT)
@@ -18,12 +9,3 @@
friendsd_DEPENDENCIES =
friendsd_LDFLAGS =
@DISABLEGARMIN_TRUE@am_garble_OBJECTS =
-@@ -183,7 +183,7 @@
- @DISABLEGARMIN_FALSE@ garmin_link.$(OBJEXT) \
- @DISABLEGARMIN_FALSE@ garmin_util.$(OBJEXT)
- garble_OBJECTS = $(am_garble_OBJECTS)
--garble_LDADD = $(LDADD)
-+garble_LDADD = $(LDADD) -lgnugetopt
- garble_DEPENDENCIES =
- garble_LDFLAGS =
- am_gpsd_OBJECTS = gpsd.$(OBJEXT)