aboutsummaryrefslogtreecommitdiff
path: root/astro/indiwebmanagerapp
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2021-05-23 06:42:14 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2021-05-23 06:43:50 +0000
commit5604cde7d16a31a77d55611ab235ec61dc19b6b7 (patch)
treee9d77c5bf92b3ceb035453964331fbbbdf27ec22 /astro/indiwebmanagerapp
parent1a68cb5c3414f3ba92dce8542fe1db9bd2da4d14 (diff)
downloadports-5604cde7d16a31a77d55611ab235ec61dc19b6b7.tar.gz
ports-5604cde7d16a31a77d55611ab235ec61dc19b6b7.zip
astro/indiwebmanagerapp: NEW: Graphical program to manage an INDI WebManager
A Graphical program to Manage, Configure, Launch, and Monitor an INDI WebManager on OS X, Linux and FreeBSD What it does: - Allows easy and extensive configuration of the options for an INDI Web Manager and an INDI server. - Makes it easy to set up a Stand alone INDI Server on OS X. - Allows the setup of an INDI Web Manager on an OS X machine (which was formerly VERY difficult) - Provides a GUI interface for Starting, Stoping, Accessing, Configuring, and Monitoring an INDI Web Manager and INDI Server on OS X and Linux WWW: https://github.com/rlancaste/INDIWebManagerApp
Diffstat (limited to 'astro/indiwebmanagerapp')
-rw-r--r--astro/indiwebmanagerapp/Makefile23
-rw-r--r--astro/indiwebmanagerapp/distinfo3
-rw-r--r--astro/indiwebmanagerapp/pkg-descr13
-rw-r--r--astro/indiwebmanagerapp/pkg-plist2
4 files changed, 41 insertions, 0 deletions
diff --git a/astro/indiwebmanagerapp/Makefile b/astro/indiwebmanagerapp/Makefile
new file mode 100644
index 000000000000..82da39d251f2
--- /dev/null
+++ b/astro/indiwebmanagerapp/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= indiwebmanagerapp
+DISTVERSION= 1.6
+CATEGORIES= astro
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Graphical program to manage an INDI WebManager
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= indiserver:devel/indi \
+ ${PYTHON_PKGNAMEPREFIX}indiweb>0:astro/py-indiweb@${PY_FLAVOR}
+
+USES= cmake iconv gettext kde:5 ninja qt:5 pkgconfig python:3.5+
+USE_KDE= auth bookmarks codecs completion config configwidgets \
+ coreaddons doctools i18n kio itemviews jobwidgets service \
+ solid widgetsaddons windowsystem xmlgui
+USE_QT= buildtools concurrent core dbus gui qmake_build network widgets \
+ xml
+USE_GITHUB= yes
+GH_ACCOUNT= rlancaste
+GH_PROJECT= INDIWebManagerApp
+
+.include <bsd.port.mk>
diff --git a/astro/indiwebmanagerapp/distinfo b/astro/indiwebmanagerapp/distinfo
new file mode 100644
index 000000000000..19dd6a73af4a
--- /dev/null
+++ b/astro/indiwebmanagerapp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1621750232
+SHA256 (rlancaste-INDIWebManagerApp-1.6_GH0.tar.gz) = 8bb0d62f6e208381a89997989105253eef8db692fb1d105fcaf5f70dd63a8cb2
+SIZE (rlancaste-INDIWebManagerApp-1.6_GH0.tar.gz) = 1474857
diff --git a/astro/indiwebmanagerapp/pkg-descr b/astro/indiwebmanagerapp/pkg-descr
new file mode 100644
index 000000000000..d2725739189b
--- /dev/null
+++ b/astro/indiwebmanagerapp/pkg-descr
@@ -0,0 +1,13 @@
+A Graphical program to Manage, Configure, Launch, and Monitor an INDI
+WebManager on OS X, Linux and FreeBSD
+
+What it does:
+- Allows easy and extensive configuration of the options for an INDI Web
+ Manager and an INDI server.
+- Makes it easy to set up a Stand alone INDI Server on OS X.
+- Allows the setup of an INDI Web Manager on an OS X machine (which was
+ formerly VERY difficult)
+- Provides a GUI interface for Starting, Stoping, Accessing, Configuring, and
+ Monitoring an INDI Web Manager and INDI Server on OS X and Linux
+
+WWW: https://github.com/rlancaste/INDIWebManagerApp
diff --git a/astro/indiwebmanagerapp/pkg-plist b/astro/indiwebmanagerapp/pkg-plist
new file mode 100644
index 000000000000..bf235ecabb6b
--- /dev/null
+++ b/astro/indiwebmanagerapp/pkg-plist
@@ -0,0 +1,2 @@
+bin/INDIWebManagerApp
+share/config.kcfg/INDIWebManagerApp.kcfg