aboutsummaryrefslogtreecommitdiff
path: root/astro/jday
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-05-15 07:37:25 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-05-15 07:37:25 +0000
commitcfe7d69a6574f9c4fedabb5f1319386097071379 (patch)
treef7a1a3de59a8a541bfe74f866288f4d99c3197f9 /astro/jday
parent1242265ae3b9f837285e9071dafe1321ef0b06a4 (diff)
downloadports-cfe7d69a6574f9c4fedabb5f1319386097071379.tar.gz
ports-cfe7d69a6574f9c4fedabb5f1319386097071379.zip
Update to 2.4.
Submitter takes maintainership. PR: ports/96061 Submitted by: Frank Laszlo <laszlof@vonostingroup.com>
Notes
Notes: svn path=/head/; revision=162415
Diffstat (limited to 'astro/jday')
-rw-r--r--astro/jday/Makefile13
-rw-r--r--astro/jday/distinfo6
-rw-r--r--astro/jday/files/patch-jday.c14
-rw-r--r--astro/jday/pkg-plist6
4 files changed, 13 insertions, 26 deletions
diff --git a/astro/jday/Makefile b/astro/jday/Makefile
index ff70061a3250..4d6406f73515 100644
--- a/astro/jday/Makefile
+++ b/astro/jday/Makefile
@@ -5,17 +5,24 @@
# $FreeBSD$
PORTNAME= jday
-PORTVERSION= 1.3
+PORTVERSION= 2.4
CATEGORIES= astro
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= jday
+MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= laszlof@vonostingroup.com
COMMENT= Astronomical julian date calculator
+USE_GNOME= gnomehack
+INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= jday.1
+PLIST_FILES= bin/jday bin/j2d bin/dbd \
+ include/jday.h lib/libjday.a \
+ lib/libjday.so lib/libjday.so.2 \
+ lib/libjday.la libdata/pkgconfig/jday.pc
+
.include <bsd.port.mk>
diff --git a/astro/jday/distinfo b/astro/jday/distinfo
index af04ce52cee7..52d0320f7ff1 100644
--- a/astro/jday/distinfo
+++ b/astro/jday/distinfo
@@ -1,3 +1,3 @@
-MD5 (jday-1.3.tar.gz) = 4b6e8e4c9322a50322e0eebf86cb32f4
-SHA256 (jday-1.3.tar.gz) = 45a3c1bc2657f3099a43e6ce408b58d49e06fa13190a7f3d5a0973d34a72b2e7
-SIZE (jday-1.3.tar.gz) = 211601
+MD5 (jday-2.4.tar.gz) = 817af56005d1346677271ed2fab63ef5
+SHA256 (jday-2.4.tar.gz) = 3b15f3a1b552ffae7c343bd47bf89e8073da9ef8c2ec6d79b90d56f8c3a06fda
+SIZE (jday-2.4.tar.gz) = 337012
diff --git a/astro/jday/files/patch-jday.c b/astro/jday/files/patch-jday.c
deleted file mode 100644
index 4b710b6776b2..000000000000
--- a/astro/jday/files/patch-jday.c
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- jday.c.orig Mon Dec 30 16:49:30 2002
-+++ jday.c Mon Dec 30 16:49:44 2002
-@@ -122,7 +122,7 @@
- if ( day < 1 ) day = 1;
- case 3:
- if ( ! strcmp((const char *)argv[1], (const char *) "-d") ) {
-- if ( 3 != sscanf( argv[2], "%d/%d/%d", & year, & mo, & day ) ) {
-+ if ( 3 != sscanf( argv[2], "%ld/%d/%d", & year, & mo, & day ) ) {
- fprintf( stderr, "failed sscanf for ymd\n" );
- exit (-1);
- } else {
diff --git a/astro/jday/pkg-plist b/astro/jday/pkg-plist
deleted file mode 100644
index af7db0a3a91a..000000000000
--- a/astro/jday/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-@comment $FreeBSD$
-bin/dbd
-bin/j2d
-bin/jday
-include/jday.h
-lib/libjday.a