aboutsummaryrefslogtreecommitdiff
path: root/astro/kosmorro
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-03-09 20:40:25 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-03-09 20:40:25 +0000
commit86d23c3c9ca2736a1b1bae74136674a17fbd47fc (patch)
tree29228208b476cf7c664d967d7e3cb9746fbae261 /astro/kosmorro
parent12ec26904cd2f3c9093d5b3f4b07c71f0dbf30b9 (diff)
downloadports-86d23c3c9ca2736a1b1bae74136674a17fbd47fc.tar.gz
ports-86d23c3c9ca2736a1b1bae74136674a17fbd47fc.zip
textproc/rubygem-ronn is BROKEN on 11.4: do not build manpages.
Since I´m there define noflavors.
Notes
Notes: svn path=/head/; revision=567955
Diffstat (limited to 'astro/kosmorro')
-rw-r--r--astro/kosmorro/Makefile19
-rw-r--r--astro/kosmorro/pkg-plist4
2 files changed, 18 insertions, 5 deletions
diff --git a/astro/kosmorro/Makefile b/astro/kosmorro/Makefile
index d18779eab8a4..9a0e6e39edfb 100644
--- a/astro/kosmorro/Makefile
+++ b/astro/kosmorro/Makefile
@@ -12,7 +12,6 @@ COMMENT= Ephemerides computation
LICENSE= AGPLv3
BUILD_DEPENDS= ${PYNUMPY} \
- ronn:textproc/rubygem-ronn \
${PYTHON_PKGNAMEPREFIX}skyfield>0:astro/py-skyfield@${PY_FLAVOR}\
${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${PY_FLAVOR}\
${PYTHON_PKGNAMEPREFIX}tabulate>0:devel/py-tabulate@${PY_FLAVOR}\
@@ -29,7 +28,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pipenv>0:devel/py-pipenv@${PY_FLAVOR} \
USE_GITHUB= yes
USES= python:3.7+ shebangfix
-USE_PYTHON= distutils
+USE_PYTHON= distutils noflavors
SHEBANG_FILES= ${PORTNAME}
OPTIONS_DEFINE= PDF
@@ -39,14 +38,28 @@ PDF_RUN_DEPENDS=pdflatex:print/tex-formats
NO_ARCH= yes
+.include <bsd.port.pre.mk>
+
+# ronn is broken on 11.x => do not build manpages
+.if ${OSVERSION} < 1200000
+PLIST_SUB+= MAN="@comment "
+.else
+BUILD_DEPENDS+= ronn:textproc/rubygem-ronn
+PLIST_SUB+= MAN=""
+.endif
+
pre-configure:
${REINPLACE_CMD} -e 's|python3|${PYTHON_CMD}|' ${WRKSRC}/Makefile
+.if ${OSVERSION} < 1200000
+ ${REINPLACE_CMD} -e 's|i18n manpages|manpages|' ${WRKSRC}/Makefile
+.else
post-build:
(cd ${WRKSRC} && LC_ALL=C.UTF-8 ${MAKE} manpages)
+.endif
do-test: install
#(cd ${WRKSRC} && ${MAKE} test)
${DO_NADA} # It uses unittest-data-provider which is deprecated
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/astro/kosmorro/pkg-plist b/astro/kosmorro/pkg-plist
index 91925343dbcc..0b767fc388dd 100644
--- a/astro/kosmorro/pkg-plist
+++ b/astro/kosmorro/pkg-plist
@@ -88,5 +88,5 @@ bin/kosmorro
%%PYTHON_SITELIBDIR%%/test/ephemerides.py
%%PYTHON_SITELIBDIR%%/test/events.py
%%PYTHON_SITELIBDIR%%/test/testutils.py
-man/man1/kosmorro.1.gz
-man/man7/kosmorro.7.gz
+%%MAN%%man/man1/kosmorro.1.gz
+%%MAN%%man/man7/kosmorro.7.gz