aboutsummaryrefslogtreecommitdiff
path: root/astro/libosmium/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-04-12 12:40:46 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-04-12 12:40:46 +0000
commit459d99b378c284f9e182adfe48b4203afcc35b66 (patch)
treea5f836289b362d0496b7c58c5f47db1b13b660b9 /astro/libosmium/Makefile
parent0ac22f8d9c2226481eef6dfa554665f7a885afcd (diff)
downloadports-459d99b378c284f9e182adfe48b4203afcc35b66.tar.gz
ports-459d99b378c284f9e182adfe48b4203afcc35b66.zip
- Update to 2.14.0
Notes
Notes: svn path=/head/; revision=467152
Diffstat (limited to 'astro/libosmium/Makefile')
-rw-r--r--astro/libosmium/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/astro/libosmium/Makefile b/astro/libosmium/Makefile
index bd5277b77a3a..f6eecc3631b5 100644
--- a/astro/libosmium/Makefile
+++ b/astro/libosmium/Makefile
@@ -2,16 +2,15 @@
# $FreeBSD$
PORTNAME= libosmium
-PORTVERSION= 2.13.1
+PORTVERSION= 2.14.0
DISTVERSIONPREFIX= v
-PORTREVISION= 4
CATEGORIES= astro geography devel
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Fast and flexible C++ library for working with OpenStreetMap data
LICENSE= BSL
-LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_powerpc64= fails to compile: types_from_string.hpp: error: 'strtoll' is not a member of 'std'
@@ -20,8 +19,10 @@ LIB_DEPENDS= libgdal.so:graphics/gdal \
libgeos.so:graphics/geos \
libexpat.so:textproc/expat2
BUILD_DEPENDS= sparsehash>=0:devel/sparsehash \
- ${LOCALBASE}/include/utf8.h:devel/utf8cpp
-RUN_DEPENDS= ${LOCALBASE}/include/utf8.h:devel/utf8cpp
+ ${LOCALBASE}/include/utf8.h:devel/utf8cpp \
+ ${LOCALBASE}/include/protozero/version.hpp:devel/protozero
+RUN_DEPENDS= ${LOCALBASE}/include/utf8.h:devel/utf8cpp \
+ ${LOCALBASE}/include/protozero/version.hpp:devel/protozero
USE_GITHUB= yes
GH_ACCOUNT= osmcode
@@ -29,12 +30,11 @@ GH_ACCOUNT= osmcode
USES= cmake compiler:c++11-lib
CMAKE_ARGS= -DBUILD_EXAMPLES:BOOL=OFF
-# if/when corresponding ports appear in the tree, these will need to
-# be turned from depends
-CMAKE_ARGS+= -DINSTALL_GDALCPP:BOOL=ON \
- -DINSTALL_PROTOZERO:BOOL=ON
+# if/when corresponding port appears in the tree, this will need to
+# be turned into dependency
+CMAKE_ARGS+= -DINSTALL_GDALCPP:BOOL=ON
-# though it builds tests, the library itself is header-only
+# although it builds tests the library itself is header-only
NO_ARCH= yes
PORTDOCS= *