aboutsummaryrefslogtreecommitdiff
path: root/astro/libosmium
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-23 16:43:27 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-23 16:43:27 +0000
commit603e165af1c97763ee0c5f6de99048dc0b34f4bf (patch)
tree59424ba6eb7231f76fb5e0d9b6151e11cfe7329b /astro/libosmium
parentc6575e46c5c83b01ded9e61582b93e6778969125 (diff)
downloadports-603e165af1c97763ee0c5f6de99048dc0b34f4bf.tar.gz
ports-603e165af1c97763ee0c5f6de99048dc0b34f4bf.zip
- Update osmium to 2.10.3 and rename to libosmium
Notes
Notes: svn path=/head/; revision=426943
Diffstat (limited to 'astro/libosmium')
-rw-r--r--astro/libosmium/Makefile41
-rw-r--r--astro/libosmium/distinfo3
-rw-r--r--astro/libosmium/files/patch-include_osmium_util_endian.hpp13
-rw-r--r--astro/libosmium/pkg-descr11
-rw-r--r--astro/libosmium/pkg-plist177
5 files changed, 245 insertions, 0 deletions
diff --git a/astro/libosmium/Makefile b/astro/libosmium/Makefile
new file mode 100644
index 000000000000..ee8fa58fe49d
--- /dev/null
+++ b/astro/libosmium/Makefile
@@ -0,0 +1,41 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libosmium
+PORTVERSION= 2.10.3
+DISTVERSIONPREFIX= v
+CATEGORIES= astro geography devel
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Fast and flexible C++ library for working with OpenStreetMap data
+
+LICENSE= BSL
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libgdal.so:graphics/gdal \
+ libboost_regex.so:devel/boost-libs \
+ libgeos.so:graphics/geos \
+ libexpat.so:textproc/expat2
+BUILD_DEPENDS= sparsehash>=0:devel/sparsehash
+
+USE_GITHUB= yes
+GH_ACCOUNT= osmcode
+
+USES= cmake compiler:c++11-lib
+CMAKE_ARGS= -DBUILD_EXAMPLES:BOOL=OFF
+
+# though it build tests, the library itself it header-only
+NO_ARCH= yes
+
+PORTDOCS= *
+
+OPTIONS_DEFINE= TEST DOCS
+OPTIONS_DEFAULT= TEST
+TEST_TEST_TARGET= test
+TEST_CMAKE_BOOL= BUILD_TESTING
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CHANGELOG.md ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/astro/libosmium/distinfo b/astro/libosmium/distinfo
new file mode 100644
index 000000000000..be3bb20ec8ef
--- /dev/null
+++ b/astro/libosmium/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1479910332
+SHA256 (osmcode-libosmium-v2.10.3_GH0.tar.gz) = 9254a276d5e2c1b172c3bdd11d284f3ef5ffcfc296e685c57e59233d641fd229
+SIZE (osmcode-libosmium-v2.10.3_GH0.tar.gz) = 428643
diff --git a/astro/libosmium/files/patch-include_osmium_util_endian.hpp b/astro/libosmium/files/patch-include_osmium_util_endian.hpp
new file mode 100644
index 000000000000..52e8a08a7f14
--- /dev/null
+++ b/astro/libosmium/files/patch-include_osmium_util_endian.hpp
@@ -0,0 +1,13 @@
+--- include/osmium/util/endian.hpp.orig 2016-11-20 16:25:23 UTC
++++ include/osmium/util/endian.hpp
+@@ -35,7 +35,9 @@ DEALINGS IN THE SOFTWARE.
+
+ // Windows is only available for little endian architectures
+ // http://stackoverflow.com/questions/6449468/can-i-safely-assume-that-windows-installations-will-always-be-little-endian
+-#if !defined(_WIN32) && !defined(__APPLE__)
++#if defined(__FreeBSD__)
++# include <sys/endian.h>
++#elif !defined(_WIN32) && !defined(__APPLE__)
+ # include <endian.h>
+ #else
+ # define __LITTLE_ENDIAN 1234
diff --git a/astro/libosmium/pkg-descr b/astro/libosmium/pkg-descr
new file mode 100644
index 000000000000..bdbf759385ea
--- /dev/null
+++ b/astro/libosmium/pkg-descr
@@ -0,0 +1,11 @@
+The Osmium Library has extensive support for all types of OSM
+entities: nodes, ways, relations, and changesets. It allows reading
+from and writing to OSM files in XML and PBF formats, including
+change files and full history files. Osmium can store OSM data in
+memory and on disk in various formats and using various indexes.
+Its easy to use handler interface allows you to quickly write data
+filtering and conversion functions. Osmium can create WKT, WKB,
+OGR, GEOS and GeoJSON geometries for easy conversion into many GIS
+formats and it can assemble multipolygons from ways and relations.
+
+WWW: http://osmcode.org/libosmium/
diff --git a/astro/libosmium/pkg-plist b/astro/libosmium/pkg-plist
new file mode 100644
index 000000000000..31c74a58bb3d
--- /dev/null
+++ b/astro/libosmium/pkg-plist
@@ -0,0 +1,177 @@
+include/osmium/area/assembler.hpp
+include/osmium/area/detail/node_ref_segment.hpp
+include/osmium/area/detail/proto_ring.hpp
+include/osmium/area/detail/segment_list.hpp
+include/osmium/area/detail/vector.hpp
+include/osmium/area/multipolygon_collector.hpp
+include/osmium/area/problem_reporter.hpp
+include/osmium/area/problem_reporter_exception.hpp
+include/osmium/area/problem_reporter_ogr.hpp
+include/osmium/area/problem_reporter_stream.hpp
+include/osmium/area/stats.hpp
+include/osmium/builder/attr.hpp
+include/osmium/builder/builder.hpp
+include/osmium/builder/builder_helper.hpp
+include/osmium/builder/osm_object_builder.hpp
+include/osmium/diff_handler.hpp
+include/osmium/diff_iterator.hpp
+include/osmium/diff_visitor.hpp
+include/osmium/dynamic_handler.hpp
+include/osmium/experimental/flex_reader.hpp
+include/osmium/fwd.hpp
+include/osmium/geom/coordinates.hpp
+include/osmium/geom/factory.hpp
+include/osmium/geom/geojson.hpp
+include/osmium/geom/geos.hpp
+include/osmium/geom/haversine.hpp
+include/osmium/geom/mercator_projection.hpp
+include/osmium/geom/ogr.hpp
+include/osmium/geom/projection.hpp
+include/osmium/geom/rapid_geojson.hpp
+include/osmium/geom/relations.hpp
+include/osmium/geom/tile.hpp
+include/osmium/geom/util.hpp
+include/osmium/geom/wkb.hpp
+include/osmium/geom/wkt.hpp
+include/osmium/handler.hpp
+include/osmium/handler/chain.hpp
+include/osmium/handler/check_order.hpp
+include/osmium/handler/disk_store.hpp
+include/osmium/handler/dump.hpp
+include/osmium/handler/node_locations_for_ways.hpp
+include/osmium/handler/object_relations.hpp
+include/osmium/index/bool_vector.hpp
+include/osmium/index/detail/create_map_with_fd.hpp
+include/osmium/index/detail/mmap_vector_anon.hpp
+include/osmium/index/detail/mmap_vector_base.hpp
+include/osmium/index/detail/mmap_vector_file.hpp
+include/osmium/index/detail/tmpfile.hpp
+include/osmium/index/detail/vector_map.hpp
+include/osmium/index/detail/vector_multimap.hpp
+include/osmium/index/id_set.hpp
+include/osmium/index/index.hpp
+include/osmium/index/map.hpp
+include/osmium/index/map/all.hpp
+include/osmium/index/map/dense_file_array.hpp
+include/osmium/index/map/dense_mem_array.hpp
+include/osmium/index/map/dense_mmap_array.hpp
+include/osmium/index/map/dummy.hpp
+include/osmium/index/map/sparse_file_array.hpp
+include/osmium/index/map/sparse_mem_array.hpp
+include/osmium/index/map/sparse_mem_map.hpp
+include/osmium/index/map/sparse_mem_table.hpp
+include/osmium/index/map/sparse_mmap_array.hpp
+include/osmium/index/multimap.hpp
+include/osmium/index/multimap/all.hpp
+include/osmium/index/multimap/hybrid.hpp
+include/osmium/index/multimap/sparse_file_array.hpp
+include/osmium/index/multimap/sparse_mem_array.hpp
+include/osmium/index/multimap/sparse_mem_multimap.hpp
+include/osmium/index/multimap/sparse_mmap_array.hpp
+include/osmium/index/node_locations_map.hpp
+include/osmium/io/any_compression.hpp
+include/osmium/io/any_input.hpp
+include/osmium/io/any_output.hpp
+include/osmium/io/bzip2_compression.hpp
+include/osmium/io/compression.hpp
+include/osmium/io/debug_output.hpp
+include/osmium/io/detail/debug_output_format.hpp
+include/osmium/io/detail/input_format.hpp
+include/osmium/io/detail/o5m_input_format.hpp
+include/osmium/io/detail/opl_input_format.hpp
+include/osmium/io/detail/opl_output_format.hpp
+include/osmium/io/detail/opl_parser_functions.hpp
+include/osmium/io/detail/output_format.hpp
+include/osmium/io/detail/pbf.hpp
+include/osmium/io/detail/pbf_decoder.hpp
+include/osmium/io/detail/pbf_input_format.hpp
+include/osmium/io/detail/pbf_output_format.hpp
+include/osmium/io/detail/protobuf_tags.hpp
+include/osmium/io/detail/queue_util.hpp
+include/osmium/io/detail/read_thread.hpp
+include/osmium/io/detail/read_write.hpp
+include/osmium/io/detail/string_table.hpp
+include/osmium/io/detail/string_util.hpp
+include/osmium/io/detail/write_thread.hpp
+include/osmium/io/detail/xml_input_format.hpp
+include/osmium/io/detail/xml_output_format.hpp
+include/osmium/io/detail/zlib.hpp
+include/osmium/io/error.hpp
+include/osmium/io/file.hpp
+include/osmium/io/file_compression.hpp
+include/osmium/io/file_format.hpp
+include/osmium/io/gzip_compression.hpp
+include/osmium/io/header.hpp
+include/osmium/io/input_iterator.hpp
+include/osmium/io/o5m_input.hpp
+include/osmium/io/opl_input.hpp
+include/osmium/io/opl_output.hpp
+include/osmium/io/output_iterator.hpp
+include/osmium/io/overwrite.hpp
+include/osmium/io/pbf_input.hpp
+include/osmium/io/pbf_output.hpp
+include/osmium/io/reader.hpp
+include/osmium/io/reader_iterator.hpp
+include/osmium/io/writer.hpp
+include/osmium/io/writer_options.hpp
+include/osmium/io/xml_input.hpp
+include/osmium/io/xml_output.hpp
+include/osmium/memory/buffer.hpp
+include/osmium/memory/collection.hpp
+include/osmium/memory/item.hpp
+include/osmium/memory/item_iterator.hpp
+include/osmium/object_pointer_collection.hpp
+include/osmium/opl.hpp
+include/osmium/osm.hpp
+include/osmium/osm/area.hpp
+include/osmium/osm/box.hpp
+include/osmium/osm/changeset.hpp
+include/osmium/osm/crc.hpp
+include/osmium/osm/diff_object.hpp
+include/osmium/osm/entity.hpp
+include/osmium/osm/entity_bits.hpp
+include/osmium/osm/item_type.hpp
+include/osmium/osm/location.hpp
+include/osmium/osm/node.hpp
+include/osmium/osm/node_ref.hpp
+include/osmium/osm/node_ref_list.hpp
+include/osmium/osm/object.hpp
+include/osmium/osm/object_comparisons.hpp
+include/osmium/osm/relation.hpp
+include/osmium/osm/segment.hpp
+include/osmium/osm/tag.hpp
+include/osmium/osm/timestamp.hpp
+include/osmium/osm/types.hpp
+include/osmium/osm/types_from_string.hpp
+include/osmium/osm/undirected_segment.hpp
+include/osmium/osm/way.hpp
+include/osmium/relations/collector.hpp
+include/osmium/relations/detail/member_meta.hpp
+include/osmium/relations/detail/relation_meta.hpp
+include/osmium/tags/filter.hpp
+include/osmium/tags/regex_filter.hpp
+include/osmium/tags/taglist.hpp
+include/osmium/thread/function_wrapper.hpp
+include/osmium/thread/pool.hpp
+include/osmium/thread/queue.hpp
+include/osmium/thread/util.hpp
+include/osmium/util/cast.hpp
+include/osmium/util/compatibility.hpp
+include/osmium/util/config.hpp
+include/osmium/util/delta.hpp
+include/osmium/util/double.hpp
+include/osmium/util/endian.hpp
+include/osmium/util/endian.hpp.orig
+include/osmium/util/file.hpp
+include/osmium/util/iterator.hpp
+include/osmium/util/memory.hpp
+include/osmium/util/memory_mapping.hpp
+include/osmium/util/minmax.hpp
+include/osmium/util/misc.hpp
+include/osmium/util/options.hpp
+include/osmium/util/progress_bar.hpp
+include/osmium/util/string.hpp
+include/osmium/util/timer.hpp
+include/osmium/util/verbose_output.hpp
+include/osmium/version.hpp
+include/osmium/visitor.hpp