aboutsummaryrefslogtreecommitdiff
path: root/astro/match
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-17 04:38:07 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-17 04:38:07 +0000
commita2c3ef380a5fd1116894cf3def78a88bce4f3a48 (patch)
treeffb54750bc37280ec9729f181b26d84418b4dd7f /astro/match
parent2abe897846df434e6872f083e0e1e4bd1b190984 (diff)
downloadports-a2c3ef380a5fd1116894cf3def78a88bce4f3a48.tar.gz
ports-a2c3ef380a5fd1116894cf3def78a88bce4f3a48.zip
add match
A program for matching star lists
Notes
Notes: svn path=/head/; revision=51645
Diffstat (limited to 'astro/match')
-rw-r--r--astro/match/Makefile18
-rw-r--r--astro/match/distinfo1
-rw-r--r--astro/match/pkg-comment1
-rw-r--r--astro/match/pkg-descr14
-rw-r--r--astro/match/pkg-plist3
5 files changed, 37 insertions, 0 deletions
diff --git a/astro/match/Makefile b/astro/match/Makefile
new file mode 100644
index 000000000000..068cdb487c42
--- /dev/null
+++ b/astro/match/Makefile
@@ -0,0 +1,18 @@
+# ex:ts=8
+# New ports collection makefile for: match
+# Date created: Dec 17, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= match
+PORTVERSION= 0.4
+CATEGORIES= astro
+MASTER_SITES= http://acd188a-005.rit.edu/match/
+
+MAINTAINER= ports@FreeBSD.org
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/astro/match/distinfo b/astro/match/distinfo
new file mode 100644
index 000000000000..75e4c457a31d
--- /dev/null
+++ b/astro/match/distinfo
@@ -0,0 +1 @@
+MD5 (match-0.4.tar.gz) = 26b2a8f7c3e2ac4ff474265e911ec4ec
diff --git a/astro/match/pkg-comment b/astro/match/pkg-comment
new file mode 100644
index 000000000000..270427bc3824
--- /dev/null
+++ b/astro/match/pkg-comment
@@ -0,0 +1 @@
+A program for matching star lists
diff --git a/astro/match/pkg-descr b/astro/match/pkg-descr
new file mode 100644
index 000000000000..6dc89d53021e
--- /dev/null
+++ b/astro/match/pkg-descr
@@ -0,0 +1,14 @@
+This program is designed to match up items in two different lists, which may
+have two different systems of coordinates. The program allows the two sets of
+coordinates to be related by a linear, quadratic, or cubic transformation. It
+is an implementation of the algorithm described in Valdes et al., Publications
+of the Astronomical Society of the Pacific, vol 107, page 1119 (1995).
+
+The program was designed and written to work on lists of stars and other
+astronomical objects, but it might be applied to other types of data. In order
+to match two lists of N points, the main algorithm calls for O(N^6) operations
+(yes, that's N-to-the-sixth), so it's not the most efficient choice. I find
+myself becoming impatient for N >= 100, but your mileage may vary. On the
+other hand, it does allow for arbitrary translation, rotation, and scaling...
+
+WWW: http://acd188a-005.rit.edu/match/
diff --git a/astro/match/pkg-plist b/astro/match/pkg-plist
new file mode 100644
index 000000000000..58924e5d9665
--- /dev/null
+++ b/astro/match/pkg-plist
@@ -0,0 +1,3 @@
+bin/match
+bin/project_coords
+bin/apply_match