aboutsummaryrefslogtreecommitdiff
path: root/astro/opencpn
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-07-12 02:14:23 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-07-12 02:14:23 +0000
commit43c9b0c5bc539452cc0f4da23f4ff1e08646554f (patch)
tree4f75d58f212e1c6a2723009313df006be5708afb /astro/opencpn
parent92e22122e819280ea0c18de3ddd7a8b8a25a3ead (diff)
downloadports-43c9b0c5bc539452cc0f4da23f4ff1e08646554f.tar.gz
ports-43c9b0c5bc539452cc0f4da23f4ff1e08646554f.zip
Correct the test for whether to disable sse extensions to x86-only.
While here, standardize on compiler:c++11-lang rather than -lib; these days, they are equivalent. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=506431
Diffstat (limited to 'astro/opencpn')
-rw-r--r--astro/opencpn/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/astro/opencpn/Makefile b/astro/opencpn/Makefile
index 82b4ab2d5807..eb617a4a9e07 100644
--- a/astro/opencpn/Makefile
+++ b/astro/opencpn/Makefile
@@ -22,7 +22,7 @@ USE_GITHUB= yes
GH_ACCOUNT= ${GH_PROJECT}
GH_PROJECT= OpenCPN
-USES= cmake compiler:c++11-lib gettext-tools gl gnome localbase
+USES= cmake compiler:c++11-lang gettext-tools gl gnome localbase
USE_CXXSTD= c++11
USE_GL= gl
USE_GNOME= cairo gdkpixbuf2 gtk20
@@ -36,14 +36,16 @@ LDFLAGS+= -Wl,--as-needed # ICE, SM, Xext
OPTIONS_DEFINE= DOCS
+.include <bsd.port.pre.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},' \
${WRKSRC}/src/mygdal/cpl_csv.cpp \
${WRKSRC}/src/mygdal/cpl_findfile.cpp \
${WRKSRC}/data/doc/help_en_US.html
-.if exists(/usr/lib/libstdc++.so)
+.if ${ARCH} != amd64 && ${ARCH} != i386
@${REINPLACE_CMD} -e '/-msse/d' -e '/-mssse3/d' \
-e '/-mavx2/d' ${WRKSRC}/CMakeLists.txt
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>