aboutsummaryrefslogtreecommitdiff
path: root/astro/py-RO/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2013-02-17 00:01:20 +0000
committerWen Heping <wen@FreeBSD.org>2013-02-17 00:01:20 +0000
commit0aba595f84c0722d477bdb3a419f9626a2d80f70 (patch)
treeb2973e93e260db3b8d79de71262da29ce950079f /astro/py-RO/Makefile
parentf639f41d7279eb74fca04e61261daea8bdd502a4 (diff)
downloadports-0aba595f84c0722d477bdb3a419f9626a2d80f70.tar.gz
ports-0aba595f84c0722d477bdb3a419f9626a2d80f70.zip
- Update to 3.2.0
- Trim Makefile headers [1] - Convert to optionsNG [1] PR: 173822 [1] Submitted by: Chris Petrik <c.petrik.sosa@gmail.com> [1]
Notes
Notes: svn path=/head/; revision=312394
Diffstat (limited to 'astro/py-RO/Makefile')
-rw-r--r--astro/py-RO/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/astro/py-RO/Makefile b/astro/py-RO/Makefile
index 6c66055141fc..a76ff93e1d3a 100644
--- a/astro/py-RO/Makefile
+++ b/astro/py-RO/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: py-RO
-# Date created: Dec 26, 2010
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= RO
-PORTVERSION= 2.9.3
+PORTVERSION= 3.2.0
CATEGORIES= astro python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,24 +13,27 @@ COMMENT= Package of Python astronomical utilities
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/core/numeric.py:${PORTSDIR}/math/py-numpy
RUN_DEPENDS:= ${BUILD_DEPENDS}
-OPTIONS= MATPLOTLIB "Add support for Matplotlib" Off \
- PYFITS "Add Support for PyFITS" On \
- PYGAME "Add Support for PyGame" Off
+OPTIONS_DEFINE= MATPLOTLIB PYFITS PYGAME
+OPTIONS_DEFAULT= PYFITS
+
+MATPLOTLIB_DESC= Add support for Matplotlib
+PYFITS_DESC= Add Support for PyFITS
+PYGAME_DESC= Add Support for PyGame
USE_PYTHON= yes
USE_PYDISTUTILS=easy_install
.include <bsd.port.pre.mk>
-.if defined(WITH_MATPLOTLIB)
+.if ${PORT_OPTIONS:MMATPLOTLIB}
RUN_DEPENDS+= ${PKGNAMEPREFIX}matplotlib>=0.98:${PORTSDIR}/math/py-matplotlib
.endif
-.if !defined(WITHOUT_PYFITS)
+.if ${PORT_OPTIONS:MPYFITS}
RUN_DEPENDS+= ${PKGNAMEPREFIX}pyfits>=1.1:${PORTSDIR}/astro/py-pyfits
.endif
-.if defined(WITH_PYGAME)
+.if ${PORT_OPTIONS:MPYGAME}
RUN_DEPENDS+= ${PKGNAMEPREFIX}game>=1.8.1:${PORTSDIR}/devel/py-game
.endif