aboutsummaryrefslogtreecommitdiff
path: root/astro/saoimage
diff options
context:
space:
mode:
authorMatthew Hunt <mph@FreeBSD.org>1998-04-17 21:27:32 +0000
committerMatthew Hunt <mph@FreeBSD.org>1998-04-17 21:27:32 +0000
commit90dca13aaafd21baee1e32af372c4573ba19d036 (patch)
tree59c7e54b06ddc5dd9e1fe3927417d2da97722f39 /astro/saoimage
parentbf2b0f108a690d6c39c283f7bf601720b521556f (diff)
downloadports-90dca13aaafd21baee1e32af372c4573ba19d036.tar.gz
ports-90dca13aaafd21baee1e32af372c4573ba19d036.zip
Import of saoimage, a viewer for FITS files (which are used in
professional astronomy). PR: 5805 Submitted by: giffunip@asme.org
Notes
Notes: svn path=/head/; revision=10544
Diffstat (limited to 'astro/saoimage')
-rw-r--r--astro/saoimage/Makefile29
-rw-r--r--astro/saoimage/distinfo1
-rw-r--r--astro/saoimage/files/patch-aa193
-rw-r--r--astro/saoimage/files/patch-ab19
-rw-r--r--astro/saoimage/files/patch-ad22
-rw-r--r--astro/saoimage/pkg-comment1
-rw-r--r--astro/saoimage/pkg-descr21
-rw-r--r--astro/saoimage/pkg-plist2
8 files changed, 288 insertions, 0 deletions
diff --git a/astro/saoimage/Makefile b/astro/saoimage/Makefile
new file mode 100644
index 000000000000..df13b54b4be0
--- /dev/null
+++ b/astro/saoimage/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: saoimage
+# Version required: 1.22
+# Date created: 21 Feb 1998
+# Whom: giffunip@asme.org
+#
+# $Id$
+#
+
+DISTNAME= saoimage-1.22
+CATEGORIES= astro
+MASTER_SITES= ftp://cfa-ftp.harvard.edu/pub/gsc/SAOimage/
+
+MAINTAINER= giffunip@asme.org
+
+MAKEFILE= makefile
+ALL_TARGET= FreeBSD
+INSTALL_TARGET= -f makefile.$(ALL_TARGET) install_saobin install_saoman
+
+MANL= saoimage.l
+USE_X11= yes
+
+pre-patch:
+ $(CP) $(WRKSRC)/makefile.sun $(WRKSRC)/makefile.$(ALL_TARGET)
+pre-build:
+ @(cd ${WRKSRC}; ${MAKE} ${MAKEFILE} clean )
+post-install:
+ strip $(PREFIX)/bin/saoimage
+
+.include <bsd.port.mk>
diff --git a/astro/saoimage/distinfo b/astro/saoimage/distinfo
new file mode 100644
index 000000000000..a6e20ac6486a
--- /dev/null
+++ b/astro/saoimage/distinfo
@@ -0,0 +1 @@
+MD5 (saoimage-1.22.tar.gz) = 2a799cb77b81cb2cb205920e01f11780
diff --git a/astro/saoimage/files/patch-aa b/astro/saoimage/files/patch-aa
new file mode 100644
index 000000000000..5e35b1f85e0c
--- /dev/null
+++ b/astro/saoimage/files/patch-aa
@@ -0,0 +1,193 @@
+*** makefile.FreeBSD.orig Fri Apr 17 02:36:13 1998
+--- makefile.FreeBSD Fri Apr 17 02:39:37 1998
+***************
+*** 1,5 ****
+ #
+! # makefile.sun for SAOimage # Sun workstations using SunOS 4.* and MIT Xlib
+ #
+ # To build:
+ # % make (or `make all') # build libs/program as necessary
+--- 1,5 ----
+ #
+! # makefile.FreeBSD for SAOimage # x86 workstations using FreeBSD and MIT Xlib
+ #
+ # To build:
+ # % make (or `make all') # build libs/program as necessary
+***************
+*** 36,44 ****
+ # FBCONFIG_2, which is set to the value of IMTOOLRC in the definition of
+ # the CFLAGS macro below.)
+
+! SAOBINDIR = $(ROOT)/usr/local/bin/
+! SAOMANDIR = $(ROOT)/usr/man/manl/
+! IMTRCDIR = $(ROOT)/usr/local/lib/
+
+ IMTOOLRC = $(IMTRCDIR)imtoolrc
+ FIFO_I = $(ROOT)/dev/imt1i
+--- 36,44 ----
+ # FBCONFIG_2, which is set to the value of IMTOOLRC in the definition of
+ # the CFLAGS macro below.)
+
+! SAOBINDIR = $(ROOT)$(PREFIX)/bin/
+! SAOMANDIR = $(ROOT)$(PREFIX)/man/manl/
+! IMTRCDIR = $(ROOT)$(PREFIX)/lib/
+
+ IMTOOLRC = $(IMTRCDIR)imtoolrc
+ FIFO_I = $(ROOT)/dev/imt1i
+***************
+*** 46,52 ****
+ FIFO_LN = $(ROOT)/dev/imt1
+
+ # Compiler specification.
+! CC = cc
+ # Uncomment these two lines to compile with gcc (add any optimizers you wish).
+ #CC = gcc -finline-functions -fdelayed-branch -fstrength-reduce
+ # Delayed branches could win big on RISC: many inner loops have branches
+--- 46,52 ----
+ FIFO_LN = $(ROOT)/dev/imt1
+
+ # Compiler specification.
+! #CC = cc
+ # Uncomment these two lines to compile with gcc (add any optimizers you wish).
+ #CC = gcc -finline-functions -fdelayed-branch -fstrength-reduce
+ # Delayed branches could win big on RISC: many inner loops have branches
+***************
+*** 62,86 ****
+ # fired up on a system where the fifos are absent. Other than this, the
+ # standalone operation is unhindered.
+
+! IFLAGS = -DFITS -DOIF -DIMTOOL
+
+ # MFLAGS: machine or library specific code.
+ # -DSUN - SunOS temp file name, IEEE floating point debug, and Sun keyboard
+ # -DLSB - byte swap for FITS (VAX and DECstations)
+ # -DSYSV - substitutes for getdtablesize() and setrlimit() not widely known
+ # -DPSCRIPT - hard copy output to a PostScript printer (else no hardcopy)
+
+! MFLAGS = -DSUN -DPSCRIPT -DQUIT
+
+ # OFLAGS: compiler optimization/debug options.
+
+! OFLAGS = -g -DDEBUG
+! #OFLAGS = -O
+
+ # ADFLAGS: architecture-dependent floating point flags, etc.
+
+ #ADFLAGS = -I/usr/openwin/share/include # ATTENTION: OpenWindows users...
+! ADFLAGS =
+
+ # Libraries that move about or may require special specification.
+ #
+--- 62,87 ----
+ # fired up on a system where the fifos are absent. Other than this, the
+ # standalone operation is unhindered.
+
+! IFLAGS = -DFITS -DOIF #-DIMTOOL
+
+ # MFLAGS: machine or library specific code.
+ # -DSUN - SunOS temp file name, IEEE floating point debug, and Sun keyboard
+ # -DLSB - byte swap for FITS (VAX and DECstations)
+ # -DSYSV - substitutes for getdtablesize() and setrlimit() not widely known
+ # -DPSCRIPT - hard copy output to a PostScript printer (else no hardcopy)
++ # -DMIRIAD - extras
+
+! MFLAGS = -DLSB -DSUN -DPSCRIPT -DQUIT
+
+ # OFLAGS: compiler optimization/debug options.
+
+! #OFLAGS = -g -DDEBUG
+! #OFLAGS = -O2 -m486 -pipe
+
+ # ADFLAGS: architecture-dependent floating point flags, etc.
+
+ #ADFLAGS = -I/usr/openwin/share/include # ATTENTION: OpenWindows users...
+! ADFLAGS = -I$(X11BASE)/include
+
+ # Libraries that move about or may require special specification.
+ #
+***************
+*** 88,110 ****
+ # usual link search path, i.e., it is not in /usr/lib, it may be necessary
+ # to specify its path fully in XLIB.
+
+! XLIB = -lX11
+! #XLIB = -L/usr/openwin/lib -lX11 # ATTENTION: OpenWindows users...
+ #F77LIB = -lF77 -lI77 -lU77
+ #LDFLAGS = -Bstatic
+
+ # END OF INSTALLATION DEPENDENT SETUP. ========================================
+ # It should not be necessary to edit anything below this line.
+
+! ARCH = sun
+ LINT = lint -b
+! MKNOD = /etc/mknod
+ MV = mv -f
+ RANLIB = ranlib
+ RM = rm -f
+ SHELL = /bin/sh
+
+! CFLAGS = $(OFLAGS) $(ADFLAGS) $(MFLAGS) $(IFLAGS) -DFBCONFIG_2=\"$(IMTOOLRC)\"
+
+ # SAOimage libraries that live in subdirectories with their own makefiles.
+ # This definition must be kept in correspondence with the DEPLIBS target.
+--- 89,112 ----
+ # usual link search path, i.e., it is not in /usr/lib, it may be necessary
+ # to specify its path fully in XLIB.
+
+! XLIB = -L$(X11BASE)/lib -lX11
+! #XLIB = -L/usr/X11R6/lib -lX11 # ATTENTION: OpenWindows users...
+ #F77LIB = -lF77 -lI77 -lU77
++ F77LIB = -lf2c
+ #LDFLAGS = -Bstatic
+
+ # END OF INSTALLATION DEPENDENT SETUP. ========================================
+ # It should not be necessary to edit anything below this line.
+
+! ARCH = FreeBSD
+ LINT = lint -b
+! MKNOD = /sbin/mknod
+ MV = mv -f
+ RANLIB = ranlib
+ RM = rm -f
+ SHELL = /bin/sh
+
+! CFLAGS += $(ADFLAGS) $(MFLAGS) $(IFLAGS) -DFBCONFIG_2=\"$(IMTOOLRC)\"
+
+ # SAOimage libraries that live in subdirectories with their own makefiles.
+ # This definition must be kept in correspondence with the DEPLIBS target.
+***************
+*** 299,305 ****
+ $(MAKE) ARCFILE=$(TAPEDEV) tar
+
+
+! XLIBH = /usr/include/X11/Xlib.h /usr/include/X11/Xutil.h
+ STRUCT = hfiles/struct.h hfiles/buffer.h hfiles/color.h hfiles/control.h \
+ hfiles/coord.h hfiles/cursor.h hfiles/image.h hfiles/window.h
+ WORKS = $(XLIBH) $(STRUCT) hfiles/constant.h hfiles/extern.h hfiles/wcs.h
+--- 301,307 ----
+ $(MAKE) ARCFILE=$(TAPEDEV) tar
+
+
+! XLIBH = /usr/X11R6/include/X11/Xlib.h /usr/X11R6/include/X11/Xutil.h
+ STRUCT = hfiles/struct.h hfiles/buffer.h hfiles/color.h hfiles/control.h \
+ hfiles/coord.h hfiles/cursor.h hfiles/image.h hfiles/window.h
+ WORKS = $(XLIBH) $(STRUCT) hfiles/constant.h hfiles/extern.h hfiles/wcs.h
+***************
+*** 408,415 ****
+ defs/dispbox.def defs/magnibox.def defs/panbox.def \
+ defs/btnbox.def defs/colorbox.def defs/graphbox.def \
+ defs/desktop.def defs/cursor.def
+! mainkey.o : $(WORKS) /usr/include/X11/keysym.h \
+! /usr/include/X11/keysymdef.h
+ mainslct.o : $(WORKS)
+ mainutil.o : $(XLIBH) $(STRUCT) hfiles/extern.h
+ menuctrl.o : $(WORKS) btnlib/buttons.h
+--- 410,417 ----
+ defs/dispbox.def defs/magnibox.def defs/panbox.def \
+ defs/btnbox.def defs/colorbox.def defs/graphbox.def \
+ defs/desktop.def defs/cursor.def
+! mainkey.o : $(WORKS) /usr/X11R6/include/X11/keysym.h \
+! /usr/X11R6/include/X11/keysymdef.h
+ mainslct.o : $(WORKS)
+ mainutil.o : $(XLIBH) $(STRUCT) hfiles/extern.h
+ menuctrl.o : $(WORKS) btnlib/buttons.h
diff --git a/astro/saoimage/files/patch-ab b/astro/saoimage/files/patch-ab
new file mode 100644
index 000000000000..28706552b85e
--- /dev/null
+++ b/astro/saoimage/files/patch-ab
@@ -0,0 +1,19 @@
+*** btnlib/makefile.orig Fri Feb 20 00:05:58 1998
+--- btnlib/makefile Fri Feb 20 00:24:12 1998
+***************
+*** 27,33 ****
+ press.o remote.o resize.o util.o
+
+ LIB = libbtn.a
+! XLIBH = /usr/include/X11/Xlib.h
+ #XLIBH = /usr/openwin/share/include/X11/Xlib.h #for OpenWindows
+
+ all: $(LIB)
+--- 27,33 ----
+ press.o remote.o resize.o util.o
+
+ LIB = libbtn.a
+! XLIBH = $(X11BASE)/include/X11/Xlib.h
+ #XLIBH = /usr/openwin/share/include/X11/Xlib.h #for OpenWindows
+
+ all: $(LIB)
diff --git a/astro/saoimage/files/patch-ad b/astro/saoimage/files/patch-ad
new file mode 100644
index 000000000000..bedfe19d6e90
--- /dev/null
+++ b/astro/saoimage/files/patch-ad
@@ -0,0 +1,22 @@
+*** ctrldisk.c.orig Fri Feb 20 00:37:18 1998
+--- ctrldisk.c Fri Feb 20 00:38:56 1998
+***************
+*** 157,164 ****
+ int nbytes;
+ char *filename; /* [i]: name of file being accessed */
+ {
+ long lseek(); /* type not declared in <sys/file.h> */
+!
+ if( lseek(fd, (long)nbytes, L_SET) < 0 ) {
+ perror("lseek");
+ (void)fprintf(stderr, "Can't lseek %d bytes", nbytes);
+--- 157,165 ----
+ int nbytes;
+ char *filename; /* [i]: name of file being accessed */
+ {
++ #ifndef __FreeBSD__
+ long lseek(); /* type not declared in <sys/file.h> */
+! #endif
+ if( lseek(fd, (long)nbytes, L_SET) < 0 ) {
+ perror("lseek");
+ (void)fprintf(stderr, "Can't lseek %d bytes", nbytes);
diff --git a/astro/saoimage/pkg-comment b/astro/saoimage/pkg-comment
new file mode 100644
index 000000000000..260322f05ff4
--- /dev/null
+++ b/astro/saoimage/pkg-comment
@@ -0,0 +1 @@
+Smithsonian Astrophysical Observatory image utility for X
diff --git a/astro/saoimage/pkg-descr b/astro/saoimage/pkg-descr
new file mode 100644
index 000000000000..d5c49e0ae6f6
--- /dev/null
+++ b/astro/saoimage/pkg-descr
@@ -0,0 +1,21 @@
+SAOimage (pronounced S-A-0-image) displays astronomical images in the X11
+window environment. It was written by Mike Van Hilst while he was at the
+Smithsonian Astrophysical Observatory (SAO) in 1990 and is now maintained by
+Doug Mink also at the SAO. Online documentation is available at
+http://tdc-www.harvard.edu/software/saoimage.html
+
+Online help is available at
+http://tdc-www.harvard.edu/software/saoimage.html.
+
+Image files can be read directly, or image data may be passed through a
+named pipe (Unix) or a mailbox (VMS) from IRAF display tasks. SAOimage
+provides a large selection of options for zooming, panning, scaling,
+coloring, pixel readback, display blinking, and region specification. User
+interactions are generally performed with the mouse, but keyboard
+alternatives are often available.
+
+The SAOimage desktop includes, a main image display window, a button menu
+panel, a display magnifier, a pan and zoom reference image, and a color bar.
+A color table graph window can be brought up by clicking on the color bar.
+
+Bugs or problems should be reported to Doug Mink at dmink@cfa.harvard.edu.
diff --git a/astro/saoimage/pkg-plist b/astro/saoimage/pkg-plist
new file mode 100644
index 000000000000..c900fd10926f
--- /dev/null
+++ b/astro/saoimage/pkg-plist
@@ -0,0 +1,2 @@
+bin/saoimage
+man/manl/saoimage.l.gz