aboutsummaryrefslogtreecommitdiff
path: root/astro/stardates
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-13 11:55:45 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-13 11:55:45 +0000
commitc6c8d4842e353319b4b76428325dad706502c8b3 (patch)
tree508d07607f925db9b567e41478cf82500b28e635 /astro/stardates
parent45ebb2b3e8a620c9bb838d4e1b650cfed2cd2fa1 (diff)
downloadports-c6c8d4842e353319b4b76428325dad706502c8b3.tar.gz
ports-c6c8d4842e353319b4b76428325dad706502c8b3.zip
Support staging
Notes
Notes: svn path=/head/; revision=344090
Diffstat (limited to 'astro/stardates')
-rw-r--r--astro/stardates/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/astro/stardates/Makefile b/astro/stardates/Makefile
index 40df1e677758..ddf5201ed6af 100644
--- a/astro/stardates/Makefile
+++ b/astro/stardates/Makefile
@@ -11,15 +11,15 @@ MASTER_SITES= ftp://ftp.cc.umanitoba.ca/startrek/stardates-pgms/ \
MAINTAINER= freebsd-ports@henrik.synth.no
COMMENT= Displays date in 5 formats (including stardate of course)
-NO_STAGE= yes
-MAN1= stardate.1
-PLIST_FILES= bin/stardate
+PLIST_FILES= bin/stardate man/man1/stardate.1.gz
do-build:
${CC} ${CFLAGS} ${WRKSRC}/stardate.c -o ${WRKSRC}/stardate
do-install:
- ${INSTALL} ${WRKSRC}/stardate ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/stardate.1 ${MAN1PREFIX}/man/man1/stardate.1
+ ${INSTALL} ${WRKSRC}/stardate ${STAGEDIR}${PREFIX}/bin
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/stardate
+ ${INSTALL_MAN} ${WRKSRC}/stardate.1 \
+ ${STAGEDIR}${MAN1PREFIX}/man/man1
.include <bsd.port.mk>