aboutsummaryrefslogtreecommitdiff
path: root/astro/stellarium/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-01-14 10:15:06 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-01-14 10:15:06 +0000
commit7c87e398999f29e2494c9854bc559efdf5b1458c (patch)
tree0f05ae42fa079d2fe4e4a9825d007bfe919aec01 /astro/stellarium/Makefile
parent537ebf43d0a7c0156b624cde253af0ca4aaf2017 (diff)
downloadports-7c87e398999f29e2494c9854bc559efdf5b1458c.tar.gz
ports-7c87e398999f29e2494c9854bc559efdf5b1458c.zip
Fix the logic so it actually works as intended.
Notes
Notes: svn path=/head/; revision=377005
Diffstat (limited to 'astro/stellarium/Makefile')
-rw-r--r--astro/stellarium/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/astro/stellarium/Makefile b/astro/stellarium/Makefile
index 4147c50787d5..158bd2d29546 100644
--- a/astro/stellarium/Makefile
+++ b/astro/stellarium/Makefile
@@ -64,8 +64,8 @@ post-install:
new=`${STAT} -f '%z' $$f` ; \
existing=`${STAT} -f '%z' \
${STAGEDIR}${DATADIR}/textures/$$f` ; \
- ${TEST} $$new -gt $$existing && \
- ${ECHO_CMD} "-- Replacing texture: $$f\
+ ${TEST} $$new -gt $$existing || continue ; \
+ ${ECHO_CMD} "-- Replacing texture: $$f\
(has larger file size)" ; \
${INSTALL_DATA} $$f ${STAGEDIR}${DATADIR}/textures ; \
done)