aboutsummaryrefslogtreecommitdiff
path: root/astro/stellarium/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-08-02 19:48:36 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-08-02 19:48:36 +0000
commit87a30f18c33211ca677f264a4a3c53f4c0459de1 (patch)
treee22fa4b093c130d200de78d65308be12dfb0336c /astro/stellarium/Makefile
parentdcec133efd409b56b73b972a8693c16a47feb185 (diff)
downloadports-87a30f18c33211ca677f264a4a3c53f4c0459de1.tar.gz
ports-87a30f18c33211ca677f264a4a3c53f4c0459de1.zip
Update Stellarium to version 0.13.0. It's a new major release, and is based
on Qt version 5 now; for those who are not comfortable with upgrading to the new version of Qt, `astro/stellarium-qt4' port is available, serving version 0.12.4. Add an UPDATING entry to alert users about this. While here, make scripting support optional in `astro/stellarium-qt4', since it allows to use one less dependency. Unfortunately, this is not applicable to 0.13.0 as required `x11-toolkits/qt5-declarative' port has USE_QT5=script unconditionally. Relax USE_GL knob for both ports: only libGL itself is required, not libGLU.
Notes
Notes: svn path=/head/; revision=363837
Diffstat (limited to 'astro/stellarium/Makefile')
-rw-r--r--astro/stellarium/Makefile21
1 files changed, 7 insertions, 14 deletions
diff --git a/astro/stellarium/Makefile b/astro/stellarium/Makefile
index 54a3a7559e67..2f3bc9b87a59 100644
--- a/astro/stellarium/Makefile
+++ b/astro/stellarium/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= stellarium
-PORTVERSION= 0.12.4
-PORTREVISION= 1
+PORTVERSION= 0.13.0
CATEGORIES= astro
MASTER_SITES= SF/${PORTNAME}/Stellarium-sources/${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -15,9 +14,8 @@ COMMENT= 3D photo-realistic sky renderer (planetarium)
LICENSE= GPLv2
USES= cmake gettext iconv
-USE_GL= glu
-USE_QT4= moc_build rcc_build uic_build qmake_build \
- corelib gui network opengl script
+USE_GL= gl
+USE_QT5= qmake_build buildtools core concurrent declarative linguist
INSTALLS_ICONS= yes
PORTDOCS= AUTHORS ChangeLog README
@@ -25,7 +23,7 @@ PORTDOCS= AUTHORS ChangeLog README
OPTIONS_DEFINE= MORE_STARS MULTIMEDIA DOCS
OPTIONS_DEFAULT= MULTIMEDIA
MORE_STARS_DESC= Install extra star catalogs (1.2GB)
-MULTIMEDIA_DESC= Sound and video support (via Phonon)
+MULTIMEDIA_DESC= Sound and video support
.include <bsd.port.options.mk>
@@ -42,18 +40,13 @@ PLIST_SUB+= MORE_STARS="@comment "
.endif
.if ${PORT_OPTIONS:MMULTIMEDIA}
-USE_QT4+= phonon
+USE_QT5+= multimedia
.else
CMAKE_ARGS+= -DENABLE_SOUND:BOOL=OFF
.endif
-post-patch: .SILENT
- ${REINPLACE_CMD} -e '/QTTEST/d' ${WRKSRC}/CMakeLists.txt
-# Avoid picking up the wrong `fixx11h.h' (`x11/kdelibs3' port installs one
-# that does not handle FontChange)
- ${GREP} -Rl --null fixx11h\\.h ${WRKSRC}/src ${WRKSRC}/plugins | \
- ${XARGS} -0 ${REINPLACE_CMD} -e 's/fixx11h\.h/fixx11qt4h.h/'
- cd ${WRKSRC}/src/core/external && ${MV} fixx11h.h fixx11qt4h.h
+post-patch:
+ @${REINPLACE_CMD} -e '/ -Wno-unused-result/d' ${WRKSRC}/CMakeLists.txt
post-install:
.if ${PORT_OPTIONS:MMORE_STARS}