aboutsummaryrefslogtreecommitdiff
path: root/astro/wmglobe
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-01-26 12:11:15 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-01-26 12:11:15 +0000
commit754b55a16325c16bfaf1fbe6a0c490f0ffb37b72 (patch)
tree9e11cf7eca412c04f6e65e861e8db4fa436cd644 /astro/wmglobe
parenta01331d6efbadbf98d60e4677a70627c2fba767f (diff)
downloadports-754b55a16325c16bfaf1fbe6a0c490f0ffb37b72.tar.gz
ports-754b55a16325c16bfaf1fbe6a0c490f0ffb37b72.zip
Resurrect astro/wmglobe
- The distfile is available again on dockapps.net - Add some missing dependencies as reported by stage-qa - Assign port to the submitter PR: 226675 Submitted by: jd.fbsd@goneja.de
Notes
Notes: svn path=/head/; revision=491271
Diffstat (limited to 'astro/wmglobe')
-rw-r--r--astro/wmglobe/Makefile24
-rw-r--r--astro/wmglobe/distinfo3
-rw-r--r--astro/wmglobe/files/patch-Makefile31
-rw-r--r--astro/wmglobe/pkg-descr5
4 files changed, 63 insertions, 0 deletions
diff --git a/astro/wmglobe/Makefile b/astro/wmglobe/Makefile
new file mode 100644
index 000000000000..52ac6ba44b4f
--- /dev/null
+++ b/astro/wmglobe/Makefile
@@ -0,0 +1,24 @@
+# Created by: Will Andrews <andrews@technologist.com>
+# $FreeBSD$
+
+PORTNAME= wmglobe
+PORTVERSION= 1.3
+PORTREVISION= 11
+CATEGORIES= astro windowmaker geography
+MASTER_SITES= https://www.dockapps.net/download/
+
+MAINTAINER= jd.fbsd@goneja.de
+COMMENT= Neat xearth-like WindowMaker dockapp
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libwraster.so:x11-wm/libwraster
+
+USE_XORG= x11 xext xpm
+
+PLIST_FILES= bin/wmglobe \
+ man/man1/wmglobe.1.gz
+MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/astro/wmglobe/distinfo b/astro/wmglobe/distinfo
new file mode 100644
index 000000000000..a987002ea37d
--- /dev/null
+++ b/astro/wmglobe/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1513946787
+SHA256 (wmglobe-1.3.tar.gz) = 3ba943d2e2e18d6c517144f74db81e51b8f9137dcde377c83f3414df9c75a914
+SIZE (wmglobe-1.3.tar.gz) = 75541
diff --git a/astro/wmglobe/files/patch-Makefile b/astro/wmglobe/files/patch-Makefile
new file mode 100644
index 000000000000..ac8b9055954e
--- /dev/null
+++ b/astro/wmglobe/files/patch-Makefile
@@ -0,0 +1,31 @@
+--- Makefile.orig 1999-02-06 12:17:06 UTC
++++ Makefile
+@@ -1,12 +1,11 @@
+-INC = -I/usr/X11R6/include
+-LIBS = -lXext -lX11 -lm -L/usr/X11R6/lib \
+- -ltiff -lXpm -lpng -lz -ljpeg -lungif -lwraster
++INC = `pkg-config wrlib --cflags`
++LIBS = -lm `pkg-config wrlib xpm xext --libs`
+ OBJS = src/wmglobe.o src/rend.o src/wmgutil.o \
+ src/sunpos.o src/myconvert.o src/mycontext.o
+
+
+ .c.o :
+- gcc -c -O2 -Wall $(INC) $< -o $*.o
++ ${CC} -c ${CFLAGS} $(INC) $< -o $@
+
+ all: wmglobe
+
+@@ -14,9 +13,8 @@ clean:
+ rm -f src/*.o wmglobe
+
+ wmglobe : $(OBJS)
+- gcc -O2 -Wall $(OBJS) -o wmglobe $(LIBS)
+- strip wmglobe
++ ${CC} ${CFLAGS} $(OBJS) -o wmglobe $(LIBS)
+
+ install :
+- install wmglobe /usr/local/bin
+- install wmglobe.1 /usr/local/man/man1
++ ${BSD_INSTALL_PROGRAM} wmglobe ${PREFIX}/bin
++ ${BSD_INSTALL_MAN} wmglobe.1 ${PREFIX}/man/man1
diff --git a/astro/wmglobe/pkg-descr b/astro/wmglobe/pkg-descr
new file mode 100644
index 000000000000..f5ad3f8f9967
--- /dev/null
+++ b/astro/wmglobe/pkg-descr
@@ -0,0 +1,5 @@
+wmglobe is a neat WindowMaker dockapp that displays a
+xearth-like view of the earth that is currently under
+the sun, and does a lot of other neat stuff.
+
+WWW: https://www.dockapps.net/wmglobe