aboutsummaryrefslogtreecommitdiff
path: root/astro/xearth
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2013-10-15 14:23:29 +0000
committerMathieu Arnold <mat@FreeBSD.org>2013-10-15 14:23:29 +0000
commit4e3451aabf5e8efd661b14a8209b70bd99520939 (patch)
tree068a16d316bff959e70f12290a996e181d4e801e /astro/xearth
parent86262cb735e9384c1ab7e86fe626c6093286d29f (diff)
downloadports-4e3451aabf5e8efd661b14a8209b70bd99520939.tar.gz
ports-4e3451aabf5e8efd661b14a8209b70bd99520939.zip
Support staging.
PR: ports/182910 Submitted by: mat (me) Approved by: maintainer
Notes
Notes: svn path=/head/; revision=330402
Diffstat (limited to 'astro/xearth')
-rw-r--r--astro/xearth/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/astro/xearth/Makefile b/astro/xearth/Makefile
index b40370fbf4bd..a69855722b92 100644
--- a/astro/xearth/Makefile
+++ b/astro/xearth/Makefile
@@ -12,20 +12,19 @@ COMMENT= Set the root window to the image of earth
USE_XORG= x11 xext sm ice xt
USE_XZ= yes
-NO_STAGE= yes
-MAN1= xearth.1
PLIST_FILES= bin/xearth \
+ man/man1/xearth.1.gz \
lib/X11/xearth/freebsd.committers.markers \
lib/X11/xearth/freebsd.ftp.markers
PLIST_DIRS= lib/X11/xearth
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/xearth ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/xearth.man ${MANPREFIX}/man/man1/xearth.1
- @${MKDIR} ${PREFIX}/lib/X11/xearth
+ @${INSTALL_PROGRAM} ${WRKSRC}/xearth ${STAGEDIR}${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/xearth.man ${STAGEDIR}${MANPREFIX}/man/man1/xearth.1
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/xearth
# Copy the list of FreeBSD sites & committers locations
.for marker in freebsd.committers.markers freebsd.ftp.markers
- @${INSTALL_DATA} ${FILESDIR}/${marker} ${PREFIX}/lib/X11/xearth
+ @${INSTALL_DATA} ${FILESDIR}/${marker} ${STAGEDIR}${PREFIX}/lib/X11/xearth
.endfor
.include <bsd.port.mk>