aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-12-06 05:43:03 +0000
committerWill Andrews <will@FreeBSD.org>2000-12-06 05:43:03 +0000
commit295ffb064c937efef21f47dc54d412210378f415 (patch)
tree721f8b11cac680604ad1a0ddb09bfaa705588381 /astro
parent978e774f349be68935ea31609c74b6eacee772e4 (diff)
downloadports-295ffb064c937efef21f47dc54d412210378f415.tar.gz
ports-295ffb064c937efef21f47dc54d412210378f415.zip
Add p5-GPS 0.12, a perl module that gives access to several GPS protocols
such as Garmin, NMEA, and Magellan. PR: 23317 Submitted by: Jeremy Shaffner <jeremy@external.org>
Notes
Notes: svn path=/head/; revision=35705
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/p5-GPS/Makefile27
-rw-r--r--astro/p5-GPS/distinfo1
-rw-r--r--astro/p5-GPS/pkg-comment1
-rw-r--r--astro/p5-GPS/pkg-descr4
-rw-r--r--astro/p5-GPS/pkg-plist12
6 files changed, 46 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 40bf12cf1673..7ac63b02dd79 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -6,6 +6,7 @@
SUBDIR += glunarclock
SUBDIR += luna
SUBDIR += openuniverse
+ SUBDIR += p5-GPS
SUBDIR += pyweather
SUBDIR += rmap
SUBDIR += saoimage
diff --git a/astro/p5-GPS/Makefile b/astro/p5-GPS/Makefile
new file mode 100644
index 000000000000..4cb912d39dbc
--- /dev/null
+++ b/astro/p5-GPS/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-GPS
+# Date created: 5 December 2000
+# Whom: Jeremy Shaffner <jeremy@external.org>
+#
+# $FreeBSD$
+
+PORTNAME= GPS
+PORTVERSION= 0.12
+CATEGORIES= astro perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= perl-gps
+PKGNAMEPREFIX= p5-
+DISTNAME= perl-GPS-${PORTVERSION}
+
+MAINTAINER= jeremy@external.org
+
+USE_PERL5= YES
+
+MAN3= GPS::Garmin.3 \
+ GPS::Serial.3 \
+ GPS::Garmin::Handler.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/astro/p5-GPS/distinfo b/astro/p5-GPS/distinfo
new file mode 100644
index 000000000000..266f6b61d655
--- /dev/null
+++ b/astro/p5-GPS/distinfo
@@ -0,0 +1 @@
+MD5 (perl-GPS-0.12.tar.gz) = 261fb84f8d6e519d25394c4c9321390d
diff --git a/astro/p5-GPS/pkg-comment b/astro/p5-GPS/pkg-comment
new file mode 100644
index 000000000000..2bb6d1bb2e7a
--- /dev/null
+++ b/astro/p5-GPS/pkg-comment
@@ -0,0 +1 @@
+Perl interface to GPS receivers
diff --git a/astro/p5-GPS/pkg-descr b/astro/p5-GPS/pkg-descr
new file mode 100644
index 000000000000..e0819a6efd82
--- /dev/null
+++ b/astro/p5-GPS/pkg-descr
@@ -0,0 +1,4 @@
+This is a Perl module that gives access to several GPS protocols, such as
+Garmin, NMEA, and Magellan. It works in Unix and Win32.
+
+WWW: http://sourceforge.net/projects/perl-gps/
diff --git a/astro/p5-GPS/pkg-plist b/astro/p5-GPS/pkg-plist
new file mode 100644
index 000000000000..657a7420f827
--- /dev/null
+++ b/astro/p5-GPS/pkg-plist
@@ -0,0 +1,12 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GPS/Garmin/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/GPS/Garmin.pm
+lib/perl5/site_perl/%%PERL_VER%%/GPS/Garmin/Constant.pm
+lib/perl5/site_perl/%%PERL_VER%%/GPS/Garmin/Handler.pm
+lib/perl5/site_perl/%%PERL_VER%%/GPS/Serial.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/GPS/Garmin/Handler/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/GPS/Garmin/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/GPS/Serial/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/GPS/Garmin/Handler
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/GPS/Garmin
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/GPS/Serial
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GPS/Garmin