aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2023-06-14 22:00:28 +0000
committerRene Ladan <rene@FreeBSD.org>2023-06-27 19:34:34 +0000
commit3d9a815d9c5acbb71f4bb07738bdeab4879feacb (patch)
treeeb093f22197a2c68a88dd2372ec1922c3f6d3c10 /astro
parentc58ef91e06e8edc4fd8579837f1453b562da3fbb (diff)
downloadports-3d9a815d9c5acbb71f4bb07738bdeab4879feacb.tar.gz
ports-3d9a815d9c5acbb71f4bb07738bdeab4879feacb.zip
all: remove explicit versions in USES=python for "3.x+"
The logic in USES=python will automatically convert this to 3.8+ by itself. Adjust two ports that only had Python 3.7 mentioned but build fine on Python 3.8 too. finance/quickfix: mark BROKEN with PYTHON libtool: compile: c++ -DHAVE_CONFIG_H -I. -I../.. -I -I. -I.. -I../.. -I../C++ -DLIBICONV_PLUG -DPYTHON_MAJOR_VERSION=3 -Wno-unused-variable -Wno-maybe-uninitialized -O2 -pipe -DLIBICONV_PLUG -fstack-protector-strong -fno-strict-aliasing -DLIBICONV_PLUG -Wall -ansi -Wno-unused-command-line-argument -Wpointer-arith -Wwrite-strings -Wno-overloaded-virtual -Wno-deprecated-declarations -Wno-deprecated -std=c++0x -MT _quickfix_la-QuickfixPython.lo -MD -MP -MF .deps/_quickfix_la-QuickfixPython.Tpo -c QuickfixPython.cpp -fPIC -DPIC -o .libs/_quickfix_la-QuickfixPython.o warning: unknown warning option '-Wno-maybe-uninitialized'; did you mean '-Wno-uninitialized'? [-Wunknown-warning-option] QuickfixPython.cpp:175:11: fatal error: 'Python.h' file not found ^~~~~~~~~~ 1 warning and 1 error generated. Reviewed by: portmgr, vishwin, yuri Differential Revision: <https://reviews.freebsd.org/D40568>
Diffstat (limited to 'astro')
-rw-r--r--astro/gpsd/Makefile2
-rw-r--r--astro/indiwebmanagerapp/Makefile2
-rw-r--r--astro/kosmorro/Makefile2
-rw-r--r--astro/py-astlib/Makefile2
-rw-r--r--astro/py-astral/Makefile2
-rw-r--r--astro/py-astroML/Makefile2
-rw-r--r--astro/py-astropy-helpers/Makefile2
-rw-r--r--astro/py-astropy/Makefile2
-rw-r--r--astro/py-ephem/Makefile2
-rw-r--r--astro/py-extension-helpers/Makefile2
-rw-r--r--astro/py-horoscopegenerator/Makefile2
-rw-r--r--astro/py-indiweb/Makefile2
-rw-r--r--astro/py-jplephem/Makefile2
-rw-r--r--astro/py-kosmorrolib/Makefile2
-rw-r--r--astro/py-metar/Makefile2
-rw-r--r--astro/py-metpy/Makefile2
-rw-r--r--astro/py-pyerfa/Makefile2
-rw-r--r--astro/py-pykep/Makefile2
-rw-r--r--astro/py-pymeeus/Makefile2
-rw-r--r--astro/py-pymetar/Makefile2
-rw-r--r--astro/py-pysofa/Makefile2
-rw-r--r--astro/py-pywapi/Makefile2
-rw-r--r--astro/py-ro/Makefile2
-rw-r--r--astro/py-sgp4/Makefile2
-rw-r--r--astro/py-skyfield-data/Makefile2
-rw-r--r--astro/py-skyfield/Makefile2
-rw-r--r--astro/py-spacetrack/Makefile2
-rw-r--r--astro/py-spktype01/Makefile2
-rw-r--r--astro/py-spktype21/Makefile2
29 files changed, 29 insertions, 29 deletions
diff --git a/astro/gpsd/Makefile b/astro/gpsd/Makefile
index 448babddb654..524fd138ff68 100644
--- a/astro/gpsd/Makefile
+++ b/astro/gpsd/Makefile
@@ -11,7 +11,7 @@ WWW= https://gpsd.gitlab.io/gpsd/index.html
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cpe pathfix pkgconfig python:3.6+ scons
+USES= cpe pathfix pkgconfig python scons
CPE_VENDOR= gpsd_project
USE_LDCONFIG= yes
USE_RC_SUBR= gpsd
diff --git a/astro/indiwebmanagerapp/Makefile b/astro/indiwebmanagerapp/Makefile
index febc5185ce01..a20d76a70fbb 100644
--- a/astro/indiwebmanagerapp/Makefile
+++ b/astro/indiwebmanagerapp/Makefile
@@ -12,7 +12,7 @@ LICENSE= GPLv2
RUN_DEPENDS= indiserver:devel/indi \
${PYTHON_PKGNAMEPREFIX}indiweb>0:astro/py-indiweb@${PY_FLAVOR}
-USES= cmake iconv gettext kde:5 ninja qt:5 pkgconfig python:3.7+ xorg
+USES= cmake iconv gettext kde:5 ninja qt:5 pkgconfig python xorg
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons doctools i18n kio itemviews jobwidgets service \
solid widgetsaddons windowsystem xmlgui
diff --git a/astro/kosmorro/Makefile b/astro/kosmorro/Makefile
index e107f3dc5def..18c746dda948 100644
--- a/astro/kosmorro/Makefile
+++ b/astro/kosmorro/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>0:devel/py-babel@${PY_FLAVOR}\
#USE_GITHUB= yes
-USES= gettext-runtime:run python:3.8+ shebangfix
+USES= gettext-runtime:run python shebangfix
USE_PYTHON= noflavors pep517
SHEBANG_FILES= ${PORTNAME}
diff --git a/astro/py-astlib/Makefile b/astro/py-astlib/Makefile
index 871828adb9ac..ff5a9717e5e8 100644
--- a/astro/py-astlib/Makefile
+++ b/astro/py-astlib/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astropy>=1.1:astro/py-astropy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.7.0:science/py-scipy@${PY_FLAVOR}
-USES= python:3.7+
+USES= python
USE_PYTHON= autoplist concurrent distutils
PORTSCOUT= skipv:0.15,0.17,0.17.1 # incorrect versioning upstream
diff --git a/astro/py-astral/Makefile b/astro/py-astral/Makefile
index bd81026f54ad..7f137e4fccbb 100644
--- a/astro/py-astral/Makefile
+++ b/astro/py-astral/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${PY_FLAVOR}
-USES= python:3.7+
+USES= python
USE_PYTHON= autoplist concurrent distutils
.include <bsd.port.mk>
diff --git a/astro/py-astroML/Makefile b/astro/py-astroML/Makefile
index 638a63e45d71..e3b6b20a598c 100644
--- a/astro/py-astroML/Makefile
+++ b/astro/py-astroML/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scikit-learn>=0.18:science/py-scikit-learn@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}astropy>=3.0:astro/py-astropy@${PY_FLAVOR}
-USES= python:3.7+
+USES= python
USE_PYTHON= autoplist distutils
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.post1
diff --git a/astro/py-astropy-helpers/Makefile b/astro/py-astropy-helpers/Makefile
index 86495a92f08c..62d12a5def00 100644
--- a/astro/py-astropy-helpers/Makefile
+++ b/astro/py-astropy-helpers/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.rst
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY}
-USES= python:3.5+
+USES= python
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/astro/py-astropy/Makefile b/astro/py-astropy/Makefile
index 614ebb83a8dd..99a9c4d85b64 100644
--- a/astro/py-astropy/Makefile
+++ b/astro/py-astropy/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${PYNUMPY} \
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}pyerfa>=0:astro/py-pyerfa@${PY_FLAVOR}
-USES= compiler:c11 python:3.8+
+USES= compiler:c11 python
USE_PYTHON= autoplist cython distutils
CONFLICTS_INSTALL= p5-Data-ShowTable # bin/showtable
diff --git a/astro/py-ephem/Makefile b/astro/py-ephem/Makefile
index 0118d204a3da..49133aa47013 100644
--- a/astro/py-ephem/Makefile
+++ b/astro/py-ephem/Makefile
@@ -11,7 +11,7 @@ WWW= https://pypi.org/project/ephem/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:3.7+
+USES= python
USE_PYTHON= autoplist distutils
post-install:
diff --git a/astro/py-extension-helpers/Makefile b/astro/py-extension-helpers/Makefile
index 9306f8e6ff73..7ce3b572ba0e 100644
--- a/astro/py-extension-helpers/Makefile
+++ b/astro/py-extension-helpers/Makefile
@@ -11,7 +11,7 @@ WWW= https://extension-helpers.readthedocs.io/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.rst
-USES= python:3.6+
+USES= python
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/astro/py-horoscopegenerator/Makefile b/astro/py-horoscopegenerator/Makefile
index c951c9181806..23eb06835f69 100644
--- a/astro/py-horoscopegenerator/Makefile
+++ b/astro/py-horoscopegenerator/Makefile
@@ -14,7 +14,7 @@ LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nltk>=0:textproc/py-nltk@${PY_FLAVOR}
-USES= python:3.6+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/astro/py-indiweb/Makefile b/astro/py-indiweb/Makefile
index 94be3c8cc43a..ee9d7f7ce77a 100644
--- a/astro/py-indiweb/Makefile
+++ b/astro/py-indiweb/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psutil>=0:sysutils/py-psutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}bottle>=0:www/py-bottle@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
-USES= python:3.5+
+USES= python
USE_PYTHON= autoplist concurrent distutils
post-patch:
diff --git a/astro/py-jplephem/Makefile b/astro/py-jplephem/Makefile
index 91f681dd692e..9626b736a84d 100644
--- a/astro/py-jplephem/Makefile
+++ b/astro/py-jplephem/Makefile
@@ -19,7 +19,7 @@ USE_GITHUB= yes
GH_ACCOUNT= brandon-rhodes
GH_PROJECT= python-jplephem
-USES= python:3.7+ shebangfix
+USES= python shebangfix
USE_PYTHON= distutils
SHEBANG_FILES= test.sh bin/doctest.sh bin/parse_zzidmap.sh bin/benchmark.py
NO_ARCH= yes
diff --git a/astro/py-kosmorrolib/Makefile b/astro/py-kosmorrolib/Makefile
index 43182fcd7df7..ff1a13bdc8b9 100644
--- a/astro/py-kosmorrolib/Makefile
+++ b/astro/py-kosmorrolib/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}skyfield>0:astro/py-skyfield@${PY_FLAVOR}\
#GH_ACCOUNT= Kosmorro
#GH_PROJECT= lib
-USES= python:3.8+
+USES= python
USE_PYTHON= pep517
PLIST_SUB= VE=${PORTVERSION}
diff --git a/astro/py-metar/Makefile b/astro/py-metar/Makefile
index 09f4652bc95a..cfb12ad2d32f 100644
--- a/astro/py-metar/Makefile
+++ b/astro/py-metar/Makefile
@@ -12,7 +12,7 @@ WWW= https://github.com/python-metar/python-metar
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:3.6+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/astro/py-metpy/Makefile b/astro/py-metpy/Makefile
index 5af5685b0b3a..0e5619fe77ef 100644
--- a/astro/py-metpy/Makefile
+++ b/astro/py-metpy/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=3.3.0:math/py-matplotlib@${PY_FL
${PYTHON_PKGNAMEPREFIX}traitlets>=5.0.5:devel/py-traitlets@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}xarray>=0.18.0:devel/py-xarray@${PY_FLAVOR}
-USES= python:3.8+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/astro/py-pyerfa/Makefile b/astro/py-pyerfa/Makefile
index 55cc3555244d..b1959523591b 100644
--- a/astro/py-pyerfa/Makefile
+++ b/astro/py-pyerfa/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.17.0,1:math/py-numpy@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.17.0,1:math/py-numpy@${PY_FLAVOR}
-USES= python:3.7+
+USES= python
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/astro/py-pykep/Makefile b/astro/py-pykep/Makefile
index 7a2dd8428ae9..0ce3266cddac 100644
--- a/astro/py-pykep/Makefile
+++ b/astro/py-pykep/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}pygmo2>0:science/py-pygmo2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
-USES= cmake compiler:c++11-lang python:3.7+
+USES= cmake compiler:c++11-lang python
USE_PYTHON= flavors
CMAKE_OFF= PYKEP_BUILD_KEP_TOOLBOX PYKEP_BUILD_TESTS
diff --git a/astro/py-pymeeus/Makefile b/astro/py-pymeeus/Makefile
index f66a50b9c4fb..0166f3f00d9d 100644
--- a/astro/py-pymeeus/Makefile
+++ b/astro/py-pymeeus/Makefile
@@ -12,7 +12,7 @@ WWW= https://github.com/architest/pymeeus
LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
-USES= python:3.6+
+USES= python
USE_PYTHON= autoplist distutils pytest
NO_ARCH= yes
diff --git a/astro/py-pymetar/Makefile b/astro/py-pymetar/Makefile
index 5e0a4f727212..bbf212d8b094 100644
--- a/astro/py-pymetar/Makefile
+++ b/astro/py-pymetar/Makefile
@@ -11,7 +11,7 @@ WWW= https://github.com/klausman/pymetar
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= python:3.5+ shebangfix
+USES= python shebangfix
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/astro/py-pysofa/Makefile b/astro/py-pysofa/Makefile
index 8c904b513f8f..4a57fae31395 100644
--- a/astro/py-pysofa/Makefile
+++ b/astro/py-pysofa/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${LOCALBASE}/lib/libsofa_c.so:astro/sofa \
${PYNUMPY}
-USES= python:3.6+
+USES= python
NO_ARCH= yes
USE_PYTHON= distutils autoplist
diff --git a/astro/py-pywapi/Makefile b/astro/py-pywapi/Makefile
index f597d3aca6a9..64f9b72a92bd 100644
--- a/astro/py-pywapi/Makefile
+++ b/astro/py-pywapi/Makefile
@@ -12,7 +12,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
NO_ARCH= yes
-USES= python:3.6+
+USES= python
USE_PYTHON= distutils autoplist
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
diff --git a/astro/py-ro/Makefile b/astro/py-ro/Makefile
index 04bb196b5ff0..5e55c80b0d4a 100644
--- a/astro/py-ro/Makefile
+++ b/astro/py-ro/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/docs/License.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR}
-USES= python:3.7+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/astro/py-sgp4/Makefile b/astro/py-sgp4/Makefile
index 1533e868a530..7702cf83db7d 100644
--- a/astro/py-sgp4/Makefile
+++ b/astro/py-sgp4/Makefile
@@ -14,7 +14,7 @@ LICENSE= MIT
#GH_ACCOUNT= brandon-rhodes
#GH_PROJECT= python-sgp4
-USES= python:3.7+
+USES= python
USE_PYTHON= distutils
.if !defined(WITH_DEBUG)
LDFLAGS+= -s
diff --git a/astro/py-skyfield-data/Makefile b/astro/py-skyfield-data/Makefile
index a72782e8a4af..35f68c4ca6cd 100644
--- a/astro/py-skyfield-data/Makefile
+++ b/astro/py-skyfield-data/Makefile
@@ -15,7 +15,7 @@ TEST_DEPENDS= py.test:devel/py-pytest@${PY_FLAVOR}
USE_GITHUB= yes
GH_ACCOUNT= brunobord
-USES= python:3.7+
+USES= python
USE_PYTHON= distutils
NO_ARCH= yes
diff --git a/astro/py-skyfield/Makefile b/astro/py-skyfield/Makefile
index bfd0b7490dc8..83d969c09c43 100644
--- a/astro/py-skyfield/Makefile
+++ b/astro/py-skyfield/Makefile
@@ -35,7 +35,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR}\
${PYTHON_PKGNAMEPREFIX}beautifulsoup>0:www/py-beautifulsoup@${PY_FLAVOR}
-USES= python:3.7+
+USES= python
USE_PYTHON= distutils
NO_ARCH= yes
diff --git a/astro/py-spacetrack/Makefile b/astro/py-spacetrack/Makefile
index 34453406ed05..595bcf0f6d28 100644
--- a/astro/py-spacetrack/Makefile
+++ b/astro/py-spacetrack/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}logbook>=0.12.3:devel/py-logbook@${PY_FLAVOR
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-asyncio>=0:devel/py-pytest-asyncio@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}responses>=0:devel/py-responses@${PY_FLAVOR}
-USES= python:3.6+
+USES= python
USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes
diff --git a/astro/py-spktype01/Makefile b/astro/py-spktype01/Makefile
index fcaf7e94ca6c..520e046a56e1 100644
--- a/astro/py-spktype01/Makefile
+++ b/astro/py-spktype01/Makefile
@@ -18,7 +18,7 @@ USE_GITHUB= yes
GH_ACCOUNT= whiskie14142
GH_TAGNAME= 964cc70
-USES= python:3.7+
+USES= python
USE_PYTHON= distutils
WRKSRC_SUBDIR= package/${PORTNAME}
diff --git a/astro/py-spktype21/Makefile b/astro/py-spktype21/Makefile
index a376bf4f9aef..dabd94303a24 100644
--- a/astro/py-spktype21/Makefile
+++ b/astro/py-spktype21/Makefile
@@ -20,7 +20,7 @@ USE_GITHUB= yes
GH_ACCOUNT= whiskie14142
GH_TAGNAME= 7ed2236
-USES= python:3.7+
+USES= python
USE_PYTHON= distutils
WRKSRC_SUBDIR= package/${PORTNAME}