aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorTatsuki Makino <tatsuki_makino@hotmail.com>2023-06-06 06:45:39 +0000
committerWen Heping <wen@FreeBSD.org>2023-06-06 06:52:39 +0000
commit60d48366346b6ee663db4d8d007383874ae0fb0e (patch)
tree5916eb0e587e0fc1307763ffa526ee8e6ae65c16 /astro
parentab62a033960858274cc7a0908dc78853d3dca1ab (diff)
downloadports-60d48366346b6ee663db4d8d007383874ae0fb0e.tar.gz
ports-60d48366346b6ee663db4d8d007383874ae0fb0e.zip
astro/geographiclib: Update to 2.2
PR: 271800 Reported by: tatsuki_makino@hotmail.com(maintainer)
Diffstat (limited to 'astro')
-rw-r--r--astro/geographiclib/Makefile71
-rw-r--r--astro/geographiclib/distinfo6
-rw-r--r--astro/geographiclib/files/patch-CMakeLists.txt23
-rw-r--r--astro/geographiclib/files/patch-cmake_CMakeLists.txt8
-rw-r--r--astro/geographiclib/files/patch-doc_CMakeLists.txt14
-rw-r--r--astro/geographiclib/files/patch-python_geographiclib_CMakeLists.txt15
-rw-r--r--astro/geographiclib/pkg-descr11
-rw-r--r--astro/geographiclib/pkg-help16
-rw-r--r--astro/geographiclib/pkg-plist142
9 files changed, 72 insertions, 234 deletions
diff --git a/astro/geographiclib/Makefile b/astro/geographiclib/Makefile
index 7a58ee99f264..724e23f00f9c 100644
--- a/astro/geographiclib/Makefile
+++ b/astro/geographiclib/Makefile
@@ -1,8 +1,7 @@
PORTNAME= geographiclib
-DISTVERSION= 1.52
+DISTVERSION= 2.2
CATEGORIES= astro
-MASTER_SITES= SF/geographiclib/distrib \
- SF/geographiclib/distrib/archive \
+MASTER_SITES= SF/geographiclib/distrib-C%2B%2B \
SF/geographiclib:geoids,gravity,magnetic
DISTNAME= GeographicLib-${DISTVERSIONFULL}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} #
@@ -13,43 +12,41 @@ COMMENT= Library for geographic projections
WWW= https://geographiclib.sourceforge.io/
LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+LICENSE_FILE_MIT= ${WRKSRC}/LICENSE.txt
+LICENSE_FILE= ${LICENSE_FILE_MIT}
-USES= cmake localbase python:env
-.if !exists(/usr/include/omp.h)
-USES+= compiler:gcc-c++11-lib
-.else
-USES+= compiler:c++14-lang
-.endif
+USES= cmake compiler:c++11-lang localbase:ldflags pathfix
USE_LDCONFIG= yes
-USE_PYTHON= optsuffix
-CMAKE_ARGS= -DGEOGRAPHICLIB_DATA:STRING=${DATADIR:Q} \
- -DGEOGRAPHICLIB_LIB_TYPE:STRING=BOTH \
- -DINSTALL_PYTHON_DIR:STRING=${PYTHON_SITELIBDIR:Q} \
- -DINSTALL_DOC_DIR:STRING=${DOCSDIR:Q}
+CMAKE_ARGS= -DGEOGRAPHICLIB_DATA:STRING=${DATADIR:Q}
+CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_OFF= BUILD_BOTH_LIBS \
+ USE_BOOST_FOR_EXAMPLES \
+ BUILD_MANPAGES
PORTDOCS= *
+PORTEXAMPLES= *
-OPTIONS_DEFINE= DOCS DOXYGEN PERL
-OPTIONS_DEFAULT= DOXYGEN PERL PREC2
+OPTIONS_DEFINE= DOCS DOXYGEN EXAMPLES
+OPTIONS_DEFAULT= DOXYGEN PREC2
OPTIONS_GROUP= DATASETS
+OPTIONS_GROUP_DATASETS= ${_OPTIONS_GROUP_DATASETS}
OPTIONS_SINGLE= PRECISION
OPTIONS_SINGLE_PRECISION= PREC1 PREC2 PREC3 PREC4 PREC5
OPTIONS_SUB= yes
DATASETS_DESC= geoid datasets, gravity models and magnetic field models
-PERL_DESC= Build documentation with pod2man and pod2html
PREC1_DESC= 1 = float
PREC2_DESC= 2 = double
PREC3_DESC= 3 = extended
PREC4_DESC= 4 = quadruple
PREC5_DESC= 5 = variable
PRECISION_DESC= default "real" precision
-DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
- ${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx@${PY_FLAVOR}
-DOXYGEN_CMAKE_BOOL= GEOGRAPHICLIB_DOCUMENTATION
-PERL_BUILD_DEPENDS= nroff:textproc/groff
-PERL_USES= perl5
-PERL_USE= PERL5=build
-PERL_CMAKE_BOOL_OFF= GEOGRAPHICLIB_NO_PERL
+DOCS_CMAKE_ON= -DDOCDIR:STRING=${DOCSDIR:Q}
+DOCS_CMAKE_OFF= -DDOCDIR:STRING=NO
+DOXYGEN_IMPLIES= DOCS
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
+DOXYGEN_CMAKE_BOOL= BUILD_DOCUMENTATION
+DOXYGEN_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Doxygen
+EXAMPLES_CMAKE_ON= -DEXAMPLEDIR:STRING=${EXAMPLESDIR:Q}
+EXAMPLES_CMAKE_OFF= -DEXAMPLEDIR:STRING=NO
PREC1_CMAKE_ON= -DGEOGRAPHICLIB_PRECISION:STRING=1
PREC2_CMAKE_ON= -DGEOGRAPHICLIB_PRECISION:STRING=2
PREC3_CMAKE_ON= -DGEOGRAPHICLIB_PRECISION:STRING=3
@@ -57,14 +54,12 @@ PREC4_BUILD_DEPENDS= ${LOCALBASE}/include/boost/version.hpp:devel/boost-libs
PREC4_RUN_DEPENDS= ${LOCALBASE}/include/boost/version.hpp:devel/boost-libs
PREC4_USE= GCC=yes
PREC4_CMAKE_ON= -DGEOGRAPHICLIB_PRECISION:STRING=4
-PREC5_BROKEN= error: call of overloaded 'max' is ambiguous\
- error: '*' was not declared in this scope
PREC5_BUILD_DEPENDS= ${LOCALBASE}/include/mpreal.h:math/mpfrc++
PREC5_LIB_DEPENDS= libgmp.so:math/gmp \
libmpfr.so:math/mpfr
PREC5_RUN_DEPENDS= ${LOCALBASE}/include/mpreal.h:math/mpfrc++
-PREC5_USE= GCC=yes
PREC5_CMAKE_ON= -DGEOGRAPHICLIB_PRECISION:STRING=5
+PREC5_VARS= LICENSE+="GPLv3" LICENSE_COMB="multi"
GEOID_NAMES= egm84-30 egm84-15 egm96-15 egm96-5\
egm2008-5 egm2008-2_5 egm2008-1
@@ -77,10 +72,11 @@ DEFAULT_GRAVITY_NAMES= egm96 wgs84
DEFAULT_MAGNETIC_NAMES= wmm2020 igrf13
DEPRECATED_NAMES= wmm2015
+.ifnmake portclippy
.for n in ${GEOID_NAMES}
GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DESC= Install ${n} geoid dataset\
${"${DEPRECATED_NAMES:M${n}}"!="":?(deprecated):}
-OPTIONS_GROUP_DATASETS+= GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}
+_OPTIONS_GROUP_DATASETS+= GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}
GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DISTFILES= geoids-distrib/${n}.tar.bz2:geoids
ALL_DATASETS_OPTIONS+= GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}
. if !empty(DEFAULT_GEOID_NAMES:M${n})
@@ -90,7 +86,7 @@ DEF_DATASETS_OPTIONS+= GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}
.for n in ${GRAVITY_NAMES}
GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DESC= Install ${n} gravity model\
${"${DEPRECATED_NAMES:M${n}}"!="":?(deprecated):}
-OPTIONS_GROUP_DATASETS+= GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}
+_OPTIONS_GROUP_DATASETS+= GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}
GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DISTFILES= gravity-distrib/${n}.tar.bz2:gravity
ALL_DATASETS_OPTIONS+= GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}
. if !empty(DEFAULT_GRAVITY_NAMES:M${n})
@@ -100,13 +96,14 @@ DEF_DATASETS_OPTIONS+= GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}
.for n in ${MAGNETIC_NAMES}
MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DESC= Install ${n} magnetic model\
${"${DEPRECATED_NAMES:M${n}}"!="":?(deprecated):}
-OPTIONS_GROUP_DATASETS+= MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}
+_OPTIONS_GROUP_DATASETS+= MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}
MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DISTFILES= magnetic-distrib/${n}.tar.bz2:magnetic
ALL_DATASETS_OPTIONS+= MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}
. if !empty(DEFAULT_MAGNETIC_NAMES:M${n})
DEF_DATASETS_OPTIONS+= MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}
. endif
.endfor
+.endif
# list of targets that require all distfiles
.ifmake makesum || makeplist || distclean
@@ -118,12 +115,10 @@ OPTIONS_DEFAULT+= ${DEF_DATASETS_OPTIONS}
.endif
post-patch:
- ${REINPLACE_CMD} -e 's/\(tail\) --lines/\1 -n/g'\
- -e "s,head --lines -4,${SED} -e '\$$d' | ${SED} -e '\$$d' | ${SED} -e '\$$d' | ${SED} -e '\$$d',"\
- ${WRKSRC}/man/makeusage.sh
- ${REINPLACE_CMD} -e '/wget/s,wget -O,${FETCH_BINARY} -o ,'\
- ${WRKSRC}/tools/geographiclib-get-*.sh
+ ${FIND} -- ${WRKSRC}/tools -name geographiclib-get-\*.sh \
+ -exec ${REINPLACE_CMD} -e '/wget/s,wget -O,${FETCH_BINARY} -o ,' -- {} \;
+.ifnmake portclippy
.for n in ${GEOID_NAMES}
post-install-GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}-on: install-datasets-geoids
.endfor
@@ -144,7 +139,8 @@ install-datasets-${n}: .NOTMAIN
x-tool-plist: .NOTMAIN .PHONY ${PLIST}
${REINPLACE_CMD}\
- -e '/^%%PORTDOCS%%/d'\
+ -e '/^%%PORTDOCS%%%%DOCSDIR%%/d'\
+ -e '/^%%PORTEXAMPLES%%%%EXAMPLESDIR%%/d'\
-e '/^%%DATADIR%%\/geoids\/[^.]/{\
h;s|^%%DATADIR%%/geoids/\([^.]\{1,\}\).*|GEOID_\1|;\
s/[^0-9A-Za-z]/_/g;\
@@ -161,5 +157,6 @@ x-tool-plist: .NOTMAIN .PHONY ${PLIST}
y/abcdefghijklmnopqrstuvwxyz/ABCDEFGHIJKLMNOPQRSTUVWXYZ/;\
s/^/%%/;s/$$/%%/;G;s/\n//;}'\
${PLIST}
+.endif
.include <bsd.port.mk>
diff --git a/astro/geographiclib/distinfo b/astro/geographiclib/distinfo
index c75857ec3d14..a864e57e0b46 100644
--- a/astro/geographiclib/distinfo
+++ b/astro/geographiclib/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1624849200
-SHA256 (GeographicLib/GeographicLib-1.52.tar.gz) = 5d4145cd16ebf51a2ff97c9244330a340787d131165cfd150e4b2840c0e8ac2b
-SIZE (GeographicLib/GeographicLib-1.52.tar.gz) = 2432658
+TIMESTAMP = 1685761200
+SHA256 (GeographicLib/GeographicLib-2.2.tar.gz) = 96bd68ae77288fbbffd854c1c8f2c2981dbdbc7670753013fe5ce9ce86d8a125
+SIZE (GeographicLib/GeographicLib-2.2.tar.gz) = 1682259
SHA256 (GeographicLib/geoids-distrib/egm2008-1.tar.bz2) = bdb382d0be7ece9142450eacc24b7b7f0889ee3e0ba4f535b04ec383f94c0fb5
SIZE (GeographicLib/geoids-distrib/egm2008-1.tar.bz2) = 162388303
SHA256 (GeographicLib/geoids-distrib/egm2008-2_5.tar.bz2) = d602e13446a4a4a23f39aecfe6a2a0760a1bc6c1b497482c2ebc9f7d513be699
diff --git a/astro/geographiclib/files/patch-CMakeLists.txt b/astro/geographiclib/files/patch-CMakeLists.txt
deleted file mode 100644
index 142eff9ee0d8..000000000000
--- a/astro/geographiclib/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,23 +0,0 @@
---- CMakeLists.txt.orig 2020-11-22 14:00:22 UTC
-+++ CMakeLists.txt
-@@ -183,6 +183,11 @@ option (APPLE_MULTIPLE_ARCHITECTURES
- # directory is present you get this behavior regardless.
- option (CONVERT_WARNINGS_TO_ERRORS "Convert warnings into errors?" OFF)
-
-+# (+) Allow perl usage to be explicitly disabled. It might exist on the
-+# system, but the user may not necessarily want it to be used for one reason
-+# or another.
-+option (GEOGRAPHICLIB_NO_PERL "Disable usage of pod2man and pod2html" OFF)
-+
- set (LIBNAME Geographic)
- if (MSVC OR CMAKE_CONFIGURATION_TYPES)
- # For multi-config systems and for Visual Studio, the debug version of
-@@ -434,7 +439,7 @@ endif ()
- # documentation files into the source tree. Skip Apple here because
- # man/makeusage.sh uses "head --lines -4" to drop the last 4 lines of a
- # file and there's no simple equivalent for MacOSX
--if (NOT WIN32 AND NOT APPLE)
-+if (NOT WIN32 AND NOT APPLE AND NOT GEOGRAPHICLIB_NO_PERL)
- find_program (HAVE_POD2MAN pod2man)
- find_program (HAVE_POD2HTML pod2html)
- find_program (HAVE_COL col)
diff --git a/astro/geographiclib/files/patch-cmake_CMakeLists.txt b/astro/geographiclib/files/patch-cmake_CMakeLists.txt
deleted file mode 100644
index 1cdb14bb28f5..000000000000
--- a/astro/geographiclib/files/patch-cmake_CMakeLists.txt
+++ /dev/null
@@ -1,8 +0,0 @@
---- cmake/CMakeLists.txt.orig 2021-06-21 21:30:33 UTC
-+++ cmake/CMakeLists.txt
-@@ -112,4 +112,4 @@ set (PACKAGE_VERSION "${PROJECT_VERSION}")
- configure_file (project.pc.in geographiclib.pc @ONLY)
- install (FILES
- "${CMAKE_CURRENT_BINARY_DIR}/geographiclib.pc"
-- DESTINATION "lib${LIB_SUFFIX}/pkgconfig")
-+ DESTINATION "libdata/pkgconfig")
diff --git a/astro/geographiclib/files/patch-doc_CMakeLists.txt b/astro/geographiclib/files/patch-doc_CMakeLists.txt
deleted file mode 100644
index 6ee5dc48cf3e..000000000000
--- a/astro/geographiclib/files/patch-doc_CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
---- doc/CMakeLists.txt.orig 2017-10-05 10:11:23 UTC
-+++ doc/CMakeLists.txt
-@@ -9,9 +9,9 @@ foreach (TOOL ${TOOLS})
- endforeach ()
-
- if (COMMON_INSTALL_PATH)
-- set (INSTALL_DOC_DIR "share/doc/GeographicLib")
-+ set (INSTALL_DOC_DIR "share/doc/GeographicLib" CACHE STRING "")
- else ()
-- set (INSTALL_DOC_DIR "doc")
-+ set (INSTALL_DOC_DIR "doc" CACHE STRING "")
- endif ()
-
- # Run doxygen, if available
diff --git a/astro/geographiclib/files/patch-python_geographiclib_CMakeLists.txt b/astro/geographiclib/files/patch-python_geographiclib_CMakeLists.txt
deleted file mode 100644
index 8ee8f8e432f0..000000000000
--- a/astro/geographiclib/files/patch-python_geographiclib_CMakeLists.txt
+++ /dev/null
@@ -1,15 +0,0 @@
---- python/geographiclib/CMakeLists.txt.orig 2017-10-05 10:11:24 UTC
-+++ python/geographiclib/CMakeLists.txt
-@@ -4,9 +4,10 @@
- file (GLOB PYTHON_FILES [A-Za-z_]*.py)
- file (GLOB TEST_FILES test/[A-Za-z_]*.py)
- if (COMMON_INSTALL_PATH)
-- set (INSTALL_PYTHON_DIR "lib${LIB_SUFFIX}/python/site-packages")
-+ set (INSTALL_PYTHON_DIR "lib${LIB_SUFFIX}/python/site-packages"
-+ CACHE STRING "")
- else ()
-- set (INSTALL_PYTHON_DIR "python")
-+ set (INSTALL_PYTHON_DIR "python" CACHE STRING "")
- endif ()
-
- install (FILES ${PYTHON_FILES}
diff --git a/astro/geographiclib/pkg-descr b/astro/geographiclib/pkg-descr
index ded1163a70b2..2eeee3f5f2bb 100644
--- a/astro/geographiclib/pkg-descr
+++ b/astro/geographiclib/pkg-descr
@@ -1,6 +1,7 @@
-GeographicLib is a small set of C++ classes for performing conversions
-between geographic, UTM, UPS, MGRS, geocentric, and local cartesian
-coordinates, for gravity (e.g., EGM2008), geoid height, and geomagnetic
-field (e.g., WMM2020) calculations, and for solving geodesic problems.
+GeographicLib is a small C++ library for
-It is a suitable replacement for the core functionality provided by geotrans.
+* geodesic and rhumb line calculations;
+* conversions between geographic, UTM, UPS, MGRS, geocentric, and local
+ cartesian coordinates;
+* gravity (e.g., EGM2008) and geomagnetic field (e.g., WMM2020)
+ calculations.
diff --git a/astro/geographiclib/pkg-help b/astro/geographiclib/pkg-help
index f48452c905a3..a4c066dc03d0 100644
--- a/astro/geographiclib/pkg-help
+++ b/astro/geographiclib/pkg-help
@@ -1,7 +1,7 @@
-Geoid datasets used by the GeographicLib::Geoid class and the GeoidEval
+geoid datasets used by the GeographicLib::Geoid class and the GeoidEval
tool to compute geoid heights.
- Available geoid data files
+ Available geoid
size (MB)
name geoid grid tar.bz2 disk
egm84-30 EGM84 30' 0.5 0.6
@@ -12,10 +12,10 @@ tool to compute geoid heights.
egm2008-2_5 EGM2008 2.5' 35 75
egm2008-1 EGM2008 1' 170 470
-Gravity models used by the GeographicLib::GravityModel class and the
-Gravity tool to compute gravity fields.
+gravitymodel datasets used by the GeographicLib::GravityModel class and
+the Gravity tool to compute gravity fields.
- Available gravity models
+ Available gravitymodel
size (kB)
name degree tar.bz2 disk
egm84 18 27 26
@@ -24,10 +24,10 @@ Gravity tool to compute gravity fields.
wgs84 20 1 1
grs80 20 1 1
-Magnetic models used by the GeographicLib::MagneticModel class and the
-MagneticField tool to compute magnetic fields.
+magneticmodel datasets used by the GeographicLib::MagneticModel class
+and the MagneticField tool to compute magnetic fields.
- Available magnetic models
+ Available magneticmodel
size (kB)
name degree years tar.bz2 disk
wmm2010 12 2010-2015 2 3
diff --git a/astro/geographiclib/pkg-plist b/astro/geographiclib/pkg-plist
index 13b14ea6f8fe..44216c8cc5b1 100644
--- a/astro/geographiclib/pkg-plist
+++ b/astro/geographiclib/pkg-plist
@@ -11,12 +11,16 @@ bin/RhumbSolve
bin/TransverseMercatorProj
include/GeographicLib/Accumulator.hpp
include/GeographicLib/AlbersEqualArea.hpp
+include/GeographicLib/AuxAngle.hpp
+include/GeographicLib/AuxLatitude.hpp
include/GeographicLib/AzimuthalEquidistant.hpp
include/GeographicLib/CassiniSoldner.hpp
include/GeographicLib/CircularEngine.hpp
include/GeographicLib/Config.h
include/GeographicLib/Constants.hpp
+include/GeographicLib/DAuxLatitude.hpp
include/GeographicLib/DMS.hpp
+include/GeographicLib/DST.hpp
include/GeographicLib/Ellipsoid.hpp
include/GeographicLib/EllipticFunction.hpp
include/GeographicLib/GARS.hpp
@@ -54,51 +58,12 @@ include/GeographicLib/UTMUPS.hpp
include/GeographicLib/Utility.hpp
lib/cmake/GeographicLib/geographiclib-config-version.cmake
lib/cmake/GeographicLib/geographiclib-config.cmake
-lib/cmake/GeographicLib/geographiclib-legacy-targets-%%CMAKE_BUILD_TYPE%%.cmake
-lib/cmake/GeographicLib/geographiclib-legacy-targets.cmake
lib/cmake/GeographicLib/geographiclib-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/GeographicLib/geographiclib-targets.cmake
-lib/libGeographic.a
-lib/libGeographic.so
-lib/libGeographic.so.19
-lib/libGeographic.so.19.2.0
-lib/node_modules/geographiclib/LICENSE.txt
-lib/node_modules/geographiclib/README.md
-lib/node_modules/geographiclib/geographiclib.js
-lib/node_modules/geographiclib/geographiclib.min.js
-lib/node_modules/geographiclib/package.json
-lib/node_modules/geographiclib/src/DMS.js
-lib/node_modules/geographiclib/src/Geodesic.js
-lib/node_modules/geographiclib/src/GeodesicLine.js
-lib/node_modules/geographiclib/src/Math.js
-lib/node_modules/geographiclib/src/PolygonArea.js
-lib/node_modules/geographiclib/test/geodesictest.js
-lib/node_modules/geographiclib/types/geographiclib.d.ts
-%%PYTHON_SITELIBDIR%%/geographiclib/__init__.py
-%%PYTHON_SITELIBDIR%%/geographiclib/accumulator.py
-%%PYTHON_SITELIBDIR%%/geographiclib/constants.py
-%%PYTHON_SITELIBDIR%%/geographiclib/geodesic.py
-%%PYTHON_SITELIBDIR%%/geographiclib/geodesiccapability.py
-%%PYTHON_SITELIBDIR%%/geographiclib/geodesicline.py
-%%PYTHON_SITELIBDIR%%/geographiclib/geomath.py
-%%PYTHON_SITELIBDIR%%/geographiclib/polygonarea.py
-%%PYTHON_SITELIBDIR%%/geographiclib/test/__init__.py
-%%PYTHON_SITELIBDIR%%/geographiclib/test/test_geodesic.py
+lib/libGeographicLib.so
+lib/libGeographicLib.so.24
+lib/libGeographicLib.so.24.1.0
libdata/pkgconfig/geographiclib.pc
-share/man/man1/CartConvert.1.gz
-share/man/man1/ConicProj.1.gz
-share/man/man1/GeoConvert.1.gz
-share/man/man1/GeodSolve.1.gz
-share/man/man1/GeodesicProj.1.gz
-share/man/man1/GeoidEval.1.gz
-share/man/man1/Gravity.1.gz
-share/man/man1/MagneticField.1.gz
-share/man/man1/Planimeter.1.gz
-share/man/man1/RhumbSolve.1.gz
-share/man/man1/TransverseMercatorProj.1.gz
-share/man/man8/geographiclib-get-geoids.8.gz
-share/man/man8/geographiclib-get-gravity.8.gz
-share/man/man8/geographiclib-get-magnetic.8.gz
sbin/geographiclib-get-geoids
sbin/geographiclib-get-gravity
sbin/geographiclib-get-magnetic
@@ -153,82 +118,17 @@ sbin/geographiclib-get-magnetic
%%MAGNETIC_WMM2015V2%%%%DATADIR%%/magnetic/wmm2015v2.wmm.cof
%%MAGNETIC_WMM2020%%%%DATADIR%%/magnetic/wmm2020.wmm
%%MAGNETIC_WMM2020%%%%DATADIR%%/magnetic/wmm2020.wmm.cof
-share/matlab/geographiclib-legacy/Contents.m
-share/matlab/geographiclib-legacy/geocentricforward.m
-share/matlab/geographiclib-legacy/geocentricreverse.m
-share/matlab/geographiclib-legacy/geodesicdirect.m
-share/matlab/geographiclib-legacy/geodesicinverse.m
-share/matlab/geographiclib-legacy/geodesicline.m
-share/matlab/geographiclib-legacy/geoidheight.m
-share/matlab/geographiclib-legacy/localcartesianforward.m
-share/matlab/geographiclib-legacy/localcartesianreverse.m
-share/matlab/geographiclib-legacy/mgrsforward.m
-share/matlab/geographiclib-legacy/mgrsreverse.m
-share/matlab/geographiclib-legacy/polygonarea.m
-share/matlab/geographiclib-legacy/utmupsforward.m
-share/matlab/geographiclib-legacy/utmupsreverse.m
-share/matlab/geographiclib/Contents.m
-share/matlab/geographiclib/cassini_fwd.m
-share/matlab/geographiclib/cassini_inv.m
-share/matlab/geographiclib/defaultellipsoid.m
-share/matlab/geographiclib/ecc2flat.m
-share/matlab/geographiclib/eqdazim_fwd.m
-share/matlab/geographiclib/eqdazim_inv.m
-share/matlab/geographiclib/flat2ecc.m
-share/matlab/geographiclib/gedistance.m
-share/matlab/geographiclib/gedoc.m
-share/matlab/geographiclib/geocent_fwd.m
-share/matlab/geographiclib/geocent_inv.m
-share/matlab/geographiclib/geodarea.m
-share/matlab/geographiclib/geoddistance.m
-share/matlab/geographiclib/geoddoc.m
-share/matlab/geographiclib/geodreckon.m
-share/matlab/geographiclib/geographiclib_test.m
-share/matlab/geographiclib/geoid_height.m
-share/matlab/geographiclib/geoid_load.m
-share/matlab/geographiclib/gereckon.m
-share/matlab/geographiclib/gnomonic_fwd.m
-share/matlab/geographiclib/gnomonic_inv.m
-share/matlab/geographiclib/loccart_fwd.m
-share/matlab/geographiclib/loccart_inv.m
-share/matlab/geographiclib/mgrs_fwd.m
-share/matlab/geographiclib/mgrs_inv.m
-share/matlab/geographiclib/polarst_fwd.m
-share/matlab/geographiclib/polarst_inv.m
-share/matlab/geographiclib/private/A1m1f.m
-share/matlab/geographiclib/private/A2m1f.m
-share/matlab/geographiclib/private/A3coeff.m
-share/matlab/geographiclib/private/A3f.m
-share/matlab/geographiclib/private/AngDiff.m
-share/matlab/geographiclib/private/AngNormalize.m
-share/matlab/geographiclib/private/AngRound.m
-share/matlab/geographiclib/private/C1f.m
-share/matlab/geographiclib/private/C1pf.m
-share/matlab/geographiclib/private/C2f.m
-share/matlab/geographiclib/private/C3coeff.m
-share/matlab/geographiclib/private/C3f.m
-share/matlab/geographiclib/private/C4coeff.m
-share/matlab/geographiclib/private/C4f.m
-share/matlab/geographiclib/private/G4coeff.m
-share/matlab/geographiclib/private/GeoRotation.m
-share/matlab/geographiclib/private/LatFix.m
-share/matlab/geographiclib/private/SinCosSeries.m
-share/matlab/geographiclib/private/atan2dx.m
-share/matlab/geographiclib/private/cbrtx.m
-share/matlab/geographiclib/private/copysignx.m
-share/matlab/geographiclib/private/cvmgt.m
-share/matlab/geographiclib/private/eatanhe.m
-share/matlab/geographiclib/private/geoid_file.m
-share/matlab/geographiclib/private/geoid_load_file.m
-share/matlab/geographiclib/private/norm2.m
-share/matlab/geographiclib/private/remx.m
-share/matlab/geographiclib/private/sincosdx.m
-share/matlab/geographiclib/private/sumx.m
-share/matlab/geographiclib/private/swap.m
-share/matlab/geographiclib/private/tauf.m
-share/matlab/geographiclib/private/taupf.m
-share/matlab/geographiclib/projdoc.m
-share/matlab/geographiclib/tranmerc_fwd.m
-share/matlab/geographiclib/tranmerc_inv.m
-share/matlab/geographiclib/utmups_fwd.m
-share/matlab/geographiclib/utmups_inv.m
+share/man/man1/CartConvert.1.gz
+share/man/man1/ConicProj.1.gz
+share/man/man1/GeoConvert.1.gz
+share/man/man1/GeodSolve.1.gz
+share/man/man1/GeodesicProj.1.gz
+share/man/man1/GeoidEval.1.gz
+share/man/man1/Gravity.1.gz
+share/man/man1/MagneticField.1.gz
+share/man/man1/Planimeter.1.gz
+share/man/man1/RhumbSolve.1.gz
+share/man/man1/TransverseMercatorProj.1.gz
+share/man/man8/geographiclib-get-geoids.8.gz
+share/man/man8/geographiclib-get-gravity.8.gz
+share/man/man8/geographiclib-get-magnetic.8.gz