aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /astro
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadports-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=488341
Diffstat (limited to 'astro')
-rw-r--r--astro/gpstk/Makefile2
-rw-r--r--astro/kstars-kde4/Makefile2
-rw-r--r--astro/kstars/Makefile2
-rw-r--r--astro/libkgeomap-kde4/Makefile2
-rw-r--r--astro/libkgeomap/Makefile2
-rw-r--r--astro/marble-kde4/Makefile2
-rw-r--r--astro/marble/Makefile2
-rw-r--r--astro/oskar/Makefile2
-rw-r--r--astro/qlandkartegt/Makefile2
9 files changed, 9 insertions, 9 deletions
diff --git a/astro/gpstk/Makefile b/astro/gpstk/Makefile
index 9fc0a8e070c9..29baafff0202 100644
--- a/astro/gpstk/Makefile
+++ b/astro/gpstk/Makefile
@@ -12,7 +12,7 @@ COMMENT= Toolkit for developing GPS applications
LICENSE= GPLv3 LGPL3
LICENSE_COMB= multi
-USES= cmake:outsource
+USES= cmake
USE_LDCONFIG= yes
USE_GITHUB= yes
diff --git a/astro/kstars-kde4/Makefile b/astro/kstars-kde4/Makefile
index 6f63f97c83bc..016068544920 100644
--- a/astro/kstars-kde4/Makefile
+++ b/astro/kstars-kde4/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
BUILD_DEPENDS= xplanet:astro/xplanet
RUN_DEPENDS= xplanet:astro/xplanet
-USES= cmake:outsource compiler:c++11-lib eigen:3 kde:4 qt:4 tar:xz
+USES= cmake compiler:c++11-lib eigen:3 kde:4 qt:4 tar:xz
USE_KDE= kdelibs automoc4
USE_QT= opengl qmake_build moc_build rcc_build uic_build
diff --git a/astro/kstars/Makefile b/astro/kstars/Makefile
index 55841b93224b..ae61f33e950c 100644
--- a/astro/kstars/Makefile
+++ b/astro/kstars/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
BUILD_DEPENDS= xplanet:astro/xplanet
RUN_DEPENDS= xplanet:astro/xplanet
-USES= cmake:outsource compiler:c++11-lib eigen:3 gettext kde:5 \
+USES= cmake compiler:c++11-lib eigen:3 gettext kde:5 \
pkgconfig qt:5 tar:xz
USE_KDE= attica auth bookmarks codecs completion config configwidgets\
coreaddons crash dbusaddons doctools ecm guiaddons i18n \
diff --git a/astro/libkgeomap-kde4/Makefile b/astro/libkgeomap-kde4/Makefile
index 283080e494a9..c35333dc59dc 100644
--- a/astro/libkgeomap-kde4/Makefile
+++ b/astro/libkgeomap-kde4/Makefile
@@ -19,7 +19,7 @@ LICENSE_COMB= multi
BUILD_DEPENDS= ${LOCALBASE}/include/boost/graph/buffer_concepts.hpp:devel/boost-libs
-USES= cmake:outsource kde:4 pathfix qt:4 tar:xz
+USES= cmake kde:4 pathfix qt:4 tar:xz
USE_KDE= kdelibs automoc4 marble
USE_LDCONFIG= yes
USE_QT= network phonon xml moc_build qmake_build rcc_build uic_build
diff --git a/astro/libkgeomap/Makefile b/astro/libkgeomap/Makefile
index 5aa0e4475cd7..772d02ca8a09 100644
--- a/astro/libkgeomap/Makefile
+++ b/astro/libkgeomap/Makefile
@@ -13,7 +13,7 @@ LICENSE_COMB= multi
BUILD_DEPENDS= ${LOCALBASE}/include/boost/graph/buffer_concepts.hpp:devel/boost-libs
LIB_DEPENDS= libopencv_video.so:graphics/opencv
-USES= cmake:outsource compiler:c++11-lang gettext kde:5 pkgconfig \
+USES= cmake compiler:c++11-lang gettext kde:5 pkgconfig \
qt:5 tar:xz
USE_KDE= config coreaddons ecm i18n kio marble service textwidgets
USE_QT= concurrent core gui network webkit widgets xml \
diff --git a/astro/marble-kde4/Makefile b/astro/marble-kde4/Makefile
index 6497d5e4db43..20a45a7eca68 100644
--- a/astro/marble-kde4/Makefile
+++ b/astro/marble-kde4/Makefile
@@ -13,7 +13,7 @@ LIB_DEPENDS= libquazip.so:archivers/quazip@qt4
DEPRECATED= KDE4 is EOL upstream
EXPIRATION_DATE= 2018-12-31
-USES= cmake:outsource kde:4 qt:4 shared-mime-info tar:xz
+USES= cmake kde:4 qt:4 shared-mime-info tar:xz
USE_KDE= kdelibs automoc4
USE_QT= corelib dbus declarative designer_build gui network phonon \
qtestlib script sql svg webkit xml \
diff --git a/astro/marble/Makefile b/astro/marble/Makefile
index 6095682baca6..e88e52228288 100644
--- a/astro/marble/Makefile
+++ b/astro/marble/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LIB_DEPENDS= libquazip5.so:archivers/quazip@qt5
-USES= cmake:outsource compiler:c++11-lang desktop-file-utils gettext \
+USES= cmake compiler:c++11-lang desktop-file-utils gettext \
kde:5 qt:5 tar:xz
USE_KDE= attica auth codecs completion config configwidgets coreaddons \
crash doctools ecm i18n jobwidgets kio newstuff package parts \
diff --git a/astro/oskar/Makefile b/astro/oskar/Makefile
index 4d00e13a31cd..3b0d7bac3c6c 100644
--- a/astro/oskar/Makefile
+++ b/astro/oskar/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libcfitsio.so:astro/cfitsio
-USES= cmake:outsource localbase:ldflags python qt:5 shebangfix
+USES= cmake localbase:ldflags python qt:5 shebangfix
SHEBANG_FILES= apps/oskar_convert_cst_to_scalar.py
USE_GITHUB= yes
GH_ACCOUNT= OxfordSKA
diff --git a/astro/qlandkartegt/Makefile b/astro/qlandkartegt/Makefile
index 8556a8c0c306..f55252eef0f7 100644
--- a/astro/qlandkartegt/Makefile
+++ b/astro/qlandkartegt/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libgdal.so:graphics/gdal \
libproj.so:graphics/proj \
libgps.so:astro/gpsd
-USES= cmake desktop-file-utils qt:4
+USES= cmake:insource desktop-file-utils qt:4
USE_QT= dbus gui opengl network sql xml linguist_build \
moc_build uic_build rcc_build qmake_build
USE_GL= glu