aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2012-08-10 09:03:12 +0000
committerRene Ladan <rene@FreeBSD.org>2012-08-10 09:03:12 +0000
commit8a6acb3cf0d8112224a4bd70d3c9388152b5773a (patch)
treed7aabf7d0bc0e01f80c3925415c9a0f9114f97ab /astro
parenta4dae68df2e9dcf43cdecf56d247359105b1c28f (diff)
downloadports-8a6acb3cf0d8112224a4bd70d3c9388152b5773a.tar.gz
ports-8a6acb3cf0d8112224a4bd70d3c9388152b5773a.zip
- Make sure the package is properly deinstalled by using the proper sh syntax.
- Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=302381
Diffstat (limited to 'astro')
-rw-r--r--astro/boinc-astropulse/Makefile2
-rw-r--r--astro/boinc-astropulse/files/pkg-deinstall.in4
2 files changed, 3 insertions, 3 deletions
diff --git a/astro/boinc-astropulse/Makefile b/astro/boinc-astropulse/Makefile
index 4f580c9da685..6c0b3a197df0 100644
--- a/astro/boinc-astropulse/Makefile
+++ b/astro/boinc-astropulse/Makefile
@@ -6,7 +6,7 @@
PORTNAME= boinc-astropulse
PORTVERSION= 6.01
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= astro
MASTER_SITES= ftp://rene-ladan.nl/pub/distfiles/
DISTNAME= astropulse-svn-1280
diff --git a/astro/boinc-astropulse/files/pkg-deinstall.in b/astro/boinc-astropulse/files/pkg-deinstall.in
index b6ee2e66ab23..f72ebd09a28f 100644
--- a/astro/boinc-astropulse/files/pkg-deinstall.in
+++ b/astro/boinc-astropulse/files/pkg-deinstall.in
@@ -14,8 +14,8 @@ if [ $? -ne 0 ]; then
echo $F is corrupt
exit 1
fi
-l1=$((l-1))
-l2=$((l+13))
+l1=$(($l-1))
+l2=$(($l+13))
sed -i.bak "${l1},${l2}d" $F # sed wants the braces
rm $F.bak