aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2023-04-23 13:47:02 +0000
committerWen Heping <wen@FreeBSD.org>2023-04-23 13:47:34 +0000
commit8ca5638c5ac9712716a1ee1a5849dd70aef6d35d (patch)
treeb8df6d10ffdb44e1aedcdcc7b7eea8dad033c178 /astro
parentef61f19d52ab7803bef87032e2027cec4275166b (diff)
downloadports-8ca5638c5ac9712716a1ee1a5849dd70aef6d35d.tar.gz
ports-8ca5638c5ac9712716a1ee1a5849dd70aef6d35d.zip
astro/py-sunpy: Add new port
Sunpy is a Python software package that provides fundamental tools for accessing, loading and interacting with solar physics data in Python. It is the core library of the SunPy Project.
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/py-sunpy/Makefile30
-rw-r--r--astro/py-sunpy/distinfo3
-rw-r--r--astro/py-sunpy/pkg-descr3
4 files changed, 37 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 2dc25b13dc44..10fd52b16dea 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -105,6 +105,7 @@
SUBDIR += py-spacetrack
SUBDIR += py-spktype01
SUBDIR += py-spktype21
+ SUBDIR += py-sunpy
SUBDIR += pykep
SUBDIR += pyweather
SUBDIR += qmapshack
diff --git a/astro/py-sunpy/Makefile b/astro/py-sunpy/Makefile
new file mode 100644
index 000000000000..653b50a5ed13
--- /dev/null
+++ b/astro/py-sunpy/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= sunpy
+DISTVERSION= 4.1.5
+CATEGORIES= astro
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Python for Solar Physics
+WWW= https://www.sunpy.org/
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.rst
+
+BUILD_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}astropy>=0:astro/py-astropy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}extension-helpers>=0:astro/py-extension-helpers@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pip>0:devel/py-pip@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}astropy>=0:astro/py-astropy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}aiohttp>=0:www/py-aiohttp@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}parfive>=0:ftp/py-parfive@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy14>=0:databases/py-sqlalchemy14@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR}
+
+USES= python:3.9+
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/astro/py-sunpy/distinfo b/astro/py-sunpy/distinfo
new file mode 100644
index 000000000000..b9d1a6381d95
--- /dev/null
+++ b/astro/py-sunpy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1682172213
+SHA256 (sunpy-4.1.5.tar.gz) = f5ceabbb665c52e663bea3de30fcd04eda28e262733079748ab2b0ac7704afc8
+SIZE (sunpy-4.1.5.tar.gz) = 3611127
diff --git a/astro/py-sunpy/pkg-descr b/astro/py-sunpy/pkg-descr
new file mode 100644
index 000000000000..ac53532347c2
--- /dev/null
+++ b/astro/py-sunpy/pkg-descr
@@ -0,0 +1,3 @@
+Sunpy is a Python software package that provides fundamental tools for
+accessing, loading and interacting with solar physics data in Python.
+It is the core library of the SunPy Project.