aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-06-30 07:02:58 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-06-30 07:02:58 +0000
commita870edef75b348be79114cbdbfe3f44f9abae6c6 (patch)
tree6f6f0dfa43444bc6902c80ae981d275549f62a68 /astro
parent4ea81886d1cea72cf529dcc81b5315de2f4ff35e (diff)
downloadports-a870edef75b348be79114cbdbfe3f44f9abae6c6.tar.gz
ports-a870edef75b348be79114cbdbfe3f44f9abae6c6.zip
astro/py-metpy: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
Diffstat (limited to 'astro')
-rw-r--r--astro/py-metpy/Makefile7
-rw-r--r--astro/py-metpy/files/patch-pyproject.toml11
2 files changed, 16 insertions, 2 deletions
diff --git a/astro/py-metpy/Makefile b/astro/py-metpy/Makefile
index 0e5619fe77ef..cdc1026d25b5 100644
--- a/astro/py-metpy/Makefile
+++ b/astro/py-metpy/Makefile
@@ -1,5 +1,6 @@
PORTNAME= metpy
PORTVERSION= 1.5.0
+PORTREVISION= 1
CATEGORIES= astro python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +13,9 @@ WWW= https://github.com/Unidata/MetPy
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=42:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=3.3.0:math/py-matplotlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}numpy>=1.18.0,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pandas>=1.0.0,1:math/py-pandas@${PY_FLAVOR} \
@@ -24,7 +27,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=3.3.0:math/py-matplotlib@${PY_FL
${PYTHON_PKGNAMEPREFIX}xarray>=0.18.0:devel/py-xarray@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/astro/py-metpy/files/patch-pyproject.toml b/astro/py-metpy/files/patch-pyproject.toml
new file mode 100644
index 000000000000..e35218e8defb
--- /dev/null
+++ b/astro/py-metpy/files/patch-pyproject.toml
@@ -0,0 +1,11 @@
+--- pyproject.toml.orig 2023-05-16 23:38:03 UTC
++++ pyproject.toml
+@@ -3,7 +3,7 @@ requires = ["setuptools>=42", "wheel", "setuptools_scm
+ build-backend = "setuptools.build_meta"
+
+ [project]
+-name = "MetPy"
++name = "metpy"
+ description = "Collection of tools for reading, visualizing and performing calculations with weather data."
+ readme = "README.md"
+ dynamic = ["version"]