aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-10-20 18:34:26 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-10-20 18:34:26 +0000
commitdab9f314ab46b24c3c18aa14a25fc9974719798d (patch)
tree894ddc408f5f4d2085bb356f6191794230ab16bf /astro
parent2dfdbf77b6bff872b4343d1934feaa535c368b6e (diff)
downloadports-dab9f314ab46b24c3c18aa14a25fc9974719798d.tar.gz
ports-dab9f314ab46b24c3c18aa14a25fc9974719798d.zip
New port gkrellmseti version 0.6.5: A SETI@home plugin for GKrellM
Submitted by: Hammurabi Mendes <hmendes_br@yahoo.com>
Notes
Notes: svn path=/head/; revision=49008
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/gkrellmseti/Makefile40
-rw-r--r--astro/gkrellmseti/distinfo1
-rw-r--r--astro/gkrellmseti/files/patch-Makefile28
-rw-r--r--astro/gkrellmseti/files/patch-seti.c15
-rw-r--r--astro/gkrellmseti/pkg-comment1
-rw-r--r--astro/gkrellmseti/pkg-descr12
-rw-r--r--astro/gkrellmseti/pkg-plist5
8 files changed, 103 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index bd946ad0ecb5..6245f845f175 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -7,6 +7,7 @@
SUBDIR += fooseti
SUBDIR += gkrellmearth
SUBDIR += gkrellmoon
+ SUBDIR += gkrellmseti
SUBDIR += glunarclock
SUBDIR += jday
SUBDIR += ksetiwatch
diff --git a/astro/gkrellmseti/Makefile b/astro/gkrellmseti/Makefile
new file mode 100644
index 000000000000..ef4c167ec359
--- /dev/null
+++ b/astro/gkrellmseti/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: gkrellmseti
+# Date created: Sat Oct 13 01:27:47 BRT 2001
+# Whom: Hammurabi Mendes <hmendes_br@yahoo.com> et al
+#
+# $FreeBSD$
+#
+
+PORTNAME= seti
+PORTVERSION= 0.6.5
+CATEGORIES= astro
+MASTER_SITES= http://xavier.serpaggi.free.fr/seti/
+PKGNAMEPREFIX= gkrellm
+
+MAINTAINER= hmendes_br@yahoo.com
+
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GTK= yes
+USE_IMLIB= yes
+USE_XPM= yes
+
+DOC_FILES= AUTHORS README TODO
+
+post-patch:
+ @${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/seti.c
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/seti.so \
+ ${PREFIX}/libexec/gkrellm/plugins
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/astro/gkrellmseti/distinfo b/astro/gkrellmseti/distinfo
new file mode 100644
index 000000000000..a14b13c70a96
--- /dev/null
+++ b/astro/gkrellmseti/distinfo
@@ -0,0 +1 @@
+MD5 (seti-0.6.5.tar.bz2) = 69e347a9b3aa681bad53b8c7cd9eaaa1
diff --git a/astro/gkrellmseti/files/patch-Makefile b/astro/gkrellmseti/files/patch-Makefile
new file mode 100644
index 000000000000..5038b8343b52
--- /dev/null
+++ b/astro/gkrellmseti/files/patch-Makefile
@@ -0,0 +1,28 @@
+--- Makefile.orig Sat Aug 18 07:56:04 2001
++++ Makefile Sat Oct 13 12:39:09 2001
+@@ -1,9 +1,9 @@
+-CFLAGS= -fpic -Wall `gtk-config --cflags` `imlib-config --cflags-gdk`
+-LDFLAGS= -shared -Wl
++CFLAGS+= -fpic -Wall `${GTK_CONFIG} --cflags` `${IMLIB_CONFIG} --cflags-gdk`
++LDFLAGS+= -shared -Wl
+
+ # uncomment the second DBGFLAGS line to make seti@home plugin
+ # be verbose when GKrellM is launched with the --debug option.
+-DBGFLAGS= -O3
++#DBGFLAGS= -O3
+ #DBGFLAGS=-DDEBUG
+
+ all: seti.so
+@@ -12,10 +12,10 @@
+ cp seti.so ${HOME}/.gkrellm/plugins/
+
+ seti.so: seti.o
+- gcc $(LDFLAGS) -o seti.so seti.o
++ ${CC} $(LDFLAGS) -o seti.so seti.o
+
+ seti.o: seti.c seti.h
+- gcc $(CFLAGS) $(DBGFLAGS) -c seti.c
++ ${CC} $(CFLAGS) $(DBGFLAGS) -c seti.c
+
+ tags:
+ ctags seti.c seti.h
diff --git a/astro/gkrellmseti/files/patch-seti.c b/astro/gkrellmseti/files/patch-seti.c
new file mode 100644
index 000000000000..ee56616cdbb7
--- /dev/null
+++ b/astro/gkrellmseti/files/patch-seti.c
@@ -0,0 +1,15 @@
+--- seti.c.orig Sat Oct 20 16:24:45 2001
++++ seti.c Sat Oct 20 16:25:59 2001
+@@ -1106,10 +1106,10 @@
+ style_id = gkrellm_add_meter_style(&plugin_mon, STYLE_NAME);
+
+ g_free(client_info.seti_file_path) ;
+- client_info.seti_file_path = g_strdup("/opt/setiathome/") ;
++ client_info.seti_file_path = g_strdup("/var/db/setiathome/") ;
+
+ g_free(client_info.seti_client_path) ;
+- client_info.seti_client_path = g_strdup("/opt/setiathome/") ;
++ client_info.seti_client_path = g_strdup("/%%LOCALBASE%%/sbin/") ;
+
+ g_free(client_info.state_file) ;
+ client_info.state_file = g_strdup_printf("%s/state.sah", client_info.seti_file_path) ;
diff --git a/astro/gkrellmseti/pkg-comment b/astro/gkrellmseti/pkg-comment
new file mode 100644
index 000000000000..5dca65d17f6b
--- /dev/null
+++ b/astro/gkrellmseti/pkg-comment
@@ -0,0 +1 @@
+A SETI@home plugin for GKrellM
diff --git a/astro/gkrellmseti/pkg-descr b/astro/gkrellmseti/pkg-descr
new file mode 100644
index 000000000000..5b464a95f433
--- /dev/null
+++ b/astro/gkrellmseti/pkg-descr
@@ -0,0 +1,12 @@
+SETI@home GKrellM plugin
+(for GKrellM 0.10.3 or later)
+
+SETI@home GKrellM plugin is a progress meter that shows the current
+computation progress of a seti-workunit.
+Current working unit and completion percent is available via a
+tooltip.
+Progress value is read every minute as client write his results
+every minute.
+
+Author: Xavier Serpaggi <xavier.serpaggi@free.fr>
+WWW: http://xavier.serpaggi.free.fr/seti/
diff --git a/astro/gkrellmseti/pkg-plist b/astro/gkrellmseti/pkg-plist
new file mode 100644
index 000000000000..8599722a8a6f
--- /dev/null
+++ b/astro/gkrellmseti/pkg-plist
@@ -0,0 +1,5 @@
+libexec/gkrellm/plugins/seti.so
+%%PORTDOCS%%share/doc/seti/AUTHORS
+%%PORTDOCS%%share/doc/seti/README
+%%PORTDOCS%%share/doc/seti/TODO
+%%PORTDOCS%%@dirrm share/doc/seti