aboutsummaryrefslogtreecommitdiff
path: root/audio/adplay/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2020-05-23 14:40:51 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2020-05-23 14:40:51 +0000
commit310ee7e299308aca58ba1d85604ffad7a967d246 (patch)
tree933cf61321d6584d5cae9a020b27d9601bc1dd53 /audio/adplay/Makefile
parentccbd09a547d3d81928d5bcdffbb314909618b776 (diff)
downloadports-310ee7e299308aca58ba1d85604ffad7a967d246.tar.gz
ports-310ee7e299308aca58ba1d85604ffad7a967d246.zip
- Provide a patch to build with libadplug 2.3.2 [1]
- While here make portlint, portfmt, portclippy happy Obtained from: pkgsrc [1]
Notes
Notes: svn path=/head/; revision=536301
Diffstat (limited to 'audio/adplay/Makefile')
-rw-r--r--audio/adplay/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/audio/adplay/Makefile b/audio/adplay/Makefile
index 693b276e89b8..5fce2e2fcf79 100644
--- a/audio/adplay/Makefile
+++ b/audio/adplay/Makefile
@@ -3,8 +3,8 @@
PORTNAME= adplay
PORTVERSION= 1.8
-PORTREVISION= 1
DISTVERSIONPREFIX= v
+PORTREVISION= 2
CATEGORIES= audio
MAINTAINER= ehaupt@FreeBSD.org
@@ -17,30 +17,32 @@ LIB_DEPENDS= libadplug.so:audio/libadplug \
libbinio.so:devel/libbinio
USES= autoreconf libtool pkgconfig
-GNU_CONFIGURE= yes
USE_GITHUB= yes
GH_ACCOUNT= adplug
GH_PROJECT= ${PORTNAME}-unix
GH_TUPLE= adplug:database:${DBVERSION}:database/database-${DBVERSION}
-DBFILE= adplug.db
-DBVERSION= v1.0
-
+GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sharedstatedir=${DATADIR}
+PLIST_FILES= ${DATADIR}/adplug.db \
+ bin/adplay \
+ man/man1/adplay.1.gz
+
OPTIONS_DEFINE= ALSA SDL
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
-ALSA_CONFIGURE_WITH= alsa-prefix=${LOCALBASE}/lib
ALSA_CONFIGURE_OFF= --disable-output-alsa
+ALSA_CONFIGURE_WITH= alsa-prefix=${LOCALBASE}/lib
ALSA_CFLAGS+= `pkg-config --cflags alsa`
-SDL_CONFIGURE_OFF= --disable-output-sdl
SDL_USES= sdl
-SDL_USE= SDL=sdl,mixer
+SDL_USE= SDL=mixer,sdl
+SDL_CONFIGURE_OFF= --disable-output-sdl
-PLIST_FILES= bin/adplay %%DATADIR%%/adplug.db man/man1/adplay.1.gz
+DBFILE= adplug.db
+DBVERSION= v1.0
post-patch:
@${RM} ${WRKSRC}/src/getopt.h