aboutsummaryrefslogtreecommitdiff
path: root/audio/alsa-plugins
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /audio/alsa-plugins
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Notes
Notes: svn path=/head/; revision=282282
Diffstat (limited to 'audio/alsa-plugins')
-rw-r--r--audio/alsa-plugins/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/audio/alsa-plugins/Makefile b/audio/alsa-plugins/Makefile
index 773667bf1ff5..2df875680364 100644
--- a/audio/alsa-plugins/Makefile
+++ b/audio/alsa-plugins/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= asound.2:${PORTSDIR}/audio/alsa-lib
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GNOME= pkgconfig
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS= JACK "JACK audio support (requires SAMPLERATE)" Off \
LAVC "libavcodec support" Off \
@@ -43,7 +43,7 @@ CONFIGURE_ARGS+= --disable-jack
.if defined(WITH_LAVC)
CONFIGURE_ARGS+= --enable-avcodec
-CONFIGURE_ENV+= CFLAGS=-I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include
LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
PLIST_SUB+= LAVC=""
.else