aboutsummaryrefslogtreecommitdiff
path: root/audio/aqualung
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-09-02 04:28:31 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-09-02 04:28:31 +0000
commitf2e1dffb9905d3d8e993c0727854b66206eee52a (patch)
treeba15a970f2eb3592496d8d6df77406b4aeff22cd /audio/aqualung
parent024bababe780c89da40808fc58eae0e70dce79d3 (diff)
downloadports-f2e1dffb9905d3d8e993c0727854b66206eee52a.tar.gz
ports-f2e1dffb9905d3d8e993c0727854b66206eee52a.zip
Remove unused duplicate global symbols to fix the build against modern
compilers which by default place uninitialized global variables in the BSS section of the object file; this inhibits the merging of tentative definitions by the linker and results in the multiple-definition error because the same variable is defined in more than one compilation unit. Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=547322
Diffstat (limited to 'audio/aqualung')
-rw-r--r--audio/aqualung/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/audio/aqualung/Makefile b/audio/aqualung/Makefile
index b27a84e61c17..b4e36232987d 100644
--- a/audio/aqualung/Makefile
+++ b/audio/aqualung/Makefile
@@ -53,4 +53,10 @@ SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio
SNDIO_CONFIGURE_ON= --with-sndio=yes
SNDIO_CONFIGURE_OFF= --with-sndio=no
+post-patch:
+# Remove unused duplicate global symbols (-fno-common)
+ @${REINPLACE_CMD} -E '/^g?char command/d' \
+ ${WRKSRC}/src/gui_main.c \
+ ${WRKSRC}/src/playlist.c
+
.include <bsd.port.mk>