aboutsummaryrefslogtreecommitdiff
path: root/audio/ardour
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2008-01-19 18:25:33 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2008-01-19 18:25:33 +0000
commit82c5cc9580166a793c9af5026072bf8844798657 (patch)
tree6e4ad1e1a51507aff8f6485e9b4fd5ecc22c67cf /audio/ardour
parent0f1dde377dfff84613b9acf9eb3a3af6b00d17a5 (diff)
downloadports-82c5cc9580166a793c9af5026072bf8844798657.tar.gz
ports-82c5cc9580166a793c9af5026072bf8844798657.zip
- Update to 2.2.
Notes
Notes: svn path=/head/; revision=205839
Diffstat (limited to 'audio/ardour')
-rw-r--r--audio/ardour/Makefile6
-rw-r--r--audio/ardour/distinfo9
-rw-r--r--audio/ardour/files/patch-gtk2_ardour-editor_mouse.cc13
-rw-r--r--audio/ardour/files/patch-gtk2_ardour-engine_dialog.cc33
-rw-r--r--audio/ardour/files/patch-gtk2_ardour-new_session_dialog.cc11
-rw-r--r--audio/ardour/pkg-plist11
6 files changed, 46 insertions, 37 deletions
diff --git a/audio/ardour/Makefile b/audio/ardour/Makefile
index 47559956a1a6..bbaea2861a0d 100644
--- a/audio/ardour/Makefile
+++ b/audio/ardour/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ardour
-PORTVERSION= 2.1
+PORTVERSION= 2.2
CATEGORIES= audio
MASTER_SITES= http://ardour.org/files/releases/
DISTFILES= ardour-${DISTVERSION}.tar.bz2
@@ -25,7 +25,9 @@ LIB_DEPENDS= lrdf.2:${PORTSDIR}/textproc/liblrdf \
sqlite3:${PORTSDIR}/databases/sqlite3 \
lo.6:${PORTSDIR}/audio/liblo \
SoundTouch.0:${PORTSDIR}/audio/soundtouch \
- usb:${PORTSDIR}/devel/libusb
+ usb:${PORTSDIR}/devel/libusb \
+ fftw3f:${PORTSDIR}/math/fftw3-float \
+ fftw3:${PORTSDIR}/math/fftw3
USE_SCONS= yes
SCONS_ENV+= SYSLIBS=yes PREFIX=${PREFIX} NLS=yes
diff --git a/audio/ardour/distinfo b/audio/ardour/distinfo
index be5032e57e26..750cb5d7033f 100644
--- a/audio/ardour/distinfo
+++ b/audio/ardour/distinfo
@@ -1,6 +1,3 @@
-MD5 (ardour-2.1.tar.bz2) = 18be414a37b832aae23c068ba9fcf8ab
-SHA256 (ardour-2.1.tar.bz2) = 160482d87d8eb2188481fc42d7f6442efe6bff38544a321a79e2e23a7aa9501b
-SIZE (ardour-2.1.tar.bz2) = 2788128
-MD5 (vst_sdk2_3.zip) = c91d3be58ad4e9c695d0a90b2198be0d
-SHA256 (vst_sdk2_3.zip) = 5400e0bbfeef0ab8a67b48899a9e8067db47552f43b30d8d15323ab999523226
-SIZE (vst_sdk2_3.zip) = 4147357
+MD5 (ardour-2.2.tar.bz2) = 151dcc194dfdba3cd7f61faeed6e06f5
+SHA256 (ardour-2.2.tar.bz2) = fc0d405e1e1d31b3e353095db67b7dc874c201ff43954751b72f57ae836799ee
+SIZE (ardour-2.2.tar.bz2) = 4296980
diff --git a/audio/ardour/files/patch-gtk2_ardour-editor_mouse.cc b/audio/ardour/files/patch-gtk2_ardour-editor_mouse.cc
deleted file mode 100644
index 0afc91f5408f..000000000000
--- a/audio/ardour/files/patch-gtk2_ardour-editor_mouse.cc
+++ /dev/null
@@ -1,13 +0,0 @@
---- gtk2_ardour/editor_mouse.cc.orig 2007-10-04 12:36:29.000000000 +0200
-+++ gtk2_ardour/editor_mouse.cc 2007-10-04 12:37:18.000000000 +0200
-@@ -1449,8 +1449,8 @@
- */
- if (!drag_info.move_threshold_passed) {
-
-- bool x_threshold_passed = (abs ((nframes64_t) (drag_info.current_pointer_x - drag_info.grab_x)) > 4LL);
-- bool y_threshold_passed = (abs ((nframes64_t) (drag_info.current_pointer_y - drag_info.grab_y)) > 4LL);
-+ bool x_threshold_passed = (::llabs ((nframes64_t) (drag_info.current_pointer_x - drag_info.grab_x)) > 4LL);
-+ bool y_threshold_passed = (::llabs ((nframes64_t) (drag_info.current_pointer_y - drag_info.grab_y)) > 4LL);
-
- drag_info.move_threshold_passed = (x_threshold_passed || y_threshold_passed);
-
diff --git a/audio/ardour/files/patch-gtk2_ardour-engine_dialog.cc b/audio/ardour/files/patch-gtk2_ardour-engine_dialog.cc
index a85da80853e6..cbaa5f1261d1 100644
--- a/audio/ardour/files/patch-gtk2_ardour-engine_dialog.cc
+++ b/audio/ardour/files/patch-gtk2_ardour-engine_dialog.cc
@@ -1,6 +1,6 @@
---- gtk2_ardour/engine_dialog.cc.orig 2007-09-20 20:05:43.000000000 +0200
-+++ gtk2_ardour/engine_dialog.cc 2007-09-29 23:55:29.000000000 +0200
-@@ -10,7 +10,7 @@
+--- gtk2_ardour/engine_dialog.cc.orig 2008-01-15 03:58:38.000000000 +0100
++++ gtk2_ardour/engine_dialog.cc 2008-01-15 22:30:06.000000000 +0100
+@@ -12,7 +12,7 @@
#include <CoreFoundation/CFString.h>
#include <sys/param.h>
#include <mach-o/dyld.h>
@@ -9,7 +9,7 @@
#include <alsa/asoundlib.h>
#endif
-@@ -110,7 +110,9 @@
+@@ -113,7 +113,9 @@
#ifdef __APPLE__
strings.push_back (X_("CoreAudio"));
#else
@@ -64,7 +64,7 @@
label = manage (new Label (_("Input device")));
label->set_alignment (1.0, 0.5);
device_packer.attach (*label, 0, 1, row, row+1, FILL|EXPAND, (AttachOptions) 0);
-@@ -573,7 +575,7 @@
+@@ -568,7 +570,7 @@
void
EngineControl::realtime_changed ()
{
@@ -73,17 +73,18 @@
priority_spinner.set_sensitive (realtime_button.get_active());
#endif
}
-@@ -586,7 +588,9 @@
- #ifdef __APPLE__
- devices["CoreAudio"] = enumerate_coreaudio_devices ();
- #else
+@@ -584,8 +586,10 @@
+ #endif
+
+ #ifndef __APPLE__
+#ifndef __FreeBSD__
- devices["ALSA"] = enumerate_alsa_devices ();
+ } else if (driver == "ALSA") {
+ devices[driver] = enumerate_alsa_devices ();
+#endif
- devices["FFADO"] = enumerate_ffado_devices ();
- devices["OSS"] = enumerate_oss_devices ();
- devices["Dummy"] = enumerate_dummy_devices ();
-@@ -665,6 +669,7 @@
+ } else if (driver == "FFADO") {
+ devices[driver] = enumerate_ffado_devices ();
+ } else if (driver == "OSS") {
+@@ -712,6 +716,7 @@
return devs;
}
#else
@@ -91,7 +92,7 @@
vector<string>
EngineControl::enumerate_alsa_devices ()
{
-@@ -725,6 +730,7 @@
+@@ -772,6 +777,7 @@
return devs;
}
@@ -99,7 +100,7 @@
vector<string>
EngineControl::enumerate_ffado_devices ()
-@@ -803,7 +809,7 @@
+@@ -860,7 +866,7 @@
EngineControl::redisplay_latency ()
{
uint32_t rate = get_rate();
diff --git a/audio/ardour/files/patch-gtk2_ardour-new_session_dialog.cc b/audio/ardour/files/patch-gtk2_ardour-new_session_dialog.cc
new file mode 100644
index 000000000000..f925ad1a8ee4
--- /dev/null
+++ b/audio/ardour/files/patch-gtk2_ardour-new_session_dialog.cc
@@ -0,0 +1,11 @@
+--- gtk2_ardour/new_session_dialog.cc.orig 2008-01-14 10:04:17.000000000 +0100
++++ gtk2_ardour/new_session_dialog.cc 2008-01-14 10:04:44.000000000 +0100
+@@ -556,7 +556,7 @@
+ */
+
+
+-#ifdef __APPLE__
++#ifndef __Linux__
+
+ char buf[PATH_MAX];
+
diff --git a/audio/ardour/pkg-plist b/audio/ardour/pkg-plist
index a467b94d75dd..879a6749e792 100644
--- a/audio/ardour/pkg-plist
+++ b/audio/ardour/pkg-plist
@@ -9,6 +9,9 @@ lib/ardour2/libardour.so
%%VST%%lib/ardour2/libardourgtk.so
lib/ardour2/libgtkmm2ext.so
lib/ardour2/libardour_cp.so
+lib/ardour2/libvampsdk.so
+lib/ardour2/libsoundtouch.so
+lib/ardour2/librubberband.so
lib/ardour2/surfaces/libardour_genericmidi.so
lib/ardour2/surfaces/libardour_mackie.so
lib/ardour2/surfaces/libardour_tranzport.so
@@ -22,6 +25,9 @@ etc/ardour2/ardour_system.rc
etc/ardour2/ardour2_ui_dark.rc
etc/ardour2/ardour2_ui_light.rc
etc/ardour2/ardour2_ui_default.conf
+etc/ardour2/ardour-sae.menus
+etc/ardour2/ardour-sae-ansi.bindings
+etc/ardour2/ardour-sae-de.bindings
@dirrmtry etc/ardour2
share/ardour2/splash.png
share/ardour2/pixmaps/hslider00.xpm
@@ -103,6 +109,10 @@ share/ardour2/icons/ardour_icon_48px.png
share/ardour2/icons/ardour_icon_32px.png
share/ardour2/icons/ardour_icon_16px.png
share/ardour2/icons/saelogo.png
+share/ardour2/icons/saebig.png
+share/ardour2/icons/saelogo2.png
+share/ardour2/icons/saeoldlogo.png
+share/ardour2/icons/sae.png
@dirrm share/ardour2/icons
share/ardour2/templates/16 Tracks.template
share/ardour2/templates/2 Track.template
@@ -128,6 +138,7 @@ share/locale/it_IT/LC_MESSAGES/gtk2_ardour.mo
share/locale/sv_SE/LC_MESSAGES/libardour2.mo
share/locale/sv_SE/LC_MESSAGES/gtk2_ardour.mo
share/locale/de_DE/LC_MESSAGES/gtk2_ardour.mo
+share/locale/de_DE/LC_MESSAGES/libardour2.mo
@dirrmtry share/locale/it_IT/LC_MESSAGES
@dirrmtry share/locale/it_IT
@dirrmtry share/locale/sv_SE/LC_MESSAGES