aboutsummaryrefslogtreecommitdiff
path: root/audio/ario/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2011-07-25 22:03:16 +0000
committerPav Lucistnik <pav@FreeBSD.org>2011-07-25 22:03:16 +0000
commitd72e079535043990bebbfd150f70ea4fa58120e9 (patch)
tree3efd81fb554de925474548d10c99660093756148 /audio/ario/Makefile
parent278bb6f052edfe6b3987593f3c0be1766fb41604 (diff)
downloadports-d72e079535043990bebbfd150f70ea4fa58120e9.tar.gz
ports-d72e079535043990bebbfd150f70ea4fa58120e9.zip
- Fix build with new libgcrypt
- Provide avahi option PR: ports/159018 Submitted by: Grzegorz Blach <magik@roorback.net> (maintainer)
Notes
Notes: svn path=/head/; revision=278330
Diffstat (limited to 'audio/ario/Makefile')
-rw-r--r--audio/ario/Makefile20
1 files changed, 15 insertions, 5 deletions
diff --git a/audio/ario/Makefile b/audio/ario/Makefile
index dc28cea02fc0..d3657bac26bb 100644
--- a/audio/ario/Makefile
+++ b/audio/ario/Makefile
@@ -13,7 +13,10 @@ MASTER_SITES= SF/ario-player/ario-player/${PORTVERSION}
MAINTAINER= magik@roorback.net
COMMENT= Ario is a GTK2 client for MPD
+LICENSE= GPLv2
+
LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls \
+ gcrypt:${PORTSDIR}/security/libgcrypt \
curl:${PORTSDIR}/ftp/curl \
notify:${PORTSDIR}/devel/libnotify \
soup:${PORTSDIR}/devel/libsoup22 \
@@ -22,21 +25,28 @@ LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls \
mpdclient:${PORTSDIR}/audio/libmpdclient
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-avahi # without this ario don't build
USE_LDCONFIG= yes
USE_GMAKE= yes
USE_GNOME= gtk20 gnomehack gnometarget
INSTALLS_ICONS= yes
-OPTIONS= NLS "Use NLS" On
+OPTIONS= AVAHI "Zeroconf support (Avahi)" Off \
+ NLS "NLS support" On
.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
+.if defined(WITH_AVAHI)
+LIB_DEPENDS+= avahi-client:${PORTSDIR}/net/avahi-app
+CONFIGURE_ARGS+= --enable-avahi
.else
-CONFIGURE_ARGS+= --enable-nls
+CONFIGURE_ARGS+= --disable-avahi
+.endif
+
+.if ! defined(WITHOUT_NLS)
USE_GETTEXT= yes
+CONFIGURE_ARGS+= --enable-nls
+.else
+CONFIGURE_ARGS+= --disable-nls
.endif
.include <bsd.port.mk>