aboutsummaryrefslogtreecommitdiff
path: root/audio/asterisk-espeak
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2017-08-22 13:01:11 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2017-08-22 13:01:11 +0000
commit6136e71df8b825739644ed12aa659d6350647fee (patch)
tree813f9a25866a4945e5e9da605789bedc93a36d4a /audio/asterisk-espeak
parent3660ac138acf7f2702c615c788c6e74635c89172 (diff)
downloadports-6136e71df8b825739644ed12aa659d6350647fee.tar.gz
ports-6136e71df8b825739644ed12aa659d6350647fee.zip
Update to 4.0
Notes
Notes: svn path=/head/; revision=448521
Diffstat (limited to 'audio/asterisk-espeak')
-rw-r--r--audio/asterisk-espeak/Makefile8
-rw-r--r--audio/asterisk-espeak/distinfo6
-rw-r--r--audio/asterisk-espeak/files/patch-Makefile43
3 files changed, 29 insertions, 28 deletions
diff --git a/audio/asterisk-espeak/Makefile b/audio/asterisk-espeak/Makefile
index fadd5c7c5fd3..71de9d7eff94 100644
--- a/audio/asterisk-espeak/Makefile
+++ b/audio/asterisk-espeak/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= asterisk-espeak
-PORTVERSION= 3.0
+PORTVERSION= 4.0
DISTVERSIONPREFIX= v
CATEGORIES= audio
@@ -13,13 +13,13 @@ LICENSE= GPLv2
LIB_DEPENDS= libespeak.so:audio/espeak \
libsamplerate.so:audio/libsamplerate
+USES= compiler gmake localbase
+INSTALL_TARGET= install samples
+
USE_GITHUB= yes
GH_ACCOUNT= zaf
GH_PROJECT= Asterisk-eSpeak
-USES= compiler gmake localbase
-INSTALL_TARGET= install samples
-
OPTIONS_SINGLE= ASTVER
OPTIONS_SINGLE_ASTVER= ASTERISK11 ASTERISK13
OPTIONS_DEFAULT= ASTERISK13
diff --git a/audio/asterisk-espeak/distinfo b/audio/asterisk-espeak/distinfo
index 3990e3e6bb3c..f1769e752ced 100644
--- a/audio/asterisk-espeak/distinfo
+++ b/audio/asterisk-espeak/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1483464333
-SHA256 (zaf-Asterisk-eSpeak-v3.0_GH0.tar.gz) = 47c7629853ad54a2f3b50a5407db356ab7806f5fa40f9811a129208d6eeec398
-SIZE (zaf-Asterisk-eSpeak-v3.0_GH0.tar.gz) = 13758
+TIMESTAMP = 1503328653
+SHA256 (zaf-Asterisk-eSpeak-v4.0_GH0.tar.gz) = 29b76b8483e398bde9b3639ebb7d89e86c5ff1bac339e6c5bea7e6b9518dd369
+SIZE (zaf-Asterisk-eSpeak-v4.0_GH0.tar.gz) = 13739
diff --git a/audio/asterisk-espeak/files/patch-Makefile b/audio/asterisk-espeak/files/patch-Makefile
index 29faa9c4d015..d707f3a69fc9 100644
--- a/audio/asterisk-espeak/files/patch-Makefile
+++ b/audio/asterisk-espeak/files/patch-Makefile
@@ -1,31 +1,33 @@
---- Makefile.orig 2016-03-19 11:15:32 UTC
+--- Makefile.orig 2017-01-08 00:20:52 UTC
+++ Makefile
-@@ -7,30 +7,15 @@
+@@ -6,31 +6,18 @@
+ # the GNU General Public License Version 2. See the COPYING file
# at the top of the source tree.
- INSTALL=install
--ASTLIBDIR:=$(shell awk '/moddir/{print $$3}' /etc/asterisk/asterisk.conf)
+-ASTLIBDIR:=$(shell awk '/moddir/{print $$3}' /etc/asterisk/asterisk.conf 2> /dev/null)
-ifeq ($(strip $(ASTLIBDIR)),)
-- MODULES_DIR=$(INSTALL_PREFIX)/usr/lib/asterisk/modules
+- MODULES_DIR:=$(INSTALL_PREFIX)/usr/lib/asterisk/modules
-else
-- MODULES_DIR=$(INSTALL_PREFIX)$(ASTLIBDIR)
+- MODULES_DIR:=$(INSTALL_PREFIX)$(ASTLIBDIR)
-endif
--ASTETCDIR=$(INSTALL_PREFIX)/etc/asterisk
+-ASTETCDIR:=$(INSTALL_PREFIX)/etc/asterisk
+MODULES_DIR=$(PREFIX)/lib/asterisk/modules
+ASTETCDIR=$(PREFIX)/etc/asterisk
- SAMPLENAME=espeak.conf.sample
--CONFNAME=$(basename $(SAMPLENAME))
--
--CC=gcc
--OPTIMIZE=-O2
--DEBUG=-g
-+CONFNAME=$(SAMPLENAME)
+ SAMPLENAME:=espeak.conf.sample
+-CONFNAME:=$(basename $(SAMPLENAME))
++CONFNAME:=$(SAMPLENAME)
+
+ INSTALL:=install
+-CC:=gcc
+-OPTIMIZE:=-O2
+-DEBUG:=-g
++CC?=gcc
-LIBS+=-lespeak -lsamplerate
+LIBS+=$(LDFLAGS) -lespeak -lsamplerate
- CFLAGS+=-pipe -fPIC -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -D_REENTRANT -D_GNU_SOURCE
+ CFLAGS+=-pipe -fPIC -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -D_REENTRANT -D_GNU_SOURCE -DAST_MODULE_SELF_SYM=__internal_app_espeak_self
- all: _all
+ all: app_espeak.so
- @echo " +-------- app_espeak Build Complete --------+"
- @echo " + app_espeak has successfully been built, +"
- @echo " + and can be installed by running: +"
@@ -33,10 +35,10 @@
- @echo " + make install +"
- @echo " +-------------------------------------------+"
- _all: app_espeak.so
-
-@@ -46,21 +31,7 @@ clean:
- install: _all
+ app_espeak.o: app_espeak.c
+ $(CC) $(CFLAGS) $(DEBUG) $(OPTIMIZE) -c -o $@ $*.c
+@@ -44,20 +31,7 @@ clean:
+ install: all
$(INSTALL) -m 755 -d $(DESTDIR)$(MODULES_DIR)
$(INSTALL) -m 755 app_espeak.so $(DESTDIR)$(MODULES_DIR)
- @echo " +---- app_espeak Installation Complete -----+"
@@ -56,4 +58,3 @@
- fi ;
$(INSTALL) -m 644 $(SAMPLENAME) $(DESTDIR)$(ASTETCDIR)/$(CONFNAME)
- @echo " ------- app_esepak confing Installed --------"
--