aboutsummaryrefslogtreecommitdiff
path: root/audio/asterisk-flite/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2018-04-12 11:07:19 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2018-04-12 11:07:19 +0000
commit9b8b75fd295a3569afe54825d2b79b8779e7ad1e (patch)
treeafce3f6747f881d38315672b050aec9eddd1a1e8 /audio/asterisk-flite/Makefile
parent957253e46dbd351e214d474bae2fe956ae3db8dd (diff)
downloadports-9b8b75fd295a3569afe54825d2b79b8779e7ad1e.tar.gz
ports-9b8b75fd295a3569afe54825d2b79b8779e7ad1e.zip
Add flavors to asterisk modules to produce packages for all asterisk
versions present in the ports tree. Approved by: portmgr (mat) Differential Revision: https://reviews.freebsd.org/D15007
Notes
Notes: svn path=/head/; revision=467143
Diffstat (limited to 'audio/asterisk-flite/Makefile')
-rw-r--r--audio/asterisk-flite/Makefile22
1 files changed, 19 insertions, 3 deletions
diff --git a/audio/asterisk-flite/Makefile b/audio/asterisk-flite/Makefile
index 7e1f4e62ee52..6b29a6046880 100644
--- a/audio/asterisk-flite/Makefile
+++ b/audio/asterisk-flite/Makefile
@@ -1,8 +1,9 @@
# $FreeBSD$
-PORTNAME= asterisk-flite
+PORTNAME= flite
PORTVERSION= 3.0
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= audio
MAINTAINER= madpilot@FreeBSD.org
@@ -11,8 +12,19 @@ COMMENT= Flite dialplan application for Asterisk
LICENSE= GPLv2
LIB_DEPENDS= libflite.so:audio/flite
-BUILD_DEPENDS= asterisk:net/asterisk13
-RUN_DEPENDS= asterisk:net/asterisk13
+
+FLAVORS= asterisk13 asterisk15
+FLAVOR?= ${FLAVORS[1]}
+
+asterisk13_PKGNAMEPREFIX= asterisk13-
+asterisk13_CONFLICTS_INSTALL= asterisk15-flite
+asterisk13_BUILD_DEPENDS= asterisk:net/asterisk13
+asterisk13_RUN_DEPENDS= asterisk:net/asterisk13
+
+asterisk15_PKGNAMEPREFIX= asterisk15-
+asterisk15_CONFLICTS_INSTALL= asterisk13-flite
+asterisk15_BUILD_DEPENDS= asterisk:net/asterisk15
+asterisk15_RUN_DEPENDS= asterisk:net/asterisk15
USES= compiler gmake localbase
INSTALL_TARGET= install samples
@@ -27,6 +39,10 @@ GH_PROJECT= Asterisk-Flite
CFLAGS+= -fblocks
.endif
+post-patch:
+ @${REINPLACE_CMD} -e '/ASTERISK_REGISTER_FILE/d' \
+ ${WRKSRC}/app_flite.c
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/asterisk/modules/app_flite.so