aboutsummaryrefslogtreecommitdiff
path: root/audio/atunes/Makefile
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2010-10-01 17:00:16 +0000
committerLars Engels <lme@FreeBSD.org>2010-10-01 17:00:16 +0000
commit2ea68b5351f8729e066b7b8ac6550df82a7e72b3 (patch)
tree81ef1d8ac999ee14c4281d31b35f6c5944ebef58 /audio/atunes/Makefile
parent31c95a33db7344ce3133e934565739cc261ba8af (diff)
downloadports-2ea68b5351f8729e066b7b8ac6550df82a7e72b3.tar.gz
ports-2ea68b5351f8729e066b7b8ac6550df82a7e72b3.zip
Update to 2.0.1
Notes
Notes: svn path=/head/; revision=262266
Diffstat (limited to 'audio/atunes/Makefile')
-rw-r--r--audio/atunes/Makefile20
1 files changed, 5 insertions, 15 deletions
diff --git a/audio/atunes/Makefile b/audio/atunes/Makefile
index 24defaf327a9..4f12016309ed 100644
--- a/audio/atunes/Makefile
+++ b/audio/atunes/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= atunes
-PORTVERSION= 1.13.6
-PORTREVISION= 4
+PORTVERSION= 2.0.1
CATEGORIES= audio java
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/aTunes%20${PORTVERSION}
-DISTNAME= aTunes_${PORTVERSION}
MAINTAINER= lme@FreeBSD.org
COMMENT= A full-featured audio player and manager developed in Java
@@ -20,7 +18,7 @@ USE_JAVA= yes
JAVA_VERSION= 1.6+
SUB_FILES= atunes
-WRKSRC= ${WRKDIR}/aTunes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-SNAPSHOT
OPTIONS= MPLAYER "Engine: Use Mplayer" on \
XINE "Engine: Use Xine" off \
@@ -65,30 +63,22 @@ DESKTOP_ENTRIES="aTunes" \
"Audio player and manager" \
"${DATADIR}/aTunes.ico" \
"aTunes" \
- "Application;Audio;AudioVideo;Java;" \
+ "Application;;AudioVideo;Java;" \
false
-INSTALL_FILES= aTunes.ico aTunes.jar build.properties changelog.txt \
- extendedLog.properties license.txt log4j.properties \
- presets.properties shortcutSpec.xml
+INSTALL_FILES= aTunes.ico aTunes.jar license.txt
-PIXMAPS= atunes125.png
+PIXMAPS= atunes.png
do-install:
@${MKDIR} ${DATADIR}
@${MKDIR} ${DATADIR}/lib
- @${MKDIR} ${DATADIR}/settings
- @${MKDIR} ${DATADIR}/translations
${INSTALL_SCRIPT} ${WRKDIR}/atunes ${PREFIX}/bin
.for file in ${INSTALL_FILES}
@${INSTALL_DATA} ${WRKSRC}/${file} ${DATADIR}/${file}
.endfor
- cd ${WRKSRC} && ${FIND} translations -type f -exec ${INSTALL_DATA} {} \
- ${DATADIR}/{} \;
cd ${WRKSRC} && ${FIND} lib -type f -name "*.jar" -exec ${INSTALL_DATA} {} \
${DATADIR}/{} \;
- cd ${WRKSRC} && ${FIND} settings -type f -exec ${INSTALL_DATA} {} \
- ${DATADIR}/{} \;
@${MKDIR} ${PREFIX}/share/pixmaps
.for file in ${PIXMAPS}
@${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/pixmaps