aboutsummaryrefslogtreecommitdiff
path: root/audio/aubio/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-15 16:57:19 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-15 16:57:19 +0000
commitef3b3465ceba35692045deebbf957bb52273429a (patch)
treefe178d540e50f8f93ab4f409456282051486ed71 /audio/aubio/Makefile
parent2a4aefd39f214bb3b1c35136909092fd415787f0 (diff)
downloadports-ef3b3465ceba35692045deebbf957bb52273429a.tar.gz
ports-ef3b3465ceba35692045deebbf957bb52273429a.zip
- Strip library
- Add LICENSE
Notes
Notes: svn path=/head/; revision=386435
Diffstat (limited to 'audio/aubio/Makefile')
-rw-r--r--audio/aubio/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/audio/aubio/Makefile b/audio/aubio/Makefile
index eea37bf3174b..c20094a9474d 100644
--- a/audio/aubio/Makefile
+++ b/audio/aubio/Makefile
@@ -3,13 +3,16 @@
PORTNAME= aubio
PORTVERSION= 0.3.2
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= audio
MASTER_SITES= http://aubio.org/pub/
MAINTAINER= ports@FreeBSD.org
COMMENT= Library for audio labelling
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
libsndfile.so:${PORTSDIR}/audio/libsndfile \
@@ -22,6 +25,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-complex
USES= gmake pathfix pkgconfig libtool
USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -lm