aboutsummaryrefslogtreecommitdiff
path: root/audio/audacity
diff options
context:
space:
mode:
authorJack <xxjack12xx@gmail.com>2021-11-14 20:31:05 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2021-11-14 20:31:05 +0000
commit6f050c504f7193f676f9670a137be71352716a65 (patch)
treedd53c1eeebdb3ae5e1727b270c7a1ca3cda97ad8 /audio/audacity
parent665e4e5edb6d6b60b6ae2e7ddf83064111b25e48 (diff)
downloadports-6f050c504f7193f676f9670a137be71352716a65.tar.gz
ports-6f050c504f7193f676f9670a137be71352716a65.zip
audio/audacity: Update to 3.1.1
Hotfix release [1]: - Fixed FFMPEG imports only importing the left channel - Improved Audacity's performance when many clips are present - Fixed a crash with detach at silences - Fixed clip name corruption when applying effects to adjacent clips - Fixed a crash with the time shift commands - Fixed custom themes not working [1] https://github.com/audacity/audacity/releases/tag/Audacity-3.1.1 PR: 259812
Diffstat (limited to 'audio/audacity')
-rw-r--r--audio/audacity/Makefile2
-rw-r--r--audio/audacity/distinfo6
-rw-r--r--audio/audacity/files/patch-cmake-proxies_libsoxr_CMakeLists.txt10
-rw-r--r--audio/audacity/files/patch-lib-src_portmixer_CMakeLists.txt11
4 files changed, 4 insertions, 25 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 8e774bd4d635..0a492c52f6fc 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -2,7 +2,7 @@
PORTNAME= audacity
DISTVERSIONPREFIX= Audacity-
-DISTVERSION= 3.1.0
+DISTVERSION= 3.1.1
CATEGORIES= audio
MAINTAINER= xxjack12xx@gmail.com
diff --git a/audio/audacity/distinfo b/audio/audacity/distinfo
index e0b6cd9c5849..8d094653c60c 100644
--- a/audio/audacity/distinfo
+++ b/audio/audacity/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1635645550
-SHA256 (audacity-audacity-Audacity-3.1.0_GH0.tar.gz) = f441fc6115277b407b7496e5009fd5066875ceccbe3a31635bbcbe5558d31828
-SIZE (audacity-audacity-Audacity-3.1.0_GH0.tar.gz) = 56424569
+TIMESTAMP = 1636782204
+SHA256 (audacity-audacity-Audacity-3.1.1_GH0.tar.gz) = 183b9cd27179230b35a17786b978fc3062782a06a08965795585658398fd3ff0
+SIZE (audacity-audacity-Audacity-3.1.1_GH0.tar.gz) = 56447499
diff --git a/audio/audacity/files/patch-cmake-proxies_libsoxr_CMakeLists.txt b/audio/audacity/files/patch-cmake-proxies_libsoxr_CMakeLists.txt
deleted file mode 100644
index f2f862a88305..000000000000
--- a/audio/audacity/files/patch-cmake-proxies_libsoxr_CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
---- cmake-proxies/libsoxr/CMakeLists.txt.orig 2021-11-03 20:20:58 UTC
-+++ cmake-proxies/libsoxr/CMakeLists.txt
-@@ -95,6 +95,4 @@ target_compile_definitions( ${TARGET} PRIVATE ${DEFINE
- target_compile_options( ${TARGET} PRIVATE ${OPTIONS} )
- target_include_directories( ${TARGET} PRIVATE ${INCLUDES} )
-
--if( CMAKE_CXX_COMPILER_ID STREQUAL "GNU" )
-- target_compile_options( ${TARGET} PRIVATE -fPIC )
--endif()
-+set_target_properties(${TARGET} PROPERTIES POSITION_INDEPENDENT_CODE On)
diff --git a/audio/audacity/files/patch-lib-src_portmixer_CMakeLists.txt b/audio/audacity/files/patch-lib-src_portmixer_CMakeLists.txt
deleted file mode 100644
index aea2acd00b63..000000000000
--- a/audio/audacity/files/patch-lib-src_portmixer_CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib-src/portmixer/CMakeLists.txt.orig 2021-11-03 20:22:02 UTC
-+++ lib-src/portmixer/CMakeLists.txt
-@@ -130,7 +130,4 @@ target_sources( ${TARGET} PRIVATE ${SOURCES} )
- target_compile_definitions( ${TARGET} PRIVATE ${DEFINES} )
- target_include_directories( ${TARGET} PRIVATE ${INCLUDES} )
- target_link_libraries( ${TARGET} PRIVATE ${LIBRARIES} )
--
--if( CMAKE_CXX_COMPILER_ID STREQUAL "GNU" )
-- target_compile_options( ${TARGET} PRIVATE -fPIC )
--endif()
-+set_target_properties(${TARGET} PROPERTIES POSITION_INDEPENDENT_CODE On)