aboutsummaryrefslogtreecommitdiff
path: root/audio/audiocd-kio/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2023-08-15 17:17:02 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2023-08-15 19:06:04 +0000
commit923c335eebe43ed05c7386db43ce16b35186d0b6 (patch)
treead52edd13331e4be9bf87a093e90a0b6bff2be31 /audio/audiocd-kio/Makefile
parent593d73f1326e5978a010080d04184f29f66ab398 (diff)
downloadports-923c335eebe43ed05c7386db43ce16b35186d0b6.tar.gz
ports-923c335eebe43ed05c7386db43ce16b35186d0b6.zip
KDE: add ecm:build dependency to KDE Gear ports
- these ports previously got their ecm transitively, but, run-time dependency on ecm is being reduced to better support KDE Plasma 6 in the future.
Diffstat (limited to 'audio/audiocd-kio/Makefile')
-rw-r--r--audio/audiocd-kio/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/audio/audiocd-kio/Makefile b/audio/audiocd-kio/Makefile
index 60b8875a23a0..995b36151c4a 100644
--- a/audio/audiocd-kio/Makefile
+++ b/audio/audiocd-kio/Makefile
@@ -1,5 +1,6 @@
PORTNAME= audiocd-kio
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= audio kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -19,9 +20,11 @@ USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash guiaddons i18n iconthemes itemviews \
jobwidgets kcmutils kdelibs4support kio notifications parts \
- service solid sonnet textwidgets unitconversion \
- widgetsaddons windowsystem xmlgui
-USE_QT= concurrent core dbus gui network phonon4 printsupport widgets xml \
+ service solid sonnet textwidgets unitconversion widgetsaddons \
+ windowsystem xmlgui \
+ ecm:build
+USE_QT= concurrent core dbus gui network phonon4 printsupport widgets \
+ xml \
buildtools:build qmake:build
USE_LDCONFIG= yes