aboutsummaryrefslogtreecommitdiff
path: root/audio/aureal-kmod
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-01-15 17:42:47 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-01-15 17:42:47 +0000
commit981f436fe76d1039b2a8e032f15ad0d947fc0a57 (patch)
tree07ba490dc836ce02f18c54d6d64745619bc8f0df /audio/aureal-kmod
parent116e7472d2bd5da3111fcc4ff992a8707eb4dc28 (diff)
downloadports-981f436fe76d1039b2a8e032f15ad0d947fc0a57.tar.gz
ports-981f436fe76d1039b2a8e032f15ad0d947fc0a57.zip
Move just-added aureal-kmod from misc into audio, because it better belongs
there. For those who missed decsription from previous commit: Add aureal-kmod - a port to provide convinient way for building FreeBSD driver for Aureal based soundcards. This driver could not be added to the base system because it's uses binary-only Linux Vortex Core object modules. The port supports 4-STABLE and 5-CURRENT, however 4-STABLE isn't tested, so please report your mileage to me. Suggested by: alex
Notes
Notes: svn path=/head/; revision=37223
Diffstat (limited to 'audio/aureal-kmod')
-rw-r--r--audio/aureal-kmod/Makefile48
-rw-r--r--audio/aureal-kmod/distinfo2
-rw-r--r--audio/aureal-kmod/files/patch-10_Makefile10
-rw-r--r--audio/aureal-kmod/files/patch-20_Makefile10
-rw-r--r--audio/aureal-kmod/files/patch-30_Makefile10
-rw-r--r--audio/aureal-kmod/files/patch-Makefile9
-rw-r--r--audio/aureal-kmod/files/patch-Makefile.inc15
-rw-r--r--audio/aureal-kmod/files/patch-au88x0.c14
-rw-r--r--audio/aureal-kmod/pkg-comment1
-rw-r--r--audio/aureal-kmod/pkg-descr3
-rw-r--r--audio/aureal-kmod/pkg-message23
-rw-r--r--audio/aureal-kmod/pkg-plist4
12 files changed, 149 insertions, 0 deletions
diff --git a/audio/aureal-kmod/Makefile b/audio/aureal-kmod/Makefile
new file mode 100644
index 000000000000..afcce3345fd3
--- /dev/null
+++ b/audio/aureal-kmod/Makefile
@@ -0,0 +1,48 @@
+# Ports collection makefile for: aureal-kmod
+# Date created: 15 January 2001
+# Whom: Maxim Sobolev <soobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aureal-kmod
+PORTVERSION= 1.5
+CATEGORIES= misc
+MASTER_SITES= http://www.cis.ohio-state.edu/~matey/au88x0/
+DISTNAME= au88x0-${PORTVERSION}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+NO_PACKAGE= package doesn't make any sense, because kld's should be in sync with running kernel to work correctly
+
+WRKSRC= ${WRKDIR}
+
+PKGMESSAGE= ${WRKSRC}/.MESSAGE
+
+MAKE_ENV= WRKSRC="${WRKSRC}"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 400000
+BROKEN= "FreeBSD 3.* isn't supported"
+.elif ${OSVERSION} < 500000
+PORTVERSION= 1.3
+.endif
+
+pre-build:
+ @if [ ! -d /sys -o ! -d /usr/src/sys ]; then \
+ ${ECHO} "****************************************" ; \
+ ${ECHO} " You need to extract kernel source tree" ; \
+ ${ECHO} " before you build this package..." ; \
+ ${ECHO} "****************************************" ; \
+ ${FALSE} ; \
+ fi
+
+pre-install:
+ @${SED} 's|%%PREFIX%%|${PREFIX}|g' ${PKGDIR}/pkg-message > ${PKGMESSAGE}
+ ${MKDIR} ${PREFIX}/lib/au88x0
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/audio/aureal-kmod/distinfo b/audio/aureal-kmod/distinfo
new file mode 100644
index 000000000000..acab6b1e35d1
--- /dev/null
+++ b/audio/aureal-kmod/distinfo
@@ -0,0 +1,2 @@
+MD5 (au88x0-1.3.tar.gz) = fe88b877286aea052af96fc5a37f9af1
+MD5 (au88x0-1.5.tar.gz) = c0e781dde9624eb1213deb84aeb9d099
diff --git a/audio/aureal-kmod/files/patch-10_Makefile b/audio/aureal-kmod/files/patch-10_Makefile
new file mode 100644
index 000000000000..f53fd9442836
--- /dev/null
+++ b/audio/aureal-kmod/files/patch-10_Makefile
@@ -0,0 +1,10 @@
+
+$FreeBSD$
+
+--- 10/Makefile.orig Mon Jan 15 18:45:58 2001
++++ 10/Makefile Mon Jan 15 18:46:31 2001
+@@ -0,0 +1,4 @@
++KMOD = snd_au8810
++SRCS += asp10.o
++
++.include <bsd.kmod.mk>
diff --git a/audio/aureal-kmod/files/patch-20_Makefile b/audio/aureal-kmod/files/patch-20_Makefile
new file mode 100644
index 000000000000..974ca87c082b
--- /dev/null
+++ b/audio/aureal-kmod/files/patch-20_Makefile
@@ -0,0 +1,10 @@
+
+$FreeBSD$
+
+--- 20/Makefile.orig Mon Jan 15 18:45:59 2001
++++ 20/Makefile Mon Jan 15 18:46:34 2001
+@@ -0,0 +1,4 @@
++KMOD = snd_au8820
++SRCS += asp20.o
++
++.include <bsd.kmod.mk>
diff --git a/audio/aureal-kmod/files/patch-30_Makefile b/audio/aureal-kmod/files/patch-30_Makefile
new file mode 100644
index 000000000000..e23040a13fe0
--- /dev/null
+++ b/audio/aureal-kmod/files/patch-30_Makefile
@@ -0,0 +1,10 @@
+
+$FreeBSD$
+
+--- 30/Makefile.orig Mon Jan 15 18:45:59 2001
++++ 30/Makefile Mon Jan 15 18:46:37 2001
+@@ -0,0 +1,4 @@
++KMOD = snd_au8830
++SRCS += asp30.o
++
++.include <bsd.kmod.mk>
diff --git a/audio/aureal-kmod/files/patch-Makefile b/audio/aureal-kmod/files/patch-Makefile
new file mode 100644
index 000000000000..795b1e286dba
--- /dev/null
+++ b/audio/aureal-kmod/files/patch-Makefile
@@ -0,0 +1,9 @@
+
+$FreeBSD$
+
+--- Makefile.orig Mon Jan 15 18:44:49 2001
++++ Makefile Mon Jan 15 18:44:49 2001
+@@ -0,0 +1,3 @@
++SUBDIR = 10 20 30
++
++.include <bsd.subdir.mk>
diff --git a/audio/aureal-kmod/files/patch-Makefile.inc b/audio/aureal-kmod/files/patch-Makefile.inc
new file mode 100644
index 000000000000..5662c830ea79
--- /dev/null
+++ b/audio/aureal-kmod/files/patch-Makefile.inc
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- Makefile.inc.orig Mon Jan 15 18:44:49 2001
++++ Makefile.inc Mon Jan 15 18:44:49 2001
+@@ -0,0 +1,9 @@
++.PATH: /sys/dev/sound/pci ${WRKSRC}
++
++KMODDIR = ${PREFIX}/lib/au88x0
++SRCS = device_if.h bus_if.h isa_if.h pci_if.h
++SRCS += au88x0.c
++.if ${OSVERSION} > 500000
++SRCS += ac97_if.h channel_if.h feeder_if.h mixer_if.h
++.endif
++CFLAGS += -I${WRKSRC}
diff --git a/audio/aureal-kmod/files/patch-au88x0.c b/audio/aureal-kmod/files/patch-au88x0.c
new file mode 100644
index 000000000000..8c5b59f1c707
--- /dev/null
+++ b/audio/aureal-kmod/files/patch-au88x0.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- au88x0.c.orig Mon Jan 15 18:44:49 2001
++++ au88x0.c Mon Jan 15 18:44:49 2001
+@@ -32,7 +32,7 @@
+ */
+
+ #include <dev/sound/pcm/sound.h>
+-#include <dev/sound/pci/au88x0.h>
++#include "au88x0.h"
+
+ #include <pci/pcireg.h>
+ #include <pci/pcivar.h>
diff --git a/audio/aureal-kmod/pkg-comment b/audio/aureal-kmod/pkg-comment
new file mode 100644
index 000000000000..b754b1b52cd9
--- /dev/null
+++ b/audio/aureal-kmod/pkg-comment
@@ -0,0 +1 @@
+A FreeBSD Driver for Aureal Vortex based soundcards
diff --git a/audio/aureal-kmod/pkg-descr b/audio/aureal-kmod/pkg-descr
new file mode 100644
index 000000000000..069914179cf3
--- /dev/null
+++ b/audio/aureal-kmod/pkg-descr
@@ -0,0 +1,3 @@
+FreeBSD Driver for Aureal Vortex based soundcards.
+
+WWW: http://www.cis.ohio-state.edu/~matey/au88x0/
diff --git a/audio/aureal-kmod/pkg-message b/audio/aureal-kmod/pkg-message
new file mode 100644
index 000000000000..e6dee4bc3e84
--- /dev/null
+++ b/audio/aureal-kmod/pkg-message
@@ -0,0 +1,23 @@
+-------------------------------------------------------------------------------
+You can load the module by typing (as root of course):
+
+# kldload %%PREFIX%%/lib/au88x0/snd_au88X0.ko
+
+where X is 1, 2 or 3 depending on which Auread chipset do you have - au8810,
+au8820 or au8830 correspondingly.
+
+Please note that you are also need to have a `snd_pcm.ko' module either already
+loaded or placed into appropriate location for modules on your system (default
+is /modules/ on 4-STABLE and /boot/kernel/ on 5-CURRENT). You can compile and
+install snd_pcm by doing:
+
+# cd /sys/modules/sound/pcm/ && make all install
+
+Please also note that module for 4-STABLE system is untested, so please use it
+with caution and if possible please report if it work for you or not to
+Maxim Sobolev <sobomax@FreeBSD.org>.
+
+Thanks and enjoy!
+
+-Maxim
+-------------------------------------------------------------------------------
diff --git a/audio/aureal-kmod/pkg-plist b/audio/aureal-kmod/pkg-plist
new file mode 100644
index 000000000000..168d6b9cf81b
--- /dev/null
+++ b/audio/aureal-kmod/pkg-plist
@@ -0,0 +1,4 @@
+lib/au88x0/snd_au8810.ko
+lib/au88x0/snd_au8820.ko
+lib/au88x0/snd_au8830.ko
+@dirrm lib/au88x0