aboutsummaryrefslogtreecommitdiff
path: root/audio/bchoppr-lv2
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-04-19 07:35:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-04-19 07:35:15 +0000
commit90fd0e4d752a14b778bf5ee4c9bb668e78c39e27 (patch)
tree6de72b7f1cd5f2abcea5c7f604de3224fa4ae213 /audio/bchoppr-lv2
parentac19f4cc96c146344e690090dd2178b47318c5c2 (diff)
downloadports-90fd0e4d752a14b778bf5ee4c9bb668e78c39e27.tar.gz
ports-90fd0e4d752a14b778bf5ee4c9bb668e78c39e27.zip
New port: audio/bchoppr-lv2: Audio stream chopping LV2 plugin
Notes
Notes: svn path=/head/; revision=532081
Diffstat (limited to 'audio/bchoppr-lv2')
-rw-r--r--audio/bchoppr-lv2/Makefile37
-rw-r--r--audio/bchoppr-lv2/distinfo3
-rw-r--r--audio/bchoppr-lv2/pkg-descr8
3 files changed, 48 insertions, 0 deletions
diff --git a/audio/bchoppr-lv2/Makefile b/audio/bchoppr-lv2/Makefile
new file mode 100644
index 000000000000..f33adb834990
--- /dev/null
+++ b/audio/bchoppr-lv2/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= bchoppr
+DISTVERSION= 1.6.0
+CATEGORIES= audio
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Audio stream chopping LV2 plugin
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
+USES= gmake gnome pkgconfig xorg
+USE_GITHUB= yes
+GH_ACCOUNT= sjaehn
+GH_PROJECT= BChoppr
+USE_GNOME= cairo
+USE_XORG= x11
+
+MAKEFILE= makefile
+
+PLIST_FILES= lib/lv2/BChoppr.lv2/BChoppr.so \
+ lib/lv2/BChoppr.lv2/BChoppr.ttl \
+ lib/lv2/BChoppr.lv2/BChoppr_GUI.so \
+ lib/lv2/BChoppr.lv2/manifest.ttl \
+ lib/lv2/BChoppr.lv2/surface.png
+
+post-install:
+ @${RM} ${STAGEDIR}${PREFIX}/lib/lv2/BChoppr.lv2/LICENSE
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lv2/BChoppr.lv2/BChoppr*.so
+
+.include <bsd.port.mk>
diff --git a/audio/bchoppr-lv2/distinfo b/audio/bchoppr-lv2/distinfo
new file mode 100644
index 000000000000..ca482c213c2a
--- /dev/null
+++ b/audio/bchoppr-lv2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1587281352
+SHA256 (sjaehn-BChoppr-1.6.0_GH0.tar.gz) = 06fbc6f0e25150ceb0532a95f4076678661841baec821722de6cc174761f001a
+SIZE (sjaehn-BChoppr-1.6.0_GH0.tar.gz) = 717264
diff --git a/audio/bchoppr-lv2/pkg-descr b/audio/bchoppr-lv2/pkg-descr
new file mode 100644
index 000000000000..bc41111ee523
--- /dev/null
+++ b/audio/bchoppr-lv2/pkg-descr
@@ -0,0 +1,8 @@
+The plugin slices a stereo input stream, amplifies or silences the individual
+slices and send the whole sequence to the output. Although this affects only the
+audio signal, it needs a playback running (Jack transport).
+
+In addition to the global controllers, the interface is divided into three
+parts: step controls, monitor and step shape.
+
+WWW: https://github.com/sjaehn/BChoppr