aboutsummaryrefslogtreecommitdiff
path: root/audio/blop/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-05-01 21:02:51 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-05-01 21:02:51 +0000
commit4b32a0c05543bbe9b118e0f5ffb5b008397856c8 (patch)
treeaf851536a3da593e8ee4ce443b22d15adc89d120 /audio/blop/Makefile
parent21c6bef5c952ca3410a25a88d9d496083eb7221e (diff)
downloadports-4b32a0c05543bbe9b118e0f5ffb5b008397856c8.tar.gz
ports-4b32a0c05543bbe9b118e0f5ffb5b008397856c8.zip
Update to 0.2.7
USE_GETOPT_LONG PR: 51510 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Notes
Notes: svn path=/head/; revision=79959
Diffstat (limited to 'audio/blop/Makefile')
-rw-r--r--audio/blop/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/audio/blop/Makefile b/audio/blop/Makefile
index 2657c18f4be6..ed04c1c37703 100644
--- a/audio/blop/Makefile
+++ b/audio/blop/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= blop
-PORTVERSION= 0.2.6
+PORTVERSION= 0.2.7
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,16 +14,19 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Bandlimited oscillator plugins for LADSPA-aware audio applications
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
-.if !exists(/usr/include/getopt.h)
-LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
-CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -lgnugetopt"
-.endif
+USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=
-CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL} \
- --with-ladspa-prefix="${LOCALBASE}"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-ladspa-prefix="${LOCALBASE}"
+
+post-patch:
+ @${REINPLACE_CMD} 's|-pipe -Wall -O3 |\$$CFLAGS |g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|\$$(LIBS)|\$$(LIBS) \$$(LDFLAGS)|g ; \
+ s|-lc | |g'
pre-build:
cd ${WRKSRC}/src; ${GMAKE} sawtooth_data.h square_data.h parabola_data.h