aboutsummaryrefslogtreecommitdiff
path: root/audio/bshapr-lv2/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-11-30 21:37:41 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-11-30 21:37:41 +0000
commita82de362b0bdd036d5d2c9bbb29970808ee3252d (patch)
tree416e0fd0fd144181c16c5afd35b9b842b0978a25 /audio/bshapr-lv2/Makefile
parent5383e472768bd75d9d621928d46afad43fc97635 (diff)
downloadports-a82de362b0bdd036d5d2c9bbb29970808ee3252d.tar.gz
ports-a82de362b0bdd036d5d2c9bbb29970808ee3252d.zip
New port: audio/bshapr-lv2: Beat/envelope shaper LV2 plugin
Notes
Notes: svn path=/head/; revision=518730
Diffstat (limited to 'audio/bshapr-lv2/Makefile')
-rw-r--r--audio/bshapr-lv2/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/bshapr-lv2/Makefile b/audio/bshapr-lv2/Makefile
new file mode 100644
index 000000000000..4707aab6d196
--- /dev/null
+++ b/audio/bshapr-lv2/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= bshapr
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.6
+CATEGORIES= audio
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Beat/envelope shaper LV2 plugin
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+
+USES= gmake gnome pkgconfig xorg
+USE_GITHUB= yes
+GH_ACCOUNT= sjaehn
+GH_PROJECT= BShapr
+USE_GCC= any # clang fails to compile BShapr: https://github.com/sjaehn/BShapr/issues/9
+USE_GNOME= cairo
+USE_XORG= x11
+
+MAKEFILE= makefile
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lv2/BShapr.lv2/*.so
+
+.include <bsd.port.mk>