aboutsummaryrefslogtreecommitdiff
path: root/audio/csound/files
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-12-12 19:57:07 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-12-12 19:57:07 +0000
commitd1bf378aa017f2d0890a89bad5f70d26d1496bee (patch)
treec4da63ee2bba982d4ba798ea29fbc557d46868a8 /audio/csound/files
parentf748db01eef4adb5b7a49613b66fa8828582c8be (diff)
downloadports-d1bf378aa017f2d0890a89bad5f70d26d1496bee.tar.gz
ports-d1bf378aa017f2d0890a89bad5f70d26d1496bee.zip
audio/csound: 6.12.2 -> 6.12.2-83
Reported by: GH issue notification
Notes
Notes: svn path=/head/; revision=487322
Diffstat (limited to 'audio/csound/files')
-rw-r--r--audio/csound/files/patch-CMakeLists.txt12
-rw-r--r--audio/csound/files/patch-cmake_Modules_FindFAUST.cmake6
2 files changed, 10 insertions, 8 deletions
diff --git a/audio/csound/files/patch-CMakeLists.txt b/audio/csound/files/patch-CMakeLists.txt
index 2d6f0f93e3dd..17afbd946d21 100644
--- a/audio/csound/files/patch-CMakeLists.txt
+++ b/audio/csound/files/patch-CMakeLists.txt
@@ -1,4 +1,4 @@
---- CMakeLists.txt.orig 2018-11-07 14:05:23 UTC
+--- CMakeLists.txt.orig 2018-12-12 19:23:43 UTC
+++ CMakeLists.txt
@@ -164,8 +164,8 @@ endif()
@@ -35,7 +35,7 @@
set(LINUX YES)
else()
set(LINUX NO)
-@@ -527,15 +527,17 @@ find_package(FLTK )
+@@ -527,9 +527,11 @@ find_package(FLTK )
# LIST_REPLACE(FLTK_LIBRARIES 2 "fltk_images_SHARED")
# endif()
#endif()
@@ -43,13 +43,15 @@
-find_package(Java)
-find_package(JNI)
+if (BUILD_FAUST_OPCODES)
-+ find_package(FAUST)
++ find_package(FAUST)
+endif()
+#find_package(Java)
+#find_package(JNI)
find_package(LIBLO)
find_package(LUAJIT)
find_package(MUSICXML)
+@@ -540,7 +542,7 @@ find_package(MUSICXML)
+
find_package(PORTSMF)
find_package(PythonLibs 2.7)
-if(NOT STK_LOCAL)
@@ -57,7 +59,7 @@
find_package(STK)
endif()
find_package(SWIG)
-@@ -1245,11 +1247,11 @@ if(CURL_FOUND)
+@@ -1251,11 +1253,11 @@ if(USE_CURL AND CURL_FOUND)
endif()
# Linux does not have a separate libintl, it is part of libc
@@ -71,7 +73,7 @@
list(APPEND libcsound_LIBS ${LIBINTL_LIBRARY})
endif()
list(APPEND libcsound_CFLAGS -DGNU_GETTEXT)
-@@ -1269,8 +1271,8 @@ endif()
+@@ -1275,8 +1277,8 @@ endif()
if(LINUX)
message(STATUS "Building on Linux.")
diff --git a/audio/csound/files/patch-cmake_Modules_FindFAUST.cmake b/audio/csound/files/patch-cmake_Modules_FindFAUST.cmake
index 40e45b4557cc..d554b2cd42c1 100644
--- a/audio/csound/files/patch-cmake_Modules_FindFAUST.cmake
+++ b/audio/csound/files/patch-cmake_Modules_FindFAUST.cmake
@@ -1,4 +1,4 @@
---- cmake/Modules/FindFAUST.cmake.orig 2018-11-17 16:56:13 UTC
+--- cmake/Modules/FindFAUST.cmake.orig 2018-12-12 19:23:43 UTC
+++ cmake/Modules/FindFAUST.cmake
@@ -27,7 +27,7 @@ if(FAUST_FOUND)
# This is a static build of faust, hence
@@ -7,5 +7,5 @@
- find_program(LLVM_CONFIG llvm-config HINTS /usr/bin /usr/local/bin /usr/local/opt/llvm/bin)
+ find_program(LLVM_CONFIG llvm-config${FAUST_LLVM_VERSION} HINTS /usr/bin /usr/local/bin /usr/local/opt/llvm/bin)
if(NOT LLVM_CONFIG)
- message(FATAL_ERROR "Using a static Faust library requires LLVM tooling to be present in the path")
- endif()
+ message(WARNING "Using a static Faust library requires LLVM tooling to be present in the path.")
+ UNSET(FAUST_FOUND)