aboutsummaryrefslogtreecommitdiff
path: root/audio/csound
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2002-07-15 00:11:09 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2002-07-15 00:11:09 +0000
commit333094fc31f6859b99782ea410a77ef28f10dc13 (patch)
treeaf75f82ea8b21e4a034b103d835926c05b0eef20 /audio/csound
parent910adbdbcde297ee102ab08dc86c778c13c33019 (diff)
downloadports-333094fc31f6859b99782ea410a77ef28f10dc13.tar.gz
ports-333094fc31f6859b99782ea410a77ef28f10dc13.zip
Update to 4.20.
Submitted by: Emil Mikulic
Notes
Notes: svn path=/head/; revision=62951
Diffstat (limited to 'audio/csound')
-rw-r--r--audio/csound/Makefile2
-rw-r--r--audio/csound/distinfo2
-rw-r--r--audio/csound/files/patch-LINUXaudio.c20
-rw-r--r--audio/csound/files/patch-Makefile54
-rw-r--r--audio/csound/files/patch-anal_adsyn_makef27
-rw-r--r--audio/csound/files/patch-anal_lpc_makef16
-rw-r--r--audio/csound/files/patch-anal_pvoc_makef16
-rw-r--r--audio/csound/files/patch-aops.c12
-rw-r--r--audio/csound/files/patch-dpwelib.h13
-rw-r--r--audio/csound/files/patch-main_c29
-rw-r--r--audio/csound/files/patch-midirecv_c11
-rw-r--r--audio/csound/files/patch-midisend.c13
-rw-r--r--audio/csound/files/patch-pvoc.c13
-rw-r--r--audio/csound/files/patch-soundin.c12
-rw-r--r--audio/csound/files/patch-util1_cscore_makef22
-rw-r--r--audio/csound/files/patch-util2_dnoise.dir_makef24
16 files changed, 219 insertions, 67 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index 38f48f9fa5b3..8a87887271fd 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= csound
-PORTVERSION= 4.16
+PORTVERSION= 4.20
CATEGORIES= audio
MASTER_SITES= ftp://sunsite.univie.ac.at/pub/sound/csound/newest/ \
ftp://ftp.cs.bath.ac.uk/pub/dream/newest/
diff --git a/audio/csound/distinfo b/audio/csound/distinfo
index ddf83fe15614..a9669efc8029 100644
--- a/audio/csound/distinfo
+++ b/audio/csound/distinfo
@@ -1 +1 @@
-MD5 (csound/Csound4.16.tar.gz) = 393b6ed0385fac1b0517e92effb30944
+MD5 (csound/Csound4.20.tar.gz) = ee138e85b866fd87244df7e2d127ed3c
diff --git a/audio/csound/files/patch-LINUXaudio.c b/audio/csound/files/patch-LINUXaudio.c
new file mode 100644
index 000000000000..d5e4e0c09684
--- /dev/null
+++ b/audio/csound/files/patch-LINUXaudio.c
@@ -0,0 +1,20 @@
+$FreeBSD$
+
+--- LINUXaudio.c.orig Sun Jul 14 16:03:01 2002
++++ LINUXaudio.c Sun Jul 14 16:02:48 2002
+@@ -89,6 +89,7 @@ void setsndparms( int dspfd, int format,
+ warning(errmsg);
+ }
+
++#ifndef __FreeBSD__
+ /* set DMA buffer fragment size to Csound's output buffer size */
+ parm = 0; frag_size = 1;
+ /* find least power of 2 >= bufsiz */
+@@ -101,7 +102,6 @@ void setsndparms( int dspfd, int format,
+ if (ioctl(dspfd, SNDCTL_DSP_SETFRAGMENT, &parm) == -1)
+ die(Str(X_755,"failed while trying to set soundcard DMA buffer size"));
+
+-#ifndef FREE_BSD
+ /* find out what buffer size the driver allocated */
+ if (ioctl(dspfd, SNDCTL_DSP_GETBLKSIZE, &parm) == -1)
+ die(Str(X_754,"failed while querying soundcard about buffer size"));
diff --git a/audio/csound/files/patch-Makefile b/audio/csound/files/patch-Makefile
index 5dd47f12a77c..6cf719724657 100644
--- a/audio/csound/files/patch-Makefile
+++ b/audio/csound/files/patch-Makefile
@@ -1,17 +1,18 @@
---- Makefile.orig Sat Dec 8 08:00:11 2001
-+++ Makefile Tue Jan 22 16:15:27 2002
-@@ -1,18 +1,18 @@
+$FreeBSD$
+
+--- Makefile.orig Sun Jul 14 16:03:01 2002
++++ Makefile Sun Jul 14 16:49:45 2002
+@@ -1,17 +1,17 @@
# Csound Makefile
# edit the following definitions according to need:
-INCLUDE = /usr/local/include
-LIB = /usr/local/lib
-DEST = /usr/local/bin
+-MAN = /usr/local/man
+INCLUDE = $(PREFIX)/include
+LIB = $(PREFIX)/lib
+DEST = $(PREFIX)/bin
- SHARE = /usr/share/csound
--MAN = /usr/local/man
+MAN = $(PREFIX)/man
MAN1 = $(MAN)/man1
CAT1 = $(MAN)/cat1
@@ -24,36 +25,34 @@
# choose either -
# CDEP = for UNIX
# COBS = $(COBJS)
-@@ -24,7 +24,8 @@
+@@ -23,7 +23,7 @@
# .c.o:
# $(CC) $(CFLAGS) -c $*.c -o $@
--DEFINES = -DWINDOWS -DRTAUDIO -DSFIRCAM -DSYS5 -DLINUX -DPIPES -DMACROS -DTCLTK
-+DEFINES = -DWINDOWS -DRTAUDIO -DSFIRCAM -DSYS5 -DPIPES -DMACROS -DLINUX -DFREE_BSD -DTCLTK
-+
+-DEFINES = -DWINDOWS -DRTAUDIO -DSFIRCAM -DSYS5 -DLINUX -DPIPES -DMACROS -DTCLTK -DIV_SCHED -DRWD_DBFS
++DEFINES = -DRTAUDIO -DSFIRCAM -DSYS5 -DLINUX -DPIPES -DMACROS -DTCLTK -DIV_SCHED -DRWD_DBFS -DFREE_BSD
# choose any of -
# -DSYS5 invoke System 5 headers (e.g. 'string.h' for 'strings.h')
# -DWINDOWS include window system calls (X11, SGI, or FG graphics)
-@@ -52,7 +53,8 @@
- # Be sure to include 'LINUXaudio.o' under 'AUDOBJ' below as well.
- # -- Jonathan Mohr 1995 Oct 17
+@@ -49,7 +49,7 @@
+ # (e.g., Linux on SPARC [not tested]), you should also define -
+ # -DLINUX_BE Linux audio device handler for big-endian samples
--CFLAGS = -O2 -march=i686 -malign-loops=4 -malign-jumps=4 -DWITHx87 $(RPM_OPT_FLAGS) $(DEFINES)
+-CFLAGS = -O2 -malign-loops=4 -malign-jumps=4 -ffast-math -fomit-frame-pointer -finline-functions -funroll-loops -DWITHx87 $(RPM_OPT_FLAGS) $(DEFINES)
+CFLAGS = $(CPPFLAGS) $(LDFLAGS) $(DEFINES)
-+
# -O Simple optimisation
# -O2 to be more specific about the optimization level
# -f compile single-precision floats (4.3,VAX,DEC-RISC)
-@@ -76,7 +78,7 @@
+@@ -84,7 +84,7 @@
# -I/usr/openwin/include Solaris openwin interface
# -I/usr/demo/SOUND/include Solaris sound interface
-
+ # -I/usr/X11R6/include non-RedHat distributions of Linux
-LIBS = -L /usr/X11R6/lib -lX11 -ltcl -ltk -lm
+LIBS = -L$(X11BASE)/lib -L$(LOCALBASE)/lib -lX11 -ltcl83 -ltk83 -lm
# -lefence
# -lm required
# -lX11 for X window calls
-@@ -242,7 +244,7 @@
+@@ -255,7 +255,7 @@
all: $(PROGS) $(SUBDIRS) #must be run in this order
csound: $(COBJS) $(CSUM) $(CDEP) csound.xmg
@@ -62,24 +61,3 @@
TAGS: $(CSRCS) $(HDRS)
etags $(CSRCS) $(HDRS)
-@@ -341,13 +343,13 @@
- cd midifils; rm -f *.bak *~
- cd cscofils; rm -f *.bak *~
-
--CSLinux.bin.tgz: /usr/local/bin/csound /usr/local/bin/hetro \
-- /usr/local/bin/lpanal /usr/local/bin/pvanal /usr/local/bin/scot \
-- /usr/local/bin/scsort /usr/local/bin/extract /usr/local/bin/sndinfo \
-- /usr/local/bin/scale /usr/local/bin/mixer /usr/local/bin/extractor \
-- /usr/local/bin/envext /usr/local/bin/pvlook /usr/local/bin/sdif2ad \
-- /usr/local/bin/dnoise /usr/local/bin/srconv
-- (cd /usr/local/bin; tar cvzf ~/csound/CSLinux.bin.tgz csound \
-+CSLinux.bin.tgz: ${PREFIX}/bin/csound ${PREFIX}/bin/hetro \
-+ ${PREFIX}/bin/lpanal ${PREFIX}/bin/pvanal ${PREFIX}/bin/scot \
-+ ${PREFIX}/bin/scsort ${PREFIX}/bin/extract ${PREFIX}/bin/sndinfo \
-+ ${PREFIX}/bin/scale ${PREFIX}/bin/mixer ${PREFIX}/bin/extractor \
-+ ${PREFIX}/bin/envext ${PREFIX}/bin/pvlook ${PREFIX}/bin/sdif2ad \
-+ ${PREFIX}/bin/dnoise ${PREFIX}/bin/srconv
-+ (cd ${PREFIX}/bin; tar cvzf ~/csound/CSLinux.bin.tgz csound \
- hetro lpanal pvanal scot scsort extract sndinfo scale mixer \
- extractor envext pvlook sdif2ad dnoise srconv)
-
diff --git a/audio/csound/files/patch-anal_adsyn_makef b/audio/csound/files/patch-anal_adsyn_makef
new file mode 100644
index 000000000000..8a79dc534a22
--- /dev/null
+++ b/audio/csound/files/patch-anal_adsyn_makef
@@ -0,0 +1,27 @@
+$FreeBSD$
+
+--- anal/adsyn/makef.orig Sun Jul 14 16:02:48 2002
++++ anal/adsyn/makef Sun Jul 14 16:02:48 2002
+@@ -6,9 +6,11 @@ T = ../..
+
+ OBJS = main.o $T/hetro.o $T/filopen.o $T/sfheader.o $T/soundin.o \
+ $T/ulaw.o $T/aiff.o $T/ieee80.o $T/memalloc.o $T/wave.o \
+- $T/window.o $T/winX11.o $T/winEPS.o $T/aifc.o $T/winascii.o \
++ $T/window.o $T/winEPS.o $T/aifc.o $T/winascii.o \
+ $T/sdif.o $T/sdif-mem.o $T/getstring.o
+
++# $T/window.o $T/winX11.o $T/winEPS.o $T/aifc.o $T/winascii.o \
++
+ adsyns: hetro
+
+ hetro: $(OBJS)
+@@ -23,7 +25,7 @@ main.o: $T/ustub.h $T/cs.h main.c
+ cc $(CFLAGS) -c main.c
+
+ clean:
+- -rm -f hetro
++ -rm -f hetro *.o
+
+ rmbak:
+- -rm *.bak *~
++ -rm -f *.bak *~
diff --git a/audio/csound/files/patch-anal_lpc_makef b/audio/csound/files/patch-anal_lpc_makef
new file mode 100644
index 000000000000..851b649dee25
--- /dev/null
+++ b/audio/csound/files/patch-anal_lpc_makef
@@ -0,0 +1,16 @@
+$FreeBSD$
+
+--- anal/lpc/makef.orig Sun Jul 14 16:02:49 2002
++++ anal/lpc/makef Sun Jul 14 16:02:48 2002
+@@ -6,8 +6,10 @@ T = ../..
+
+ OBJS = main.o $T/lpanal.o $T/lptrkfns.o $T/filopen.o $T/sfheader.o \
+ $T/soundin.o $T/ulaw.o $T/aiff.o $T/wave.o $T/ieee80.o \
+- $T/memalloc.o $T/window.o $T/winX11.o $T/winascii.o $T/winEPS.o \
++ $T/memalloc.o $T/window.o $T/winascii.o $T/winEPS.o \
+ $T/aifc.o $T/getstring.o
++
++# $T/memalloc.o $T/window.o $T/winX11.o $T/winascii.o $T/winEPS.o \
+
+ lpcs: lpanal
+
diff --git a/audio/csound/files/patch-anal_pvoc_makef b/audio/csound/files/patch-anal_pvoc_makef
new file mode 100644
index 000000000000..4926a26bc0ba
--- /dev/null
+++ b/audio/csound/files/patch-anal_pvoc_makef
@@ -0,0 +1,16 @@
+$FreeBSD$
+
+--- anal/pvoc/makef.orig Sun Jul 14 16:02:49 2002
++++ anal/pvoc/makef Sun Jul 14 16:02:49 2002
+@@ -7,8 +7,10 @@ T = ../..
+ OBJS = main.o $T/pvanal.o $T/pvxanal.o $T/pvfileio.o $T/filopen.o \
+ $T/sfheader.o $T/mxfft.o \
+ $T/soundin.o $T/ulaw.o $T/aiff.o $T/wave.o $T/ieee80.o $T/memalloc.o \
+- $T/pvoc.o $T/fft.o $T/dsputil.o $T/window.o $T/winX11.o $T/winascii.o \
++ $T/pvoc.o $T/fft.o $T/dsputil.o $T/window.o $T/winascii.o \
+ $T/winEPS.o $T/aifc.o $T/getstring.o
++
++# $T/pvoc.o $T/fft.o $T/dsputil.o $T/window.o $T/winX11.o $T/winascii.o \
+
+ pvocs: pvanal
+
diff --git a/audio/csound/files/patch-aops.c b/audio/csound/files/patch-aops.c
index 0dd3e34b94d1..04e4b099ea0d 100644
--- a/audio/csound/files/patch-aops.c
+++ b/audio/csound/files/patch-aops.c
@@ -1,11 +1,13 @@
---- aops.c.orig Thu Jan 4 03:48:26 2001
-+++ aops.c Thu Mar 15 06:26:31 2001
+$FreeBSD$
+
+--- aops.c.orig Sun Jul 14 16:03:01 2002
++++ aops.c Sun Jul 14 16:02:49 2002
@@ -1,3 +1,4 @@
+#include <sys/time.h>
- #include "cs.h" /* AOPS.C */
+ #include "cs.h" /* AOPS.C */
#include "aops.h"
- #include <math.h>
-@@ -421,8 +422,6 @@
+ #include <math.h>
+@@ -442,8 +443,6 @@ void ftsr(EVAL *p) /**** ft
#ifdef LINUX
void rtclock(EVAL *p)
{
diff --git a/audio/csound/files/patch-dpwelib.h b/audio/csound/files/patch-dpwelib.h
new file mode 100644
index 000000000000..b3e2c56a27a2
--- /dev/null
+++ b/audio/csound/files/patch-dpwelib.h
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- dpwelib.h.orig Sun Jul 14 16:03:01 2002
++++ dpwelib.h Sun Jul 14 16:02:51 2002
+@@ -56,7 +56,7 @@
+ #else /* ultrix, not NeXT */
+ #ifdef clipper
+ #else
+-# if defined(LATTICE) || defined(WIN32) || defined(SGI)
++# if defined(LATTICE) || defined(WIN32) || defined(SGI) || defined(__FreeBSD__)
+ # include <stdlib.h>
+ # else
+ # include <unistd.h>
diff --git a/audio/csound/files/patch-main_c b/audio/csound/files/patch-main_c
index 3fd7558b90a8..76467b981e7c 100644
--- a/audio/csound/files/patch-main_c
+++ b/audio/csound/files/patch-main_c
@@ -1,13 +1,20 @@
---- main.c.orig Sat Feb 24 14:16:18 2001
-+++ main.c Mon Apr 9 23:04:12 2001
-@@ -150,10 +150,6 @@
+$FreeBSD$
+
+--- main.c.orig Sat Jun 1 19:42:24 2002
++++ main.c Thu Jul 4 19:32:12 2002
+@@ -92,12 +92,15 @@
+ return;
}
- }
--void psignal(int sig, char *str)
--{
-- fprintf(stderr, "%s: %s\n", str, signal_to_string(sig));
--}
- #endif
-
- #if defined(__BEOS__)
++#ifndef __FreeBSD__
+ /* lock all pages into physical memory */
+ if (mlockall(MCL_CURRENT | MCL_FUTURE) != 0) {
+ fprintf(stderr, "csound: cannot lock memory pages: %s\n",
+ strerror(errno));
+ exit(-1);
+ }
++#endif
++
+ /* set round robin mode with max. priority */
+ p.sched_priority = sched_get_priority_max(SCHED_RR);
+ if (sched_setscheduler(0, SCHED_RR, &p) != 0) {
diff --git a/audio/csound/files/patch-midirecv_c b/audio/csound/files/patch-midirecv_c
deleted file mode 100644
index 0ebee1e959d4..000000000000
--- a/audio/csound/files/patch-midirecv_c
+++ /dev/null
@@ -1,11 +0,0 @@
---- midirecv.c.orig Fri Aug 18 19:09:11 2000
-+++ midirecv.c Wed Oct 11 16:00:18 2000
-@@ -3,6 +3,8 @@
- #include "midiops.h"
- #include "oload.h"
-
-+#include <sys/ioctl_compat.h>
-+#undef SGI
- #ifdef SGI
- # include <sys/termio.h>
- # include <sys/stropts.h>
diff --git a/audio/csound/files/patch-midisend.c b/audio/csound/files/patch-midisend.c
new file mode 100644
index 000000000000..6ffaeccaf34e
--- /dev/null
+++ b/audio/csound/files/patch-midisend.c
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- midisend.c.orig Sun Jul 14 16:03:01 2002
++++ midisend.c Sun Jul 14 16:02:53 2002
+@@ -16,7 +16,7 @@
+ #include <ctype.h>
+ #include <sys/ioctl.h>
+ #include <fcntl.h>
+-#ifdef FREE_BSD
++#ifdef __FreeBSD__
+ # include <sys/soundcard.h>
+ #else
+ # include <linux/soundcard.h>
diff --git a/audio/csound/files/patch-pvoc.c b/audio/csound/files/patch-pvoc.c
new file mode 100644
index 000000000000..0290cc4b9827
--- /dev/null
+++ b/audio/csound/files/patch-pvoc.c
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- pvoc.c.orig Sun Jul 14 16:03:01 2002
++++ pvoc.c Sun Jul 14 16:02:55 2002
+@@ -8,7 +8,7 @@
+ #include "sysdep.h"
+
+ #include <stdio.h>
+-#if defined(mac_classic) || defined(SYMANTEC)
++#if defined(mac_classic) || defined(SYMANTEC) || defined(__FreeBSD__)
+ # include <stdlib.h> /* for malloc() */
+ # define READMODE "rb"
+ # define WRITEMODE "wb+"
diff --git a/audio/csound/files/patch-soundin.c b/audio/csound/files/patch-soundin.c
new file mode 100644
index 000000000000..ebe4e388c8d9
--- /dev/null
+++ b/audio/csound/files/patch-soundin.c
@@ -0,0 +1,12 @@
+$FreeBSD$
+
+--- soundin.c.orig Sun Jul 14 16:03:01 2002
++++ soundin.c Sun Jul 14 16:02:57 2002
+@@ -5,6 +5,7 @@
+ /*RWD 3:2000*/
+ #ifdef RWD_DBFS
+ /* quick hack to save typing etc... */
++#undef INLONGFAC
+ #define INLONGFAC (double)long_to_dbfs
+ #else
+ #define INLONGFAC (1.0 / 65536.0) /* convert 32bit long to quasi 16 bit range */
diff --git a/audio/csound/files/patch-util1_cscore_makef b/audio/csound/files/patch-util1_cscore_makef
new file mode 100644
index 000000000000..892198b6d6f7
--- /dev/null
+++ b/audio/csound/files/patch-util1_cscore_makef
@@ -0,0 +1,22 @@
+$FreeBSD$
+
+--- util1/cscore/makef.orig Sun Jul 14 16:02:58 2002
++++ util1/cscore/makef Sun Jul 14 16:02:58 2002
+@@ -16,7 +16,7 @@ $I/cscore.h: $T/cscore.h
+ cp $T/cscore.h $I
+
+ cscore.a: $(OBJS)
+- -rm cscore.a
++ -rm -f cscore.a
+ ar q cscore.a $(OBJS)
+ -ranlib cscore.a
+
+@@ -33,7 +33,7 @@ $T/memalloc.o:
+
+
+ install: includes cscore.a
+- -rm $(LIB)/libcscore.a
++ -rm -f $(LIB)/libcscore.a
+ cp cscore.a $(LIB)/libcscore.a
+
+ clean:
diff --git a/audio/csound/files/patch-util2_dnoise.dir_makef b/audio/csound/files/patch-util2_dnoise.dir_makef
new file mode 100644
index 000000000000..4f5f2867adb0
--- /dev/null
+++ b/audio/csound/files/patch-util2_dnoise.dir_makef
@@ -0,0 +1,24 @@
+$FreeBSD$
+
+--- util2/dnoise.dir/makef.orig Sun Jul 14 16:02:59 2002
++++ util2/dnoise.dir/makef Sun Jul 14 16:02:59 2002
+@@ -36,15 +36,15 @@ srconv: $(SOBJS)
+
+ install: $(PROGS)
+ -strip $(PROGS)
+- -rm $(DEST)/dnoise
+- -rm $(DEST)/srconv
++ -rm -f $(DEST)/dnoise
++ -rm -f $(DEST)/srconv
+ cp $(PROGS) $(DEST)
+
+ clean:
+- -rm $(COBS)
++ -rm -f $(COBS)
+
+ rmbak:
+- -rm *.bak *~
++ -rm -f *.bak *~
+
+ depend:
+ gcc -M $(DEFINES) $(CSRCS) > deps