aboutsummaryrefslogtreecommitdiff
path: root/audio/csound
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2002-01-23 00:45:37 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2002-01-23 00:45:37 +0000
commit8b4b38812f0a04974c805f0e4477b9eab78080c1 (patch)
tree60be911576aa9746f3b22cdace4a1f19490f203a /audio/csound
parent77232051435a9c47dc5b36409107d532d483461d (diff)
downloadports-8b4b38812f0a04974c805f0e4477b9eab78080c1.tar.gz
ports-8b4b38812f0a04974c805f0e4477b9eab78080c1.zip
Update to 4.16.
Submitted by: Sven Petai <hadara@bsd.ee> PR: 34160 also: Use new FIND and DATADIR macros. Simplify do-install target. Add warning. The csound.txt data file has been renamed upstream to csound.xmg, so don't rename it to csound.dat. Users will know it is not a text file.
Notes
Notes: svn path=/head/; revision=53617
Diffstat (limited to 'audio/csound')
-rw-r--r--audio/csound/Makefile24
-rw-r--r--audio/csound/distinfo2
-rw-r--r--audio/csound/files/patch-Makefile44
3 files changed, 34 insertions, 36 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index 48662f07f6c6..aa2c33120408 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -6,16 +6,14 @@
#
PORTNAME= csound
-PORTVERSION= 4.13
+PORTVERSION= 4.16
CATEGORIES= audio
MASTER_SITES= ftp://ftp.maths.bath.ac.uk/pub/dream/newest/
-DISTFILES= Csound${PORTVERSION}.tar.gz
+DISTNAME= Csound${PORTVERSION}
DIST_SUBDIR= csound
-EXTRACT_ONLY= Csound${PORTVERSION}.tar.gz
MAINTAINER= trevor@FreeBSD.org
-BROKEN= "distfile was overwritten"
LIB_DEPENDS= tcl83:${PORTSDIR}/lang/tcl83 \
tk83:${PORTSDIR}/x11-toolkits/tk83
@@ -24,6 +22,7 @@ RESTRICTED= "no redistribution; no commercial use except to make music (see http
MAKE_ENV= CPPFLAGS="-I${PREFIX}/include" \
LDFLAGS="-L${PREFIX}/lib -L${LOCALBASE}/lib"
NO_WRKSUBDIR= yes
+PKGMESSAGE= ${WRKDIR}/pkg-message
PLIST= ${WRKDIR}/pkg-plist
USE_X_PREFIX= yes
@@ -32,21 +31,22 @@ pre-build:
post-build:
${RM} -f ${PLIST}
- @for i in `find ${WRKDIR} -type f -perm 755`; do \
+ for i in `find ${WRKDIR} -type f -perm 755`; do \
${ECHO} bin/`${BASENAME} $${i}` >> ${PLIST}; \
done
- ${ECHO} share/csound/csound.dat >> ${PLIST}
+ ${ECHO} share/csound/csound.xmg >> ${PLIST}
${ECHO} "@dirrm share/csound" >> ${PLIST}
+ ${ECHO} "*** WARNING ***" > ${PKGMESSAGE}
+ ${ECHO} "The sources for the csound package have not been" >> ${PKGMESSAGE}
+ ${ECHO} "thoroughly reviewed by the FreeBSD maintainer." >> ${PKGMESSAGE}
post-patch:
- ${PERL} -pi -e "s:/usr/local/lib:${PREFIX}/share/csound:g" ${WRKSRC}/getstring.c
- ${PERL} -pi -e "s:csound.txt:csound.dat:g" ${WRKSRC}/getstring.c
+ ${PERL} -pi -e "s:/usr/local/lib:${DATADIR}:g" ${WRKSRC}/getstring.c
do-install:
${MKDIR} ${PREFIX}/share/csound
- ${INSTALL_DATA} ${WRKSRC}/csound.txt ${PREFIX}/share/csound/csound.dat
- for i in `find ${WRKDIR} -type f -perm 755`; do \
- ${INSTALL_PROGRAM} $${i} ${PREFIX}/bin ; \
- done
+ ${INSTALL_DATA} ${WRKSRC}/csound.xmg ${DATADIR}/csound.xmg
+ ${FIND} ${WRKDIR} -type f -perm 755 \
+ -exec ${INSTALL_PROGRAM} {} ${PREFIX}/bin \;
.include <bsd.port.mk>
diff --git a/audio/csound/distinfo b/audio/csound/distinfo
index f44530cbf25d..ddf83fe15614 100644
--- a/audio/csound/distinfo
+++ b/audio/csound/distinfo
@@ -1 +1 @@
-MD5 (csound/Csound4.13.tar.gz) = 7edbfd63436a3d94b2e6312bb5b0e3b8
+MD5 (csound/Csound4.16.tar.gz) = 393b6ed0385fac1b0517e92effb30944
diff --git a/audio/csound/files/patch-Makefile b/audio/csound/files/patch-Makefile
index d9a9d57ae0e5..5dd47f12a77c 100644
--- a/audio/csound/files/patch-Makefile
+++ b/audio/csound/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Fri Jan 5 04:38:27 2001
-+++ Makefile Sun Jan 21 18:52:58 2001
+--- Makefile.orig Sat Dec 8 08:00:11 2001
++++ Makefile Tue Jan 22 16:15:27 2002
@@ -1,18 +1,18 @@
# Csound Makefile
# edit the following definitions according to need:
@@ -34,34 +34,35 @@
# choose any of -
# -DSYS5 invoke System 5 headers (e.g. 'string.h' for 'strings.h')
# -DWINDOWS include window system calls (X11, SGI, or FG graphics)
-@@ -52,7 +53,7 @@
+@@ -52,7 +53,8 @@
# Be sure to include 'LINUXaudio.o' under 'AUDOBJ' below as well.
# -- Jonathan Mohr 1995 Oct 17
--CFLAGS = -O2 $(RPM_OPT_FLAGS) $(DEFINES)
-+CFLAGS += -g $(CPPFLAGS) $(DEFINES) $(LDFLAGS)
+-CFLAGS = -O2 -march=i686 -malign-loops=4 -malign-jumps=4 -DWITHx87 $(RPM_OPT_FLAGS) $(DEFINES)
++CFLAGS = $(CPPFLAGS) $(LDFLAGS) $(DEFINES)
++
# -O Simple optimisation
# -O2 to be more specific about the optimization level
# -f compile single-precision floats (4.3,VAX,DEC-RISC)
-@@ -73,7 +74,7 @@
+@@ -76,7 +78,7 @@
# -I/usr/openwin/include Solaris openwin interface
# -I/usr/demo/SOUND/include Solaris sound interface
--LIBS = -L /usr/X11R6/lib -lX11 -lbsd -ltcl -ltk -lm
-+LIBS = -L$(X11BASE)/lib -L$(LOCALBASE)/lib -lX11 -ltcl83 -ltk83 -lm
+-LIBS = -L /usr/X11R6/lib -lX11 -ltcl -ltk -lm
++LIBS = -L$(X11BASE)/lib -L$(LOCALBASE)/lib -lX11 -ltcl83 -ltk83 -lm
# -lefence
# -lm required
# -lX11 for X window calls
-@@ -236,7 +237,7 @@
+@@ -242,7 +244,7 @@
all: $(PROGS) $(SUBDIRS) #must be run in this order
- csound: $(COBJS) $(CSUM) $(CDEP) csound.txt
+ csound: $(COBJS) $(CSUM) $(CDEP) csound.xmg
- $(CC) $(CFLAGS) -o csound $(COBJS) $(LIBS)
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o csound $(COBJS) $(LIBS)
TAGS: $(CSRCS) $(HDRS)
etags $(CSRCS) $(HDRS)
-@@ -335,15 +336,15 @@
+@@ -341,13 +343,13 @@
cd midifils; rm -f *.bak *~
cd cscofils; rm -f *.bak *~
@@ -70,18 +71,15 @@
- /usr/local/bin/scsort /usr/local/bin/extract /usr/local/bin/sndinfo \
- /usr/local/bin/scale /usr/local/bin/mixer /usr/local/bin/extractor \
- /usr/local/bin/envext /usr/local/bin/pvlook /usr/local/bin/sdif2ad \
-- /usr/local/bin/dnoise /usr/local/bin/srconv /usr/local/lib/csound.txt
+- /usr/local/bin/dnoise /usr/local/bin/srconv
- (cd /usr/local/bin; tar cvzf ~/csound/CSLinux.bin.tgz csound \
-+CSLinux.bin.tgz: $(PREFIX)/bin/csound $(PREFIX)/bin/hetro \
-+ $(PREFIX)/bin/lpanal $(PREFIX)/bin/pvanal $(PREFIX)/bin/scot \
-+ $(PREFIX)/bin/scsort $(PREFIX)/bin/extract $(PREFIX)/bin/sndinfo \
-+ $(PREFIX)/bin/scale $(PREFIX)/bin/mixer $(PREFIX)/bin/extractor \
-+ $(PREFIX)/bin/envext $(PREFIX)/bin/pvlook $(PREFIX)/bin/sdif2ad \
-+ $(PREFIX)/bin/dnoise $(PREFIX)/lib/csound.txt
-+ (cd $(PREFIX)/bin; tar cvzf ~/csound/CSLinux.bin.tgz csound \
++CSLinux.bin.tgz: ${PREFIX}/bin/csound ${PREFIX}/bin/hetro \
++ ${PREFIX}/bin/lpanal ${PREFIX}/bin/pvanal ${PREFIX}/bin/scot \
++ ${PREFIX}/bin/scsort ${PREFIX}/bin/extract ${PREFIX}/bin/sndinfo \
++ ${PREFIX}/bin/scale ${PREFIX}/bin/mixer ${PREFIX}/bin/extractor \
++ ${PREFIX}/bin/envext ${PREFIX}/bin/pvlook ${PREFIX}/bin/sdif2ad \
++ ${PREFIX}/bin/dnoise ${PREFIX}/bin/srconv
++ (cd ${PREFIX}/bin; tar cvzf ~/csound/CSLinux.bin.tgz csound \
hetro lpanal pvanal scot scsort extract sndinfo scale mixer \
-- extractor envext pvlook sdif2ad dnoise srconv -C /usr/local/lib csound.txt)
-+ extractor envext pvlook sdif2ad dnoise -C $(PREFIX)/lib csound.txt)
+ extractor envext pvlook sdif2ad dnoise srconv)
- Csound.tar.gz: all_files \
- $(CSRCS) $(HDRS) \