aboutsummaryrefslogtreecommitdiff
path: root/audio/csound
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2003-05-03 15:56:24 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2003-05-03 15:56:24 +0000
commita7ff88b7ff18651b19998d7685a5a002471580e2 (patch)
tree625f35161ac5798456a67ffb020d3665af7ea1e6 /audio/csound
parentb55b3703f274f98a851886f21f2708dc418365b8 (diff)
downloadports-a7ff88b7ff18651b19998d7685a5a002471580e2.tar.gz
ports-a7ff88b7ff18651b19998d7685a5a002471580e2.zip
Unbreak port by updating to 4.23.
Triggered by: kris wants to remove broken ports Approved by: maintainer timeout (he hasn't much time at the moment and I want to have bugs get reported just in time to have it fixed before 5.1)
Notes
Notes: svn path=/head/; revision=80057
Diffstat (limited to 'audio/csound')
-rw-r--r--audio/csound/Makefile13
-rw-r--r--audio/csound/distinfo2
-rw-r--r--audio/csound/files/patch-LINUXaudio.c20
-rw-r--r--audio/csound/files/patch-Makefile73
-rw-r--r--audio/csound/files/patch-anal_adsyn_makef20
-rw-r--r--audio/csound/files/patch-anal_convol_makef11
-rw-r--r--audio/csound/files/patch-anal_lpc_makef15
-rw-r--r--audio/csound/files/patch-anal_pvoc_makef15
-rw-r--r--audio/csound/files/patch-aops.c8
-rw-r--r--audio/csound/files/patch-cs_h11
-rw-r--r--audio/csound/files/patch-dpwelib.h13
-rw-r--r--audio/csound/files/patch-main_c20
-rw-r--r--audio/csound/files/patch-midisend.c13
-rw-r--r--audio/csound/files/patch-pvoc.c13
-rw-r--r--audio/csound/files/patch-soundin.c12
-rw-r--r--audio/csound/files/patch-util2_dnoise_dir_dnoise_c10
-rw-r--r--audio/csound/files/patch-util2_dnoise_dir_srconv_c10
17 files changed, 131 insertions, 148 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index 0cac63c2212f..cb6b07a0dfca 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= csound
-PORTVERSION= 4.20
+PORTVERSION= 4.23
CATEGORIES= audio
MASTER_SITES= ftp://sunsite.univie.ac.at/pub/sound/csound/newest/ \
ftp://ftp.cs.bath.ac.uk/pub/dream/newest/
@@ -16,8 +16,6 @@ DIST_SUBDIR= csound
MAINTAINER= trevor@FreeBSD.org
COMMENT= Sound synthesizer
-BROKEN= "Does not fetch"
-
LIB_DEPENDS= tcl83:${PORTSDIR}/lang/tcl83 \
tk83:${PORTSDIR}/x11-toolkits/tk83
@@ -31,9 +29,10 @@ NO_WRKSUBDIR= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
PLIST= ${WRKDIR}/pkg-plist
USE_X_PREFIX= yes
+USE_REINPLACE= yes
pre-build:
- ${FIND} ${WRKDIR} -type f -exec ${CHMOD} 644 \{\} \;
+ @${FIND} ${WRKDIR} -type f -exec ${CHMOD} 644 \{\} \;
post-build:
${RM} -f ${PLIST}
@@ -47,9 +46,9 @@ post-build:
${ECHO_CMD} "thoroughly reviewed by the FreeBSD maintainer." >> ${PKGMESSAGE}
post-patch:
- ${PERL} -pi -e "s:/usr/local/lib:${DATADIR}:g" ${WRKSRC}/getstring.c
- ${FIND} ${WRKSRC} -type f -exec \
- ${PERL} -pi -e "s:<malloc.h>:<stdlib.h>:g" {} \;
+ @${REINPLACE_CMD} -i -e "s:/usr/local/lib:${DATADIR}:g" ${WRKSRC}/getstring.c
+ @${FIND} ${WRKSRC} -type f -exec \
+ ${REINPLACE_CMD} -i -e 's:<malloc.h>:<stdlib.h>:g' {} \;
do-install:
${MKDIR} ${PREFIX}/share/csound
diff --git a/audio/csound/distinfo b/audio/csound/distinfo
index a9669efc8029..964dd8a0e834 100644
--- a/audio/csound/distinfo
+++ b/audio/csound/distinfo
@@ -1 +1 @@
-MD5 (csound/Csound4.20.tar.gz) = ee138e85b866fd87244df7e2d127ed3c
+MD5 (csound/Csound4.23.tar.gz) = 194440772229410ed5f5f1bc07304d2d
diff --git a/audio/csound/files/patch-LINUXaudio.c b/audio/csound/files/patch-LINUXaudio.c
deleted file mode 100644
index d5e4e0c09684..000000000000
--- a/audio/csound/files/patch-LINUXaudio.c
+++ /dev/null
@@ -1,20 +0,0 @@
-$FreeBSD$
-
---- LINUXaudio.c.orig Sun Jul 14 16:03:01 2002
-+++ LINUXaudio.c Sun Jul 14 16:02:48 2002
-@@ -89,6 +89,7 @@ void setsndparms( int dspfd, int format,
- warning(errmsg);
- }
-
-+#ifndef __FreeBSD__
- /* set DMA buffer fragment size to Csound's output buffer size */
- parm = 0; frag_size = 1;
- /* find least power of 2 >= bufsiz */
-@@ -101,7 +102,6 @@ void setsndparms( int dspfd, int format,
- if (ioctl(dspfd, SNDCTL_DSP_SETFRAGMENT, &parm) == -1)
- die(Str(X_755,"failed while trying to set soundcard DMA buffer size"));
-
--#ifndef FREE_BSD
- /* find out what buffer size the driver allocated */
- if (ioctl(dspfd, SNDCTL_DSP_GETBLKSIZE, &parm) == -1)
- die(Str(X_754,"failed while querying soundcard about buffer size"));
diff --git a/audio/csound/files/patch-Makefile b/audio/csound/files/patch-Makefile
index 6cf719724657..2e2609fc918c 100644
--- a/audio/csound/files/patch-Makefile
+++ b/audio/csound/files/patch-Makefile
@@ -1,7 +1,5 @@
-$FreeBSD$
-
---- Makefile.orig Sun Jul 14 16:03:01 2002
-+++ Makefile Sun Jul 14 16:49:45 2002
+--- Makefile.orig Thu Apr 24 15:00:58 2003
++++ Makefile Thu Apr 24 15:03:27 2003
@@ -1,17 +1,17 @@
# Csound Makefile
# edit the following definitions according to need:
@@ -29,30 +27,77 @@ $FreeBSD$
# .c.o:
# $(CC) $(CFLAGS) -c $*.c -o $@
--DEFINES = -DWINDOWS -DRTAUDIO -DSFIRCAM -DSYS5 -DLINUX -DPIPES -DMACROS -DTCLTK -DIV_SCHED -DRWD_DBFS
-+DEFINES = -DRTAUDIO -DSFIRCAM -DSYS5 -DLINUX -DPIPES -DMACROS -DTCLTK -DIV_SCHED -DRWD_DBFS -DFREE_BSD
+-DEFINES = -DWINDOWS -DRTAUDIO -DSFIRCAM -DSYS5 -DLINUX -DPIPES -DMACROS -DTCLTK -DIV_SCHED -DHAVE_FLTK
++DEFINES = -DRTAUDIO -DSFIRCAM -DSYS5 -DLINUX -DPIPES -DMACROS -DTCLTK -DIV_SCHED -DFREE_BSD
# choose any of -
# -DSYS5 invoke System 5 headers (e.g. 'string.h' for 'strings.h')
# -DWINDOWS include window system calls (X11, SGI, or FG graphics)
-@@ -49,7 +49,7 @@
+@@ -50,7 +50,7 @@
# (e.g., Linux on SPARC [not tested]), you should also define -
# -DLINUX_BE Linux audio device handler for big-endian samples
--CFLAGS = -O2 -malign-loops=4 -malign-jumps=4 -ffast-math -fomit-frame-pointer -finline-functions -funroll-loops -DWITHx87 $(RPM_OPT_FLAGS) $(DEFINES)
+-CFLAGS = -Wall -O2 -malign-loops=4 -malign-jumps=4 -ffast-math -fomit-frame-pointer -finline-functions -funroll-loops -DWITHx87 $(RPM_OPT_FLAGS) $(DEFINES)
+CFLAGS = $(CPPFLAGS) $(LDFLAGS) $(DEFINES)
# -O Simple optimisation
# -O2 to be more specific about the optimization level
# -f compile single-precision floats (4.3,VAX,DEC-RISC)
-@@ -84,7 +84,7 @@
- # -I/usr/openwin/include Solaris openwin interface
- # -I/usr/demo/SOUND/include Solaris sound interface
- # -I/usr/X11R6/include non-RedHat distributions of Linux
--LIBS = -L /usr/X11R6/lib -lX11 -ltcl -ltk -lm
+@@ -88,14 +88,14 @@
+
+ # uncomment these if HAVE_FLTK was enabled in DEFINES
+ #
+-CXX = g++
+-CXXFLAGS = -fno-exceptions -fno-rtti
+-FLTKSRC = widgets.cpp
+-FLTKOBJ = widgets.o
++CXX ?= g++
++#CXXFLAGS = -fno-exceptions -fno-rtti
++#FLTKSRC = widgets.cpp
++#FLTKOBJ = widgets.o
+ # source and object files for FLTK widgets
+ #FLTKLIB = -lfltk -lpthread -lg++
+-FLTKLIB = /usr/local/lib/libfltk.a /usr/lib/libpthread.a \
+- /usr/lib/libstdc++-libc6.2-2.a.3
++#FLTKLIB = /usr/local/lib/libfltk.a /usr/lib/libpthread.a \
++# /usr/lib/libstdc++-libc6.2-2.a.3
+ # libraries required by widgets.cpp
+ # -lfltk -lpthread -lg++ use dynamic libraries
+ #
+@@ -105,7 +105,7 @@
+ # directiories and version
+ # numbers are system-dependent)
+
+-LIBS = $(FLTKLIB) -L /usr/X11R6/lib -lX11 -ltcl -ltk -lm -ldl
+LIBS = -L$(X11BASE)/lib -L$(LOCALBASE)/lib -lX11 -ltcl83 -ltk83 -lm
# -lefence
# -lm required
# -lX11 for X window calls
-@@ -255,7 +255,7 @@
+@@ -124,8 +124,8 @@
+ # note: SuSE 7.3 users should use -ltcl8.3 -ltk8.3, but another
+ # (probably better) solution is to create symbolic links
+
+-WINSRC = winFLTK.c FL_graph.cpp
+-WINOBJ = winFLTK.o FL_graph.o
++#WINSRC = winFLTK.c FL_graph.cpp
++#WINOBJ = winFLTK.o FL_graph.o
+ # ;if WINDOWS enabled in DEFINES, choose one of -
+ # winX11.o for X11 window graphics
+ # winSGI.o for SGI window graphics
+@@ -133,10 +133,10 @@
+ # winFLTK.o and FL_graph.o for `improved' X graphics
+ # and many others....winbor, wincwin
+
+-#AUDSRC = rtlinux.c LINUXaudio.c
+-#AUDOBJ = rtlinux.o LINUXaudio.o
+-AUDSRC = rtalsa.c
+-AUDOBJ = rtalsa.c
++AUDSRC = rtlinux.c LINUXaudio.c
++AUDOBJ = rtlinux.o LINUXaudio.o
++#AUDSRC = rtalsa.c
++#AUDOBJ = rtalsa.c
+ # ;if RTAUDIO enabled in DEFINES, include one of
+ # rtaudio.o general interface to audio handlers & libraries
+ # rtDEC.c rtSGI.c rtHP.c rtSUN.c
+@@ -283,7 +283,7 @@
all: $(PROGS) $(SUBDIRS) #must be run in this order
csound: $(COBJS) $(CSUM) $(CDEP) csound.xmg
diff --git a/audio/csound/files/patch-anal_adsyn_makef b/audio/csound/files/patch-anal_adsyn_makef
index 8a79dc534a22..c7dec2eb6554 100644
--- a/audio/csound/files/patch-anal_adsyn_makef
+++ b/audio/csound/files/patch-anal_adsyn_makef
@@ -1,21 +1,15 @@
-$FreeBSD$
-
---- anal/adsyn/makef.orig Sun Jul 14 16:02:48 2002
-+++ anal/adsyn/makef Sun Jul 14 16:02:48 2002
-@@ -6,9 +6,11 @@ T = ../..
+--- anal/adsyn/makef.orig Tue Oct 8 15:49:08 2002
++++ anal/adsyn/makef Thu Apr 24 14:49:25 2003
+@@ -6,7 +6,7 @@
OBJS = main.o $T/hetro.o $T/filopen.o $T/sfheader.o $T/soundin.o \
$T/ulaw.o $T/aiff.o $T/ieee80.o $T/memalloc.o $T/wave.o \
-- $T/window.o $T/winX11.o $T/winEPS.o $T/aifc.o $T/winascii.o \
-+ $T/window.o $T/winEPS.o $T/aifc.o $T/winascii.o \
- $T/sdif.o $T/sdif-mem.o $T/getstring.o
+- $T/window.o $T/winFLTK.o $T/FL_graph.o $T/winEPS.o $T/aifc.o \
++ $T/window.o $T/winEPS.o $T/aifc.o \
+ $T/winascii.o $T/sdif.o $T/sdif-mem.o $T/getstring.o
-+# $T/window.o $T/winX11.o $T/winEPS.o $T/aifc.o $T/winascii.o \
-+
adsyns: hetro
-
- hetro: $(OBJS)
-@@ -23,7 +25,7 @@ main.o: $T/ustub.h $T/cs.h main.c
+@@ -23,7 +23,7 @@
cc $(CFLAGS) -c main.c
clean:
diff --git a/audio/csound/files/patch-anal_convol_makef b/audio/csound/files/patch-anal_convol_makef
new file mode 100644
index 000000000000..8e91f90aa601
--- /dev/null
+++ b/audio/csound/files/patch-anal_convol_makef
@@ -0,0 +1,11 @@
+--- anal/convol/makef.orig Thu Apr 24 14:59:47 2003
++++ anal/convol/makef Thu Apr 24 15:00:08 2003
+@@ -7,7 +7,7 @@
+ OBJS = main.o $T/cvanal.o $T/fft.o $T/dsputil.o $T/filopen.o \
+ $T/sfheader.o $T/soundin.o $T/ulaw.o $T/aiff.o $T/ieee80.o \
+ $T/memalloc.o $T/wave.o $T/window.o $T/aifc.o $T/getstring.o \
+- $T/winFLTK.o $T/FL_graph.o $T/winEPS.o $T/winascii.o
++ $T/winEPS.o $T/winascii.o
+
+
+ cvl: cvanal
diff --git a/audio/csound/files/patch-anal_lpc_makef b/audio/csound/files/patch-anal_lpc_makef
index 851b649dee25..0a8a8d4d096e 100644
--- a/audio/csound/files/patch-anal_lpc_makef
+++ b/audio/csound/files/patch-anal_lpc_makef
@@ -1,16 +1,13 @@
-$FreeBSD$
-
---- anal/lpc/makef.orig Sun Jul 14 16:02:49 2002
-+++ anal/lpc/makef Sun Jul 14 16:02:48 2002
-@@ -6,8 +6,10 @@ T = ../..
+--- anal/lpc/makef.orig Tue Oct 8 15:53:00 2002
++++ anal/lpc/makef Thu Apr 24 14:51:19 2003
+@@ -6,8 +6,8 @@
OBJS = main.o $T/lpanal.o $T/lptrkfns.o $T/filopen.o $T/sfheader.o \
$T/soundin.o $T/ulaw.o $T/aiff.o $T/wave.o $T/ieee80.o \
-- $T/memalloc.o $T/window.o $T/winX11.o $T/winascii.o $T/winEPS.o \
+- $T/memalloc.o $T/window.o $T/winFLTK.o $T/winascii.o $T/winEPS.o \
+- $T/aifc.o $T/getstring.o $T/FL_graph.o
+ $T/memalloc.o $T/window.o $T/winascii.o $T/winEPS.o \
- $T/aifc.o $T/getstring.o
-+
-+# $T/memalloc.o $T/window.o $T/winX11.o $T/winascii.o $T/winEPS.o \
++ $T/aifc.o $T/getstring.o
lpcs: lpanal
diff --git a/audio/csound/files/patch-anal_pvoc_makef b/audio/csound/files/patch-anal_pvoc_makef
index 4926a26bc0ba..93bc1d64fa71 100644
--- a/audio/csound/files/patch-anal_pvoc_makef
+++ b/audio/csound/files/patch-anal_pvoc_makef
@@ -1,16 +1,13 @@
-$FreeBSD$
-
---- anal/pvoc/makef.orig Sun Jul 14 16:02:49 2002
-+++ anal/pvoc/makef Sun Jul 14 16:02:49 2002
-@@ -7,8 +7,10 @@ T = ../..
+--- anal/pvoc/makef.orig Thu Apr 24 14:53:29 2003
++++ anal/pvoc/makef Thu Apr 24 14:53:58 2003
+@@ -7,8 +7,8 @@
OBJS = main.o $T/pvanal.o $T/pvxanal.o $T/pvfileio.o $T/filopen.o \
$T/sfheader.o $T/mxfft.o \
$T/soundin.o $T/ulaw.o $T/aiff.o $T/wave.o $T/ieee80.o $T/memalloc.o \
-- $T/pvoc.o $T/fft.o $T/dsputil.o $T/window.o $T/winX11.o $T/winascii.o \
+- $T/pvoc.o $T/fft.o $T/dsputil.o $T/window.o $T/winFLTK.o $T/winascii.o \
+- $T/winEPS.o $T/aifc.o $T/getstring.o $T/FL_graph.o
+ $T/pvoc.o $T/fft.o $T/dsputil.o $T/window.o $T/winascii.o \
- $T/winEPS.o $T/aifc.o $T/getstring.o
-+
-+# $T/pvoc.o $T/fft.o $T/dsputil.o $T/window.o $T/winX11.o $T/winascii.o \
++ $T/winEPS.o $T/aifc.o $T/getstring.o
pvocs: pvanal
diff --git a/audio/csound/files/patch-aops.c b/audio/csound/files/patch-aops.c
index 04e4b099ea0d..9f9622cbebf0 100644
--- a/audio/csound/files/patch-aops.c
+++ b/audio/csound/files/patch-aops.c
@@ -8,11 +8,11 @@ $FreeBSD$
#include "aops.h"
#include <math.h>
@@ -442,8 +443,6 @@ void ftsr(EVAL *p) /**** ft
+ }
+
#ifdef LINUX
- void rtclock(EVAL *p)
- {
-#include <sys/time.h>
-#include <unistd.h>
+ void rtclock(EVAL *p)
+ {
struct timeval tv;
- struct timezone tz;
- gettimeofday(&tv, &tz);
diff --git a/audio/csound/files/patch-cs_h b/audio/csound/files/patch-cs_h
new file mode 100644
index 000000000000..efd2baaf1a78
--- /dev/null
+++ b/audio/csound/files/patch-cs_h
@@ -0,0 +1,11 @@
+--- cs.h.orig Thu Apr 24 15:09:06 2003
++++ cs.h Thu Apr 24 15:09:25 2003
+@@ -782,7 +782,7 @@
+ # define POLL_EVENTS() STasks()
+ # define __cdecl
+ #else
+-#ifdef LINUX
++#if defined(LINUX) && defined(HAVE_FLTK)
+ extern int POLL_EVENTS(void);
+ #else
+ # define POLL_EVENTS() (1)
diff --git a/audio/csound/files/patch-dpwelib.h b/audio/csound/files/patch-dpwelib.h
deleted file mode 100644
index b3e2c56a27a2..000000000000
--- a/audio/csound/files/patch-dpwelib.h
+++ /dev/null
@@ -1,13 +0,0 @@
-$FreeBSD$
-
---- dpwelib.h.orig Sun Jul 14 16:03:01 2002
-+++ dpwelib.h Sun Jul 14 16:02:51 2002
-@@ -56,7 +56,7 @@
- #else /* ultrix, not NeXT */
- #ifdef clipper
- #else
--# if defined(LATTICE) || defined(WIN32) || defined(SGI)
-+# if defined(LATTICE) || defined(WIN32) || defined(SGI) || defined(__FreeBSD__)
- # include <stdlib.h>
- # else
- # include <unistd.h>
diff --git a/audio/csound/files/patch-main_c b/audio/csound/files/patch-main_c
deleted file mode 100644
index 76467b981e7c..000000000000
--- a/audio/csound/files/patch-main_c
+++ /dev/null
@@ -1,20 +0,0 @@
-$FreeBSD$
-
---- main.c.orig Sat Jun 1 19:42:24 2002
-+++ main.c Thu Jul 4 19:32:12 2002
-@@ -92,12 +92,15 @@
- return;
- }
-
-+#ifndef __FreeBSD__
- /* lock all pages into physical memory */
- if (mlockall(MCL_CURRENT | MCL_FUTURE) != 0) {
- fprintf(stderr, "csound: cannot lock memory pages: %s\n",
- strerror(errno));
- exit(-1);
- }
-+#endif
-+
- /* set round robin mode with max. priority */
- p.sched_priority = sched_get_priority_max(SCHED_RR);
- if (sched_setscheduler(0, SCHED_RR, &p) != 0) {
diff --git a/audio/csound/files/patch-midisend.c b/audio/csound/files/patch-midisend.c
deleted file mode 100644
index 6ffaeccaf34e..000000000000
--- a/audio/csound/files/patch-midisend.c
+++ /dev/null
@@ -1,13 +0,0 @@
-$FreeBSD$
-
---- midisend.c.orig Sun Jul 14 16:03:01 2002
-+++ midisend.c Sun Jul 14 16:02:53 2002
-@@ -16,7 +16,7 @@
- #include <ctype.h>
- #include <sys/ioctl.h>
- #include <fcntl.h>
--#ifdef FREE_BSD
-+#ifdef __FreeBSD__
- # include <sys/soundcard.h>
- #else
- # include <linux/soundcard.h>
diff --git a/audio/csound/files/patch-pvoc.c b/audio/csound/files/patch-pvoc.c
deleted file mode 100644
index 0290cc4b9827..000000000000
--- a/audio/csound/files/patch-pvoc.c
+++ /dev/null
@@ -1,13 +0,0 @@
-$FreeBSD$
-
---- pvoc.c.orig Sun Jul 14 16:03:01 2002
-+++ pvoc.c Sun Jul 14 16:02:55 2002
-@@ -8,7 +8,7 @@
- #include "sysdep.h"
-
- #include <stdio.h>
--#if defined(mac_classic) || defined(SYMANTEC)
-+#if defined(mac_classic) || defined(SYMANTEC) || defined(__FreeBSD__)
- # include <stdlib.h> /* for malloc() */
- # define READMODE "rb"
- # define WRITEMODE "wb+"
diff --git a/audio/csound/files/patch-soundin.c b/audio/csound/files/patch-soundin.c
deleted file mode 100644
index ebe4e388c8d9..000000000000
--- a/audio/csound/files/patch-soundin.c
+++ /dev/null
@@ -1,12 +0,0 @@
-$FreeBSD$
-
---- soundin.c.orig Sun Jul 14 16:03:01 2002
-+++ soundin.c Sun Jul 14 16:02:57 2002
-@@ -5,6 +5,7 @@
- /*RWD 3:2000*/
- #ifdef RWD_DBFS
- /* quick hack to save typing etc... */
-+#undef INLONGFAC
- #define INLONGFAC (double)long_to_dbfs
- #else
- #define INLONGFAC (1.0 / 65536.0) /* convert 32bit long to quasi 16 bit range */
diff --git a/audio/csound/files/patch-util2_dnoise_dir_dnoise_c b/audio/csound/files/patch-util2_dnoise_dir_dnoise_c
new file mode 100644
index 000000000000..1d0cc0900b89
--- /dev/null
+++ b/audio/csound/files/patch-util2_dnoise_dir_dnoise_c
@@ -0,0 +1,10 @@
+--- util2/dnoise.dir/dnoise.c.orig Thu Apr 24 15:16:01 2003
++++ util2/dnoise.dir/dnoise.c Thu Apr 24 15:16:32 2003
+@@ -109,6 +109,7 @@
+ static long bytes = 0;
+ OPARMS O = {0,0, 0,1,1,0, 0,0, 0,0, 0,0, 1,0,0,7, 0,0,0, 0,0,0,0, 0,0 };
+
++#undef POLL_EVENTS
+ int POLL_EVENTS(void)
+ {
+ return 1;
diff --git a/audio/csound/files/patch-util2_dnoise_dir_srconv_c b/audio/csound/files/patch-util2_dnoise_dir_srconv_c
new file mode 100644
index 000000000000..afd9fc827ca8
--- /dev/null
+++ b/audio/csound/files/patch-util2_dnoise_dir_srconv_c
@@ -0,0 +1,10 @@
+--- util2/dnoise.dir/srconv.c.orig Thu Apr 24 15:17:43 2003
++++ util2/dnoise.dir/srconv.c Thu Apr 24 15:18:07 2003
+@@ -78,6 +78,7 @@
+ OPARMS O = {0,0, 0,1,1,0, 0,0, 0,0, 0,0, 1,0,0,7, 0,0,0, 0,0,0,0, 0,0 };
+
+
++#undef POLL_EVENTS
+ int POLL_EVENTS(void)
+ {
+ return 1;